Closing Lid in Linux Does not Send Sleep Signal

I have had my Framework DIY edition for a few weeks now and I noticed that closing the lid does not send a sleep signal to the computer. When the laptop detects that the lid is closed, the keyboard, power button light, and trackpad are all disabled, but the screen remains on and the computer keeps running. In the KDE power management settings, it does not have an option for ‘lid close’ actions as it should, so I think the OS doesn’t recognize that the computer has this function. Has anyone else experienced this? My secure boot is disabled. Specs Below:

OS: EndeavourOS Linux
Kernel: 5.16.10-zen (but the problem persists in the regular and LTS kernels)

Lid closing works for me using Gnome on Fedora 35. Oddly enough, the standard “settings” have an option to select what to do on the power button but not for a lid close event. Gnome Tweaktool does have an option for that.

If your system runs under systemd, it might be that /etc/systemd/logind.conf helps. The options there for me are:


and indeed, if I close the lid while plugged into my USB-C Hub Monitor, the laptop does not suspend. I haven’t changed any of the default settings on this, but perhaps this gives you some searchable terms to find more information.


Seeing the same issue, and additionally selecting “sleep” from the main menu does not actually sleep the computer either.

Sleep command from the command line does seem to work though.

Also on EndeavourOS, plasma desktop, etc

This just started happening for me on Arch Linux 5.15.24-2-lts. Closing the lid does nothing… like it doesn’t sleep or even turn off the internal display. Does anyone have ideas? It’s really annoying with a multi-monitor setup.

Edit: Seems to be a bug in the upower package:


Also experiencing this same issue like many others thanks to upower 0.99.16-1. Also on Endeavour OS on the latest lts kernel.

Thanks for the links @supernintendo, seems like this is affecting many devices from those comments, not just Frameworks. It looks like the issue has been recently fixed upstream: FD handling fixes (!121) · Merge requests · upower / upower · GitLab

Hopefully we will be seeing an update with this fix coming down to us soon.

1 Like

I just solved this problem. I saw that people had success downgrading upower (Thanks @supernintendo) and I was able to get the option back into the KDE settings by doing the following:

$ sudo pacman -Rdd upower
$ yay -S upower-git
$ reboot