Consistent Wake from Sleep Issues on Linux Edit:(5x Distros Tested)

I received my Framework yesterday, and have been rolling distros on it to try to find one that I can make friends with.

Thus far I’ve tried:

  • openSUSE Tumbleweed (KDE)
  • Pop!_OS
  • Manjaro KDE

Every single one of them has had an issue where the laptop will wake from sleep just fine if it’s a relatively short sleep (<20 min), but it hangs on sleep longer than that, and has to be forcibly rebooted.

Has anyone else experienced this problem?

2 Likes

I have only tried Ubuntu and Fedora. Deep sleep takes about 5 seconds to wake from, but other than that works just fine. I have never had the system hang on resuming from suspend.

1 Like

@BesselFunct

I’ve had lots of issues waking from sleep on Linux as well. Especially when a thunderbolt dock is attached. I have found no fix for most of them.

I did find a fix for waking up and the touchpad by disabling ps2 emulation BUT at times when I wake the touchpad will be extremely sensitive and shoot across the screen when I barely touch it. Sometimes suspending again and re-waking up will fix it but not always.

I really hope we find resolutions to these issues because it makes using Linux on the framework so frustrating. I got to the point where I put Windows on the internal which I haven’t used in years. Windows doesn’t seem to have issues waking up.

1 Like

Some googling is leading me to believe that it might be my drive. I installed a 1Tb Crucial P5 that I got a great deal on. I can’t find the thread right now, but the discussion seemed to indicate that there was something wonky with the firmware for the drive that wasn’t playing nice with Linux.

I’m going to try burning the Fedora 35 beta (after all the customization I did T_T) over my Manjaro KDE, and see if the suspend issues persist.

Hopefully that’s it. My drive was one from Framework so I wouldn’t imagine it would have any unknown issues relating to being suspended.

@nomb85 I’ve had similar issues with suspend on Linux previously, which is why I’ve usually been rocking windows on my notebooks. Granted it was ~ 7 years ago when I was trying to get it to work, but it never really got to a point where the behavior was consistent.

Never had any issues with my Linux desktops waking from sleep, which makes the whole situation a bit mystifying.

OK. I’ve tried:

  • ElementaryOS 6
  • Fedora 35 beta

in addition to the distros listed above, and both also have consistent issues with wake from sleep. At this point, I have to assume it’s the drive. I have a WD SN750 in my home desktop that currently has a borked windows install on it. I’m going to pull that and see if it fixes the issue.

Ubuntu 21.10 with the stock 5.13.20 kernel has no issues with waking from sleep. Anything 5.14 and above seems to have issues.

@Nixingit I’m pretty sure most of my testing was done with 5.13. I started my Manjaro KDE install on 5.13, and bumped it to 5.14 to see if the suspend issue persisted, and it did.

I swapped the WD SN750 I had in, and am running Pop! now. A lot of the weirdness immediately went away (there’s still some, but a lot less).

Adding "mem_sleep_default=deep" using kernel stub seems to have addressed the remaining issues? Still need to use it a little more to verify that the drive was the problem.

Oh yeah, that’s also the first thing I edited. With that, seems okay. But yeah 5.14 and above is a crap shoot.

thanks for posting this - just want to +1 that I’m also having to force reboot everytime I want to wake my framework. I’m on Manjaro Gnome.

$ cat /etc/lsb-release
DISTRIB_ID=ManjaroLinux
DISTRIB_RELEASE=21.1.6
DISTRIB_CODENAME=Pahvo
DISTRIB_DESCRIPTION="Manjaro Linux"

journalctl --boot -1 --pager-end --catalog (with Storage=persistent set in /etc/systemd/journald.conf) shows not log entries since going to the last entry when the machine went to sleep.

Here's a sample of the tail on my last boot's entry
Nov 01 19:46:54 mymachine systemd[1]: Reached target Sleep.
░░ Subject: A start job for unit sleep.target has finished successfully
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ 
░░ A start job for unit sleep.target has finished successfully.
░░ 
░░ The job identifier is 2912.
Nov 01 19:46:54 mymachine systemd[1]: Starting System Suspend...
░░ Subject: A start job for unit systemd-suspend.service has begun execution
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ 
░░ A start job for unit systemd-suspend.service has begun execution.
░░ 
░░ The job identifier is 2911.
Nov 01 19:46:54 mymachine systemd-sleep[32144]: Entering sleep state 'suspend'...
░░ Subject: System sleep state suspend entered
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ 
░░ The system has now entered the suspend sleep state.
Nov 01 19:46:54 mymachine kernel: PM: suspend entry (s2idle)

@jon What drive are you running? My sleep issues have almost completely gone away after swapping out my Crucial P5.

Oh interesting note about the drive. I ordered this laptop with the WD_BLACK™ SN850 NVMe (and then I also got an “storage” expansion slot, but that’s not the drive my OS and/or boot is on, so seems unrelated).

I don’t currently have another SSD I can use to experiment and prove/disprove a hypothesis about the SN850 being problematic, but if this issue/thread isn’t resolved in another month, then I might have an SSD by then.

@jon I’m running with a SN850 and have no problem waking my machine from sleep apart from it taking longer than it seems like it should.

Thanks Ron. Good to know - I also can confirm a couple tests today (since I posted earlier here) show I can wake from sleep due to inactivity. (and +1 that it takes a strangely long time… O(10)sec… maybe 30 seconds on last success?)

I’ll report back if lid-close’s sleep suddenly start waking without issues.

I’ll report back if lid-close’s sleep suddenly start waking without issues.

Okay this actually just happened. New hypothesis: it might have to do with being plugged into a usbc doc (external display → usbc hub → laptop) at time of sleep. This is the first time I’ve closed the lid away from my desk/hub, so hadn’t made the distinction. I’ll report back how testing with the dock goes.

The long sleep resumes seem to be with enabling mem_sleep_default=deep. Usually it’s around 10 seconds for me.

Running Manjaro KDE + the 850 ssd. I’m using the thunderbolt port of my external monitor to drive power + display + USB devices without an issue.

My only issue is SDDM/KDE related where if I yank the monitor out while the device is asleep the login manager crashes and the virtual terminals don’t always connect. So now I’m paranoid about unplugging before locking.

On my Manjaro also with the 850 I have constant wake from sleep issues. Some times it works somtimes it doesn’t. Sometimes it wakes with the touchpad way more sensitive. Sometimes it wakes to a black screen with a blinking cursor. Sometimes when it wakes it tries to shutdown and then says “cannot find shutdown binary”.

I’ve had nothing but issues with sleep and waking and using it in clamshell with a tb4 dock.

2 Likes

Just as an example I’ve been using the laptop all day today and it has awoken just fine all day. But now however, I go to use the computer and it’s not waking up. Just has a black screen and doesn’t respond at all. All I can do is hold the power button down until it turns off and force a reboot.

2 Likes

@nomb85 I’ve had issues with the touchpad not initializing if I try to provide input before the wake cycle is complete and I get a splash screen. I also had issues with shutdown previously, but they went away when I switched drives and enabled deep sleep.