Core X Razer External GPU Tips

After troubleshooting all day, If anyone has trouble with thier framework laptop crashing/freezing up when connected to a Thunderbolt external GPU make sure you are plugged in directly to the Motherboard thunderbolt connector and not the Expansion Card. I was experiencing a ton of windows issues until I figured out that in order to make it run properly it has to be connected to the empy bay’s Thunderbolt connector…

I hope this helps someone :slight_smile:

1 Like

that shouldn’t matter, the expansion cards are supposed to be passive?

Mine would not work properly plugged into the USB-C expansion card, I removed the card and the issue went away. It could be that I have a bad card or something, but plugging into the main port seemed to fix my problem.

I would not advice this. The expansion cards act as a tension break and help to ensure that the mainboard connector is not stressed. If you are rough on an expansion card it messes up only the expansion card port, and not the port on the mainboard. The same can not be said if you are connecting to the port directly soldered to the mainboard.

If you are having issues with the expansion card, have you tried another? Additionally have you tried changing the orientation of the USB C cable coming off the Core X Razer? (IE: flip the cable 180 degrees and plug it in)

1 Like

I did have this issue with my other Thunderbolt 4 laptop.

Every 10 or 20 minutes it freeze randomly while doing daily tasks (Chrome, Word document…). Tried a million solutions and this one worked for me:

While plugged with your eGPU, and there is a second monitor directly connected to the eGPU.

Open your device manager and drop down the "Display adapters“. Then Disable the integrated graphic. Run your monitors solely with your eGPU.

It worked like magic to me and I hope this worked for you as well.

1 Like

Thanks i will try these and report back, my cord is the one that came with the Core X, it is approx 1m. I have a few extra Usb-c expansion cards that I will try also and report back.

OS is windows 11, I have installed the latest firmware last night for the bios, and updated the drivers using the alpha package for Win11 so I have the latest for thunderbolt.

After reloading my OS, installing the driver pack again and replacing the USB-C cable with a beefier better grade one. It is now working through the USB expansion slot. I think the issue was most likely a bad windows 10 update that carried over to the new OS. It is working now through the Expansion Port. Thanks all


Hello, I think I’m having the same issue as you. I have a razer core attached and my machine will freeze doing random things like watching youtube. However it will have no problem playing videogames.

Was there a concrete solution?

I have updated all the firmware/drivers to the best of my knowledge

Sure, first step do this Install the Windows 10/11 Drivers from the Alpha bundle
Update the Bios if you have the Old version

The reason this might be the key, is that I think the default thunderbolt drivers with windows may not be the right ones, and this fixes that issue

Next download the Latest Nvida Drivers(if your gfx card is Nvida based)

Optional I think (just something else I did)
Next go to power options
Control Panel\Hardware and Sound\Power Options\Edit Plan Settings
Change Sleep and Display Settings to Never

Click Advanced Settings->
Change Hard Disk Settings to 0 minutes to disable turning off HDD, and plugged in =Never

PCI Express - Set both Link State Power Management Settings to Off

This may or may not be helpful to someone in the future, but when I used my Razer Chroma X (the one with the fancy lights and extra ports), it would bluescreen before it hit the desktop.
IT WORKED FINE when I used a regular razer external box (no lights or USB or crap).
I chalked it up to the extra ports and lights being generally useless.