Debian based Linux on the Framework Laptop

I installed stock Ubuntu 21.04 w/ Gnome on mine. I haven’t tried doing the fingerprint stuff yet. I’m currently on 5.11.0-31-generic.

Sadly, I haven’t yet been able to get the wifi module working on Debian 11 yet. It looks like there’s been a regression of the Intel AX210 driver in the kernel in the latest release: It’s exactly what I’ve been seeing…

1 Like

For those of who who want to install Linux Mint, consider the edge installation. You can see the documentation here: Edge ISO Images — Linux Mint User Guide documentation

The current Edge ISO image is for Mint version 20.2 and already contains the 5.11 kernel. This will prevent the user from having to connect via Ethernet to upgrade the kernel version after the standard installation process.


In case anyone’s interested, I’ve written up a (somewhat lengthy) post on getting Debian Bullseye up and running. Probably the most interesting bit is I’ve included instructions on how to build actual Debian packages for libfprint 1.92.1 and fprintd 1.92.0, which results in a cleaner install and makes removing or upgrading them later a heck of a lot easier:


As an FYI for folks, Debian Testing has now migrated to Linux 5.14.0, which means PSR should work out of the box now!

In addition, the AX210 should work, though on my own laptop Bluetooth still doesn’t work for reasons I have yet to figure out. It’s especially weird because when I stick the AX210 in my old X1 Carbon with the 5.14.0 testing kernel it works just fine. It’s only when the card is in my Framework that it doesn’t. Hopefully other folks have better luck!


Got my FW today and installed debian stable.

  1. NetInstall from the /current/ branch (dated 09/25/2021)
  2. Obtain and move linux-image-5.14*.deb and firmware-linux-nonfree (and dependencies) onto the laptop
  3. Install the new kernel image and firmware and reboot

Works great - running kernel 5.14 on Debian Stable.

Now to go through the power management/battery life threads to get it tuned for daily use.

1 Like

Eh, yeah. I am on Debian Bookworm/kernel 5.14 with the Intel firmware-iwlwifi package - looks like there’s some regression with how the bluetooth firmware interacts with the machine. I was able to get the bluetooth working by replacing the firmware included in the sid/bookworm release (20210818-1, Intel release 28502) with one that was recently updated on the linux firmware git repo (Intel release 31586, checked into the repo on Sep 19th).

Copy the sfi file into /lib/firmware/intel, then power cycle your machine (shutdown, wait about 10 seconds, power it on again). The issue here is that while the bluetooth works just fine right after the power-on, any reboot will make it disappear. Resuming from sleep (not hibernation) is just fine, though.

1 Like

Yup, confirmed here as well. TBH, this firmware is the first time I’ve seen the AX210 work with Linux 5.14 at all. But I agree, a reboot or resume from hibernation leads to Bluetooth no longer functioning.

1 Like

A quick update - I tried using bluetooth on kernel 5.14 and, surprise surprise, I ran into the ‘warm boot’ issue with Bluetooth.

So I compiled and installed 5.12.15 from and all of my problems have evaporated. I just used the same kernel configuration from my initial install with 5.10 and it built in about 45 minutes (I wasn’t timing and I was sleepy as it was finishing up).

1 Like

some notes from my install of Debian testing with i3 over an LXDE base installation:

  • xbacklight doesn’t work as expected, you need to use light instead. You’ll also need to chmod +s $(which light) after installing.
  • to get the touchpad working as expected, I added this to a file (as root) in /etc/X11/xorg.conf.d:
Section "InputClass"
	Identifier "touchpad"
	Driver "libinput"
	MatchIsTouchpad "on"
	Option "Tapping" "on"
  • the DPI is … interesting (see xdpyinfo | grep -B2 resolution for more info). To start with, I added this to a file in the same xorg.conf.d folder, again owned by root:
Section "Monitor"
	Identifier "eDP-1"
	DisplaySize 285 190

and then added a file in /etc/X11/Xresources/ (201 is actually correct, but 144 looked better to me):

Xft.dpi: 144
  • I also added this to the bottom of ~/.config/i3/config:
# needed for pkexec stuff
exec_always --no-startup-id lxpolkit
# ... no
focus_follows_mouse no
# backlight keys
bindsym XF86MonBrightnessDown exec --no-startup-id light -U 1
bindsym XF86MonBrightnessUp exec --no-startup-id light -A 1

edit: if you’re using steam, you’ll also want to run: echo "GDK_SCALE=2 steam" | sudo tee /usr/local/bin/steam && sudo chmod +x /usr/local/bin/steam to fix its DPI - it doesn’t respect X’s font DPI, just the toolkit’s scaling factor


Thank you! This was the only way I was able to get bluetooth working on my FW running Debian 11. It sucks that a soft reboot borks it, but at least it’s an easy fix.

Anyone have updates on the long term use with Debian Linux on this laptop?

Just received my \o/

On debian 11.3 GNOME installs without issue (trackpad recognized, usb-eth for network), annoying bluetooth off/on messages but solved by installing kernel from bullseye-backports (wifi then works).

Installed from sid : firmware-misc-nonfree and firmware-iwlwifi.

Also installed from sid : libfprint and libpam-fprintd and fingerprint was proposed in GNOME and works.

I’ve tested

$ cat /etc/X11/xorg.conf.d/20-touchpad.conf 

Section "InputClass"
        Identifier "touchpad"
        Driver "libinput"
        MatchIsTouchpad "on"
        Option "Tapping" "on"

but it does not solve the problem I’ve described here (Debian testing under XFCE4, verified under Debian 11.3. live installer)
Do you have any further hints?
Kind regards, Andreas.

Alternatively, per this Ask Ubuntu answer, you can add the
following to your /etc/X11/xorg.conf file (creating it if necessary):

Section "Device"
    Identifier  "Intel Graphics" 
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"

This works on my Framework (Intel 11th gen with Linux Mint and XMonad).

1 Like

Anyone have updates with Kali installed on this laptop?