Devices on USB-C Card disconnecting

I’m having a strange issue. I have a Dell USB C monitor that provides power + a usb hub. I’m on Windows 10.

The problem I’m having is that the usb devices connected to the monitor’s hub are constantly disconnecting. Video is not impacted. I did some trial and error and found that this happens only when going through a USB-C expansion card. If I bypass the expansion card and connect directly to usb-c of the mainboard, all my issues go away. I’ve tried different USB-C cards and different slots but I get the same disconnects.

Any thoughts? Do these USB-C cards affect power output?

The cards don’t impact power output, but it is possible that if signal integrity is just at the edge of working, that having the card in the signal path puts it out of spec. A couple of things to check would be:

  1. Does this happen in all Expansion Card bays on the laptop?
  2. Does it happen if you use a shorter or different USB-C cable.

Thanks for the replies.

  1. This happens in all expansion bays on the laptop
  2. Unfortunately I only have my one usb-c thunderbolt cable. I have had no issues with other laptops though (Mac, Thinkpad X1)
  3. My monitor is a Dell u3419w. Its a thunderbolt 3 monitor and supports up to 90W PD. I’m in San Diego.

I also did some more testing and:

  1. The issue becomes more apparent when I plug in another usb-c device to the laptop while I’m connected to my monitor. I used a usb-a flash drive with a usb-c dongle and Windows went crazy with its disconnecting/connecting sounds :slightly_smiling_face:
  2. The issue seems to also go away if I plug the laptop in to another power source at the same time (basically, not rely on monitor for PD)
1 Like

What happens if you plug the expansion card into one of these computers and then the Dell? Same issue?

Oh good suggestion.
I tried the expansion card on my macbook. I always had power and display but sometimes my usb devices weren’t detected on plug-in. I couldn’t reproduce it consistently.

I guess all I can try is another, shorter cable. Thanks for the help

So if I’m reading that right, even your macbook had issues with the expansion inline? It could be that expansion card then.

Shorter cable might also help (all cables are not created equally) I have 2 different USB-C docks/hubs coming next week (Of which I will try to get my 4K monitor AND PD charging working) so I can try on mine as well to see how much I can jam through USB-C expansion card :slight_smile:

Yea, the macbook had issues with expansion inline too.

Long testing post, sorry. I’ve been trying to figure this out.

So I bought a shorter 3ft certified TB4 cable and I still have issues with disconnects with the usb-c expansion card inline. I also looked into my monitor and found out its actually USB-C, not TB. It does DP 1.4 + power + usb2.0 over USB-C.

Removing the monitor entirely, I think I also replicated the issue with a USB-A 3.0 ethernet adapter attached to a 3ft USB3.0 extender (USB-A to USB-A) to a USB-A expansion card on my Framework.

  1. Initial plug-in seems to work. But once I unplug the USB-A cable and reconnect it to the same slot, the ethernet adapter either randomly disconnects, doesn’t get detected, or I don’t have internet access (I’m guessing a power issue).
  2. If I remove the entire USB-A module from the laptop and plug it in again to the same slot, things seem to work again. But then unplugging the cable repeats bullet 1.
  3. Issues go away once I remove the usb extender from the setup.
  4. My macbook + usb-a module + extender + ethernet adapter combo had no issues regardless if I unplugged the module or the cable.

If nobody else is reporting any problems, I’m feeling like maybe its just a me thing. FWIW this is the ethernet adapter I tested with. Amazon Link


I’ve noticed that my FW laptop will periodically say that it’s disconnected from the charger even though it’s plugged in. This is with both the Framework USB-C charging cable, and a shorter cable that came with my power bank. It doesn’t last long, so I’ve never worried. I don’t have any USB-C devices to test if it disconnects from them as well, and I haven’t tested this with my other USB-C module.

That sounds like what I’m hitting? Do you have the same issue if you bypass the module and plug your Samsung adapter directly into the laptop?

I could not reproduce what RandomUser did with an Apple USB-A to USB-C adapter but I did find something interesting.

I tested a 2.5HDD drive. It always spins up with power when plugged in but it isn’t always recognized by Windows. When its in this state, if i plug in an empty USB-C to USB-A adapter to any USB-C module, then my drive suddenly gets recognized! Is that any clue as to what could be going on?

I’m a Batch 2 i7-1165G7 btw.

We have seen some odd behaviors get traced back to the issue here:

1 Like

Thanks for the reply @nrp. One emi sticker did look a little close and I pulled it back. Unfortunately that didn’t fix it.

One last test I tried since I originally thought power. I have a usb-c power meter which I connected to a USB-C ssd and 1m cable.

Idle: 4.99v
File Transfer: 4.92v(4.93v without module)/400mA. I also saw a rare dip to 4.85v/100mA

Idle : 5.16v
File Transfer: 5.09v/470mA, no dips.

I’m wondering if the disconnects are from falling too far below 5v under load? Other power sources I’ve tried also idle between 5.05-5.25v… wondering if its possible to raise the voltage on the Framework a bit and see if the disconnects go away.

@josehabanero Thanks so much for the USB-Ethernet adapter suggestion. I purchased one and it’s great! I also noticed that it connects/disconnects, similar to my power charger.

I followed @nrp’s link “” and adjusted 3/4 of my EMI shields; however, now my 1TB expansion card seems to periodically disconnect, so I might need to go in and try it again.


I’m having a similar issue with my 4k portable monitor and this laptop:

I get random disconnects (video signal goes and comes), sometimes a few per minute! This happens while having the power source connected to the monitor, so the monitor is bringing power to the laptop while laptop sends a 4k signal to the monitor. I tried connecting directly to the laptop, without the expansion card (on both sides), same issue.

This doesn’t happen on my Lenovo X1, btw, so it’s not a monitor issue.

Don’t know what else to try. BIOS is updated to latest version as of today. Any suggestion?

P.S. Same cable works fine with my other laptop, in case someone wonders about that.

Hello, is there any update on this issue? I have a 13th gen Framework and have similar issues. If I plug directly into the laptop USB-C port the external monitor and USB devices work. If I plug into the USB-C expansion card, it is very erratic.

The same setup works perfect with a Dell and Macbook. I only have issues on this setup with the Framework.

I too have a similar issue, I have a USB-C hub ( but I think an older version with only 60w charging?), one DP monitor, and one HDMI monitor. If I plug in all 3, sometimes one monitor or the USB hub isn’t recognized and I have to un/replug things until it works. Also, my keyboard (attached externally via the hub, worked just fine on my PC when I was at home) seems to constantly go to sleep (or something?) and not respond to inputs for a few seconds after not being used (like I don’t touch it for 2-5 seconds, hit a key (or multiple) and it doesn’t start doing anything for 2-3 seconds. The keys I pressed before are NOT transmitted to the machine once the keyboard works.) I disabled usb suspend via TLP (though the keyboard was whitelisted) and the mouse and ethernet adapter in the same hub do not have this behavior. Below is the exact layout in case it matters, though I’ve tried switching it around and nothing has changed.

Left top port: DisplayPort out
Left bottom port: HDMI out
Right top port: USB-C hub with 100w charger, amazon basics usb-c ethernet adapter, Filco FLICKF15 mechanical keyboard, and logitech universal reciever
Right lower port: Empty USB-A expansion card

Some other points to make:
Plugging in to the headphone jack has basically the same effect as plugging in a USB device where ALL displays go black and reconnect (as if I un/replugged them) and the USB-C dock disconnects everything (sometimes the ethernet adapter doesn’t come back online and it needs to be powercycled manually, but that might be a wonky driver.) Also, if I move my desk (bump in to it, etc) my displayport monitor sometimes disconnects briefly, but that could be up to it being an old monitor (HP ZR30w).

I have the 13th gen i7 model Framework 13.

This seems like a nightmare problem, but this laptop is going to be in this position a lot for the next 8 months so I’m willing to put in work to fix it.