Driver .exe bug

Hi, after recently assembling my Framework 16 computer, I installed the computer driver bundle pack just after installing Windows 11 pro.
Then, as usual, I set up Windows down to the last detail to remove everything I didn’t need and increase my level of privacy. Except that when I did this, I noticed that when I ran the driver .exe again, it unpacked and then a black cmd window opened for a very short time and then closed itself.

I don’t know what to do, thank you in advance for helping me.

Welcome to the community!

I may be completely misunderstanding things here, but that “black cmd window” seems to be a normal part of some installers, and many updates directly from Microsoft as well. Windows seems to insist on opening up a GUI window for all terminal processes, whether they need to show anything or not. I’ve seen several of them open up in a row, and then immediately close themselves, during a Windows update.

(I’m primarily a Linux guy, but I do have two machines running Windows right now: a laptop running Windows 11 for work purposes, and my previous desktop on Windows 10, which is primarily used for updating a fairly-ancient GPS receiver we own and spends the rest of its time turned off.)

What I wanted to say is that following my Windows settings, the installation of the .exe drivers for my Framework 16 no longer works. When the black cmd window opens, it’s supposed to stay open for at least 5 minutes and the installation status is automatically displayed. But instead, as soon as it opens, it closes again straight away…

It sounds like you removed a dependency that the installer relies on. This is often the case with “debloated” Windows installs, and it’s why they are generally not recommended.

1 Like

Yes, that’s what I thought too. But which dependency? I’ve tried reinstalling parts of Windows that I’d removed, but that didn’t change anything…

Have you tried a fresh installation? It’s possible that you corrupted this one beyond repair.

To explain, I started by installing the official Windows 11 iso on my Framework. Just after the installation I installed the drivers. I then proceeded to clean up my Windows. Then I noticed that there was some software I hadn’t thought of that was useless. I’m talking about software that is automatically installed on the machine (Goodix, Realtek…). So I uninstalled them. But then I realised that some of the computer’s functions weren’t working properly any more. That’s when I tried to reinstall the drivers… without success.
So I had to reinstall my entire Windows, run the driver installation and only then clean up the bone.

Goodix made your fingerprint reader. Realtek made your audio codec chip. Neither of those drivers comes with Windows; rather, they were installed by the Framework driver bundle.

If you do not understand the ways in which you are changing your system, you may want to be more careful! :smile:


I’ve been involved in IT for about ten years now. I’ve configured dozens of PCs and this is the first time this kind of problem has happened to me. Usually, I install the drivers by loading the driver package directly into the device manager.
My question is just which dependency the Framework .exe is based on.

Suggestion: open a cmd window yourself and invoke the driver exe. See if it spews any errors. Might shed some light.


Unfortunately, this just has the effect of launching the .exe as before, extracting the necessary files and then opening a new cmd window which closes immediately…