eGPU doesn't boot after AMD 13 BIOS update 3.05 (works after rollback)

Hi, I am new here so please let me know if I should have posted this in another thread, I couldn’t find much related to this issue. I will try to keep this concise but detailed.

For context I have a FW13 AMD Ryzen 7640U and use an ADT-Link UT3G external GPU dock (USB4) with a Radeon RX 7800 XT. This setup has been working fine for the past few months since I got the dock.

I use EndeavourOS (basically Arch Linux) and after updating the BIOS to 3.05 yesterday, booting with the eGPU connected would completely halt the init process in systemd at “Starting Virtual Console” (this is after choosing my OS in GRUB). Booting without the EGPU attached doesn’t do this, and the init process completes and my laptop boots normally.

It does the same if I boot into a live usb, unless it is Fedora. Somehow, out of all the OSes I have tried, the Fedora live iso is the only one that doesn’t crash or display “operation not permitted” or any such problem that prevents boot when the eGPU is plugged in. However, if I INSTALL Fedora on my SSD, my laptop starts to crash again on boot. So as of now, no INSTALLED OS has been able to boot with my USB4 eGPU plugged in using BIOS 3.05.

Plugging the eGPU later results in it not being detected at all by any OS.

I have rolled back my BIOS to 3.03b, and I can now boot with the eGPU plugged into any OS I want without further modification to my settings or drivers.

Questions:

  1. Is it possible that the updates included in BIOS 3.05 affect the USB4 controller during the boot process in a way that could make my system crash after GRUB?

  2. Has anyone else exprienced eGPU or USB related issues after updating their BIOS?

  3. Could this be a hardware issue and should I contact support?

Let me know if you need more information or if I can help diagnose this issue in any way. Thanks!

There is a patch on the IOMMU mailing list for the trusted domain for eGPU being set wrong.

I expect that helps. Can you get it?

Hello, thank you for your answer. I am not sure where to find that patch or that mailing list. I have looked around on the forum and on google but haven’t found much information. Can you enlighten me?

[PATCH v2] iommu/amd: Enhance def_domain_type to handle untrusted device - Vasant Hegde (kernel.org)

I have basically the exact same configuration as you are running except I am running Fedora 40. Exact same issue here, except Fedora won’t give me an actual error to read. It just won’t boot. I currently have a ticket open with FW and we are working together to get a solution. Matt with FW support said he plugged in his Razer egpu enclosure with an nvidea gpu and it managed to boot okay, so we are thinking this may be something to do with the UT3G. It is gonna really suck if they can’t find a solution considering how insanely fast the UT3G is. I hope they find a solution.

Thanks for the link Mario! I may look into it when I have time, or wait to see if it gets fixed in a future kernel update.

@OzyOzyOzy this is interesting. I will try with an nvidia gpu I have lying around and report back. What is bugging me is that it used to work flawlessly with the older BIOS version. Let me know if you get any update from support, I am hesitant to open a duplicate ticket for the issue if you already have one, but it may help to have multiple samples…

@isma I’ll pin this thread to add updates when available. The only updates I can give so far is what I put in my last comment. I’m thinking it may be an issue with USB4/Thunderbolt4 authorization and the new bios, considering it works on 3.03/b bios and the UT3G is the only egpu on the market that runs at pcie gen4x4.

It may be useful for you to email them anyway, that way they have multiple incidents with the same setup. They may want your journal logs as well to find any common factors that may be causing issues.

I’ll contact them as well, thanks.

I can confirm I also tried with an nvidia gpu (an old Titan X) and it boots and detects fine on Fedora 40 and on Endeavour. This is after updating the BIOS to 3.05 again. AMD card still doesn’t work.

@isma Dude, that’s an awesome find, make sure you state that. That means it’s not the egpu, but an issue with amd cards and bios 3.05. That narrows down the issues majorly.