eGPU issues with AMD FW 16

Please move this if it is in the wrong support thread.

I just received my preorder for the framework 16 and so far it was going well enough…Though some keys are not working on the keyboard. Anyway the real issue is the every time I plug in my Razor core X (eGPU 6900xt) the thing hard crashes, restarts, then promptly continues to hard crash. I’ve tried TPM disabling, which allows it to boot up where previously it would not even boot with the card plugged in. And even with disabled secure boot it still crashes. I’ll have to wait to the 2230 m.2 to get Windows 10 tested, but so far I’m starting to consider a return. The system does run Linux Mint 21.3 which as far as I’m aware no one has any major issues with. I may need to try fedora or whatever the other distro was, debian? God I hope not, I’d rather run Windows ME.

This is disappointing, I’ll have to email support anyway for the keyboard, but I figured I need to find out if this laptop can actually run a eGPU first and see if I need to get the dedicated GPU instead.

Mine doesn’t even detect the GPU in a Lenovo BoostStation in Windows. Picks up the UCM-UCSI device, and nothing past that.

I was just curious to see if it worked, have the dGPU so it’s not an issue.

Try a newer kernel. There were egpu bugs in older kernels. Ideally 6.8 or newer.

I’m running Arch on the current latest rolling kernel (6.8 something I believe) and also use a Razer Core X with my Framework 16. I do not have the issues you’re reporting.

You don’t need to switch distros to use a different kernel, though I’m not sure what the user experience is like on a debian based distro like Mint for using more up to date kernels.

If it doesn’t boot with the eGPU disconnected, your issue may be something else.

eGPU related thread of mine here:

Are you connecting display output via the eGPU? I had issues getting that to work reliably and found it easier to simply connect through the FW itself and take the performance hit (which seems to be negligible).

There seems to be a bit of confusion, the laptop works great. It even magically fixed the keyboard Issues after a few hours of running. The final, and only problem I have is using my 6900xt. I already tried a kernel update to 6.8.4 which still hard crashes after the eGPU is plugged in. I will get back this thread later today, as I have my second M.2 in, and I’ll set it up with Windows 10, then fedora 39 to see if they have problems. I really don’t like Ubuntu, but just to determine if it is a software related issue I may try it to see.

Also, no the display was running through the framework. I could try using a monitor with the eGPU, but I’ve never had issues with using it through the laptop display. Normally I wait to get it all working, then start getting X11 to play nice with the External monitor with eGPU. I may have to try a Wayland session, maybe it’s X11 that’s the issue?

For what it’s worth, I’m running a Wayland login and Wayland DE.


I’ve also an issue with my egpu

I’m using a 6800 xt in a razer chroma X and it’s not booting with kernel 6.8 but working well with LTS Kernel

I’m also using wayland but don’t know if it’s related

Looks like it will detect and not hard crash on a fedora live media. I’ll try a full install tomorrow to confirm. Might take a while though, I’ve never used another distro for more than a day or two. Haven’t been able to test steam with it though. I don’t know if its because fedora doesn’t set up a RAM disk like mint live media, or if I’m doing it wrong. But I haven’t been able to test installing software.

Hmm, I’m using an nVidia GPU in my enclosure right now. I wonder if that difference could be why I’m not having an issue… which would be incredibly ironic.

I trust the laptop still boots if you unplug it from the eGPU?

Yes it boot without the egpu

I removed the quiet option in grub to check where it’s blocking and it seems it freeze during the loading of the modules

Also tried kernel 6.8.4 and the mainline 6.9

My issues appear to be hardware related, as Windows 10 has issues with the same card, ironically though the desktop x16 solt has no issues. It’s just through the eGPU that the card has problems, a rx580 works fine in the eGPU enclosure.

Did you try the LTS kernel ?

In my case it work, maybe it’s driver related

Okay, moving from the 6900XT to the RX580 has produced some interesting results.

First, the 580 has no issues with Windows 10. Only in Linux Mint.

Second, mint sees the GPU and does make an attempt to use it. But for whatever reason, the drivers don’t load correctly.

Third, I found an issue with the USB4 handshake on older threads here. Apparently the USB4 Chip had issues with Linux?

I started a Linux Mint support thread over on there forms, but it seems that the issues I am having may be caused my something other than Mint itself.

Does anyone here have any ideas?

Start with a newer kernel as I suggested above.

If you have issues, open a bug report with the matching logs and descriptions.

You might also experiment with amd_iommu=off as a debugging tactic.

Ah, I forgot I reinstalled Mint (GRUB didn’t have a Win 10 option, my fault) and never installed 6.8 again. I’ll get on that right after a firmware update.

For the record 6.8 did not help.

However, if someone has a similar issue, (WITH LINUX MINT) I would start with a Firmware update, and that is different than a system update, the update manager does do firmware updates it’s just that “Canonical (Ubuntu) is not including all available firmware so the very newest are not included in the updates. Many people running AMD GPUs need the very latest from AMD to get everything working properly.” Thank you SMG at the Linux Mint forms for the clarification!

You can find Linux amdgpu Firmware here

This did fix my issues, at least with another AMD card (RX580) the 6900xt is now named Karen, since only the desktop will put up with it. I don’t recommend Powercolor, even with killer deals.

Oh now it’s booting with kernel 6.8 for me

But as I understand that’s not secure

BTW thanks for the tip

Does anyone know do to complete/solve this topic? I can seem to figure it out, thanks.


This confirms there is a bug in the IOMMU driver.