Fedora 39 on the Framework Laptop 13

What is the output of grubby --default-index ?

and what is the output of : sudo ls /boot | grep vmlinuz


Reference: Working with the GRUB 2 Boot Loader :: Fedora Docs

IIRC scripts just enumerate based on the numerical versioning of vmlinuz entiries.

Grubby is the supported tool in Fedora for manipulating things (although I kinda give it a wide berth because I’ve had issues with it in the past).

The config for wether new kernel-pkgs should become the default is at /etc/sysconfig/kernel

Hmm, that file didn’t exist. I created it with contents as shown in the doc you linked:

# UPDATEDEFAULT specifies if new-kernel-pkg should make
# new kernels the default

# DEFAULTKERNEL specifies the default kernel package type

I can’t say I remember having to manually create that config file before in the 10 or so years I’ve used Fedora, is it a known recent change?


That’s the same I noticed in my first posts in this topic: /etc/sysconfig/kernel is completely missing. Have also manually created it now; let’s see if that resolves the issue.

Can confirm that restoring the /etc/sysconfig/kernel file as above resolves the issue of the default kernel not updating after upgrade. :slight_smile:

1 Like

Odd this happened, delighted it’s resolved.

Hey all. Just to say the installation was very smooth on AMD 13, and it was surprising not to do any tweak or anything to have everything working. I followed just this page Fedora 39 Installation on the Framework Laptop 13 - Framework Guides and this one https://github.com/FrameworkComputer/linux-docs/blob/main/Fedora39-amd-fw13.md

There is just one thing slightly confusing on the Github page @Matt_Hartley is that it is hinted that activating the fractional scaling is password protected here https://github.com/FrameworkComputer/linux-docs/blob/main/Fedora39-amd-fw13.md#step-2---if-you-want-to-enable-fractional-scaling-on-wayland I quote, « * Then press the enter key, user password, enter key.» In my experience, the command line just worked without any password and there was then a dropdown of scaling in my screen configuration screen.

Another thing slightly confusing is in battery saving instructions, it’s clearly said «don’t use TLP and use PPD for AMD» but it isn’t said what is is PPD and how to use it. As I understand it, it’s just the default energy deamon already installed, you have nothing to do except go on the upper right corner and chose your energy profile.

Oh, yes, four bugs:

  • I had yersterday a graphical weird glitch coming back from sleep, the whole desktop was unusable, white patches and lines on parts of GNOME interface, I had to reboot. Hope it doesn’t come back.
  • blurrry apps with fractional scaling at 125% (really noticeable on electron apps like Slack)
  • The automatic brightness adjustement keeps doing adjustments and it’s quite annoying. It’s like I’m not moving, there isn’t any change of luminosity in the room, and it goes up and down. Not constantly, but enough so it annoys me, because each level change is very noticeable, it goes by quite huge steps I find.
  • the keyboard layout cannot be shown if you go in the upper right corner, click on keyboard layouts, and then on «display keyboard layout» (like, show the image of it).

Likely this is a feature of them using XWayland by default. Have a look here: How to run Electron apps under Linux's Wayland session like a pro - DEV Community

Jep, that was the same for me and it irritated me enough to disable it :slight_smile: (Settings → Power → Automatic Screen Brightness)

This works for me:

Probably because I’m using a weird layout : Bépo (afnor version) – it’s the French equivalent of Dvorak keyboard. It was proposed out of the box during the installation process, but can’t show the layout if I have a doubt about a key. Not really important. First time I hit the button, there was an error message that said there was an automatic report done, and now nothing shows.

In fact my main doubt about keyboard layout (I ordered the clear keyboard without any marking) is not about the usual keys, but about the Framework function keys (volume, brightness, scroll up and down, screen capture, etc).

Dont worry. its enabled by default. You could check service status by

sudo systemctl status power-profiles-daemon.service

this might help you

sudo grubby --update-kernel=ALL --args=“amdgpu.sg_display=0”

Also if you have 64gb ram, try switch in bios uma_auto to uma_gameoptimized

Just got my Batch 11 AMD 7840U in yesterday, installing Fedora 39 from the Framework instructions couldn’t have been easier :smiling_face:

Didn’t change anything related to battery or sleep, and suspended it overnight by closing the lid. Battery dropped just 4%, from 90% to 86%. Never had this much out-of-the-box success with Linux suspend before. Great work to everyone involved!

1 Like

Something else I’m not sure I should do, is using RPM Fusion to swap drivers.

I’ve followed the instructions here Howto/Multimedia - RPM Fusion

Including this:

sudo dnf swap mesa-va-drivers mesa-va-drivers-freeworld
sudo dnf swap mesa-vdpau-drivers mesa-vdpau-drivers-freeworld

I think if this is necesary to correctly use hardware and video acceleration, it should be included in Framework guides. I find it unfortunate that we have to resolve to hacks and external repositories to have video codecs and video acceleration working, just because of a single country (the USA), this has been resolved for a while in Ubuntu and Debian, but well…


I wish I could say this worked for me, but unfortunately GRUB still seems to be defaulting to the oldest kernel for me.

$ rpm -qa kernel

$ uname -r

$ cat /etc/default/grub
GRUB_DISTRIBUTOR=“$(sed ‘s, release .*$,g’ /etc/system-release)”

$ cat /etc/sysconfig/kernel

/etc/sysconfig/kernel also did not exist for me, so I had to create it as above, but I’m still booting to 6.5.6 by default, despite the fact that 6.6.6 is installed. Any help?

Next time the kernel is updated the default kernel should be set to the latest installed one. As far as I understand, the sysconfig file is only used when updating your system, so I think you just need some patience :slight_smile: . In the meantime you can manually change the default using grub-set-default.

Also, welcome to the community! :hugs:

1 Like

Thanks, I appreciate that! Unfortunately, it seems grub-set-default doesn’t work for me. I’m getting sudo: grub-set-default: command not found

That’s right. It’s grub2-set-default now, my bad :wink:

sudo grub2-set-default 0

worked! thank you so much!

1 Like

I think new kernel installs started updating grub properly after used grub2-set-default one time. Since then, I’ve installed the 6.6.6 kernel and a custom 6.6.7 kernel and both times the default grub entry has been updated accordingly.

Note, if you want to check what your default boot entry is before rebooting, you can use sudo grubby --default-kernel. Or,

$ sudo grep saved_entry /boot/grub2/grubenv

$ sudo grubby --info=0
args="ro rd.lvm.lv=fedora/root rd.luks.uuid=luks-c28dcd68-0d5b-4fdf-99eb-c5f1ebe6985b rhgb quiet"
title="Fedora Linux (6.6.7-200.draconyx.fc39.x86_64) 39 (KDE Plasma)"

EDIT: I previously said it didn’t seem like /etc/sysconfig/kernel is used anymore, but have since found that it still is. This is how it all gets tied together. Maybe this will lead someone to figure out why it isn’t working right!

When you install a new kernel, the post transaction script runs /bin/kernel-install add 6.6.6-200.fc39.x86_64 /lib/modules/6.6.6-200.fc39.x86_64/vmlinuz. (You can see this in the output of rpm -q --scripts kernel-core-6.6.6-200.fc39.x86_64)

The man page for kernel-install says it executes scripts from /usr/lib/kernel/install.d. One script in this directory, 20-grub.install, is responsible for updating the default grub entry in certain cases.
It runs the grub2-get-kernel-settings command and evalutes it’s output. grub2-get-kernel-settings reads /etc/sysconfig/kernel if it exists, and if it contains UPDATEDEFAULT=yes, then it sets GRUB_UPDATE_DEFAULT_KERNEL=true.

Later in 20-grub.install, it checks if GRUB_UPDATE_DEFAULT_KERNEL=true (this may have been output by grub2-get-kernel-settings). If it is, it will run grub2-editenv - set "saved_entry=${NEWDEFAULT}". This updates the saved_entry setting in /boot/grub2/grubenv.

Note: 20-grub.install and grub2-get-kernel-settings are shell scripts so you can have a look at what they do easily enough. Also, it looks safe to run grub2-get-kernel-settings - it will just output some text to your terminal so you can see what settings it would use.

What I don’t quite understand, is why my system is updating the default grub entry when I install a kernel. I do not have a /etc/sysconfig/kernel file but on the last two installs (and since one-time using grub2-set-default) grub is being updated.

EDIT2: I just clued in, I used grub2-set-default 0, so now grubenv has saved_entry=0. When I install a new kernel, it is inserted at index 0 and becomes the default as a result. This doesn’t seem very reliable.

1 Like

hey guys,
i’ve been using fedora on my ryzen 7 and i’ve been enjoying my time with linux (first time linux user other than steam deck), but i keep getting pulled back to windows because of one simple thing – fractional scaling and how blurry all the apps get!
if i leave scaling at 100% everything is way too small, and if i set it to 200% it’s all way too big. so i am using 125% which is working well for me, but it makes almost every app look blurry and awful. it’s really ruining the experience for me.
as far as i’ve been able to research this seems to be an issue with gnome? is there a way to fix this so apps scale properly? it’s really killing the vibe for me. i’m enjoying gnome but maybe it’s not for me if this is an issue that can’t be solved.
any other linux recommendations that don’t have this problem? i really want to move away from windows for good.

Could you provide some ss? i am on fedora with 125% scaling… no any problem with blurry.

1 Like

Same here the laptop screen is at 125% and two 4K 27" screens at 150%. No blurry fonts, or interfaces. Everything is crisp.