Fedora 39 on the Framework Laptop 13

here is a screenshot with teams, discord and brave. brave is crisp and fine, but only after changing a setting – after a clean install it’s blurry. discord and teams are blurry no matter what. even GIMP which i used to quickly scratch out names in my screenshot was blurry.
pretty much every app i use other than system apps are blurry.

edit: [F40] Fractional scaling in Fedora 40 Workstation makes some applications blurry - Fedora Discussion

apparently its apps that don’t support wayland natively.
i had to do this to get brave to not be blurry:

Chromium-based browsers (Chrome, Edge, etc) - Don’t support Wayland out of the box, but you can change it .

use firefox its great and wayland enabled by default =)
Yep, i could agree little blurry, just checked with mine discord flatpak. I hadn’t noticed that before.
A bit of nostalgy such fonts reminded me first MS cleartype font on CRT Displays in 90s) nowadays i only could see fonts blurrness while taking my self close to display.

There are some really not so bad FOSS Discord clients available. try one maybe.

Discord, and i other ms app i think too, broken by design to support wayland. so I don’t think it’s a good idea to expect the developer to implement it soon.
Maybe your solution could be is switch back scaling to 100, and adjust font size to suitable ones.

no thanks. brave works great for me. had major issues with firefox and video playback that i was never able to resolve.

i’ve tried a bunch of other discord options and they are all blurry, haven’t found one that isn’t.

i really like gnome, but i think its just not for me. the blurriness is too much.

check webcord or armcord, i remember one of those was with wayland.

i had tried webcord before, but not armcord. i just checked it out and sadly it’s blurry too. i also retried webcord and it’s blurry as well D:

ok, there is also one another trick you could try.
disable fractional scaling
logout - login
switch scaling to 200
then in gnome tweaks play with font scaling factor to down.
maybe thats would give you result u want.

In plasma_wayland display settings there is an option to allow legacy x11 apps to apply scaling themselves in display settings - which can be useful for some apps (cough steam) which don’t pick up system fractional scaling.

My advice at this time is if you must use scaling run plasma_wayland

@demounit I see what you are talking about, and I don’t have any of that going on. Is this a completely fresh install…or did you possibly import font settings sitting in your home folder form an old install? What are your gnome tweaks font settings? DId you try tuning your appearance settings in Discord to sync with the system?

Compared GIMP and Discord to your screenshots, mine are crisp, but yours are in fact muddy/blurry. This is why I am asking about an old font config or font settings in gnome tweaks.

This might not be a good solution for everyone, but since I didn’t specifically need fractional scaling, I just changed the global text size using Settings > Accessibility > Large Text. I found this was enough to make using this crisp display comfortable to my eyes without leading to blurry apps.

Plus, I think the text size can be tweaked fractionally using gsettings keys/dconf editor, so if the Large Text setting is too big/small, you can get even more granular.

The other benefit for me at least was less processing power being spent on the fractional scaling stuff, so you’ll probably see better battery life compared to using fractional scaling.

1 Like

Absolutely agree with you, corrected this immediately upon reading this. Thank you :slight_smile:

Again, this is great feedback. It does assume customers know what PPD is and does. I need to address this straight away on the Knowledge Base Article where it mentions this.

  • I disable this myself, instead opting for a manual approach with the keyboard brightness keys. To disable this automatic brightness function, Settings, Power, (scroll to Power Saving Options), toggle off Automatic Screen Brightness. This should help.
1 Like

I noticed all the "Fedora 39 Community Forum links such as https://community.frame.work/t/fedora-39-official-fedora-39-thread/37465/3 (/3!) to this page on the Linux compatibility page are not accurate. It should be https://community.frame.work/t/fedora-39-on-the-framework-laptop/37465/.

Electron does support running on wayland directly and produces crisp text with fractional scaling then. The problem is that each electron-based app packages things differently, so you’ll have to jump through different hoops to get the requisite options to the particular app. It usually involves some combination of the options:

--enable-features=UseOzonePlatform --ozone-platform=wayland --enable-features=WaylandWindowDecorations

Hopefully this gives you sufficient keywords to search how your particular app needs to be massaged. Chrome/Chromium has a flag in chrome://flags now that allows setting Preferred Ozone platform to wayland, so slowly apps are catching on and making a bit easier to set. Chromium as packaged by Fedora already defaults to Wayland.

Ah, it may have been mis-linked. I’ll submit a request to the web team with a correction later. Thanks for the heads up.

1 Like

Thanks for submitting the request! For the “Framework Laptop 13 (13th Gen Intel® Core™) Compatibility” section, the Fedora 39 Community Forum link [1] is especially unique with a mysterious URL argument.

  • [1] https://community.frame.work/t/fedora-39-official-fedora-39-thread/37465/3?_gl=1*174zmb6*sg_ga4w_production_ga*MjEyODM3MDcxMC4xNjk4ODUyMzM3*sg_ga4w_production_ga_PYG8X65YJJ*MTcwMTM3MzM0NC4zMC4wLjE3MDEzNzMzNDQuNjAuMC4w

I have the following issues running Fedora 39 on my AMD Ryzen 13’':

  • occsional screen flashing, especially if I watch videos in an enlarged mode or with some games. I tweaked the BIOS to fix this, enlarging the amount of memory available to the GPU, but the problem has persisted. It’s fixed with a reboot, but this is a little annoying.

  • some videos won’t play.

I’m sure both are due to driver issues. I haven’t had time to really explore them. I was wondering if anyone else had found a fix for these issues?


Welcome Nicholas! Yes, this is a known issue. You can find Framework’s recommendation here. People report good results after enabling this kernel parameter.

You can also follow this bug report; it looks like kernel 6.8 will fix the issues altogether (no kernel parameter needed any longer). For more info, see also this thread: [TRACKING] Graphical corruption in Fedora 39 (AMD 3.03 BIOS)

1 Like

When editing the ticket, add the Framework top-level ticket id 2240811 to the item: Blocks.

Sorry, where is this field? I see ‘Treeview+ depends on/blocked’, but not ‘Blocks:’ in the edit menu.

EDIT: nevermind - found it under ‘Show Advanced Fields’.

Hi all, the graphical glitches after suspend are back for me. They had disappeared for a while with the advised boot parameter:

sudo grubby --update-kernel=ALL --args="amdgpu.sg_display=0"

But now they’re back again. After every suspend, my screen has graphical colored artifacts that cover the whole surface, may disappear after a few touch presses but then come back. I’ve rerun the same command, with no effect.

I don’t even know if the configuration works, perhaps grub2 has been updated? If I do sudo cat /boot/grub2/grub.cfg | grep amd I get nothing, and from the grubby man page this seems to be the file that’s supposed to be edited.

I also get nothing on that, but it still is applied so I guess the man page is wrong?

(replace linecmd with cmdline in the command below. I had to fake this to get around this forum posting bug)

$ cat /proc/linecmd |egrep -o 'amdgpu.+'

Do you get the same?

Try running

sudo grubby --info=ALL

This should list all available kernels and their parameters. You can find out which kernel you’re currently running with

uname --all