Fedora Linux 35 (Fedora 35) on the Framework Laptop

Reddit: Fedora 34 Hibernation: https://www.reddit.com/r/Fedora/comments/mw4ee9/fedora_34_hibernation/

I am investigating about the system sleep and ACPI mainly reading kernel document now. Here is just my memo. I will add more contents there when I find something new.

Just note yesterday I updated the wiki updating Sleep / Suspend and adding Reporting upstream or Fedora project section.

Installed Fedora Linux 35 following the guide. Removed all partitions and restarted.
Computer fails to boot. Stuck on and will not power down.
text on black screen reads:
Answered my own question (shown below).
To restart the Framework, hold down the power key for more than 10 seconds (13?)
Computer booted into Fedora 35 after that.
On to the next challenge! :slightly_smiling_face:

[FAILED] Failed to start Show Plymouth Reboot Screen
[FAILED] Failed deactivating swap Compressed Swap on /dev/zram0
[ 766.994700] watchdog0: watchdog did not stop!

If you know how to force the Framework to shutdown, please let me know.
I am sure I did something wrong but I don’t know what.

Caution: people who are using Fedora 35 and wants to use s2idle as a sleep state, Fedora 35 kernel 5.16.5 s2idle and maybe wifi issues . There is a regression bug about s2idle on kernel 5.16.5 on Fedora 35. So, don’t upgrade the kernel or use “deep” instead of s2idle. See the context here.

Anyone know where we could report the grub2 bug exactly? Not on framework hardware (yet), but I had the same issue on a ThinkPad T14, which was also solved by running

sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

@jorp Did you check “Reporting to upstream project or Fedora” section on the 1st wiki comment on this thread?

Check possible packages related to grub2.

$ rpm -qa | grep grub
$ rpm -qi grub2-common | grep URL
URL         : http://www.gnu.org/software/grub/
Bug URL     : https://bugz.fedoraproject.org/grub2

Oops! I actually missed that… thanks for the info @junaruga!

To everyone reading, there’s an open relevant bug report here with additional links to an upstream fix.


Thanks for reporting!

Relating this graphical issue I am seeing on a fresh install of Fedora 35: Fedora 35 graphical issues

When I move my mouse to the left of the screen it glitches out, I’ve gotten rainbow snow, hangs, and black screens since the update.

1 Like

Updated the sleep / suspend section on this thread’s wiki, adding content about sleep mode deep & hibernation. I wrote a step by step page about changing the sleep mode from s2idle to deep, and change back.

1 Like

I renamed this thread title from “Fedora Linux 35 on the Framework Laptop” to “Fedora Linux 35 (Fedora 35) on the Framework Laptop”, because I noticed this thread can not be found when searching by “Fedora 35” using this forum’s search area on the top of the page.

I understand “Fedora Linux” is the official name of Fedora distribution. That’s why the title was using “Fedora Linux 35” rather than “Fedora 35”.

But I assume the current situation is why a user who don’t know this thread might create a new thread about Fedora 35. I know the title is a kind of redundancy. But I could not find any better way to solve this situation.

1 Like

Hello, I tried to install Fedora 35 following the official guide, but it doesn’t work. During boot (I hink) there are a bunch of repeated log lines like this:

[  349.288629] dracut-initqueue[647]: Warning: /lib/dracut/hooks/initqueue/finished/devexists-\x2fdev\x2fdisk\x2fby-label\x2fFEDORA-WS-L.sh: [...]
[  349.291731] dracut-initqueue[647]: Warning: /lib/dracut/hooks/initqueue/finished/devexists-\x2fdev\x2froot.sh: "[ -e "/dev/root" ]"
[  349.294809] dracut-initqueue[647]: Warning: dracut-initqueue: starting timeout scripts

And then finishes with:

[  349.297570] dracut-initqueue[647]: Warning: Could not boot.
Warning: /dev/disk/by-label/FEDORA-WS-L does not exist
Warning: /dev/root does not exist

And then allowing to enter an emergency mode with a shell or continue (which doesn’t work).

A Google search lead to some forums with people reporting this, but not with a comprehensive / easy guide to follow to fix this.

Besides the official guide for the installation I also tried with a USB drive prepared with Rufus, as well as with Ventoy (one time with GPT and Secure Boot enabled in Ventoy and Framework BIOS, another time with MBR and Secure Boot disabled in both Ventoy and BIOS).

Is it an issue with the Fedora image? Or with the USB drive? Or the laptop?

I tried with a separate USB drive and it worked with that. So I guess it was because of the drive. It was a SanDisk Ultra with USB-A on one side and Micro-USB on the other, where the storage is actually a (non-removable) SD card, and I heard about booting issues with those.

I had exactly that problem. I created my USB stick with unetbootin a few times and it kept happening. I then tried to install NixOS which requires secure boot turned off, but that didn’t work either. I then went back to trying to get Fedora working and created a new USB stick but this time just using dd. At this point, the live disk worked.

I’m not sure what was the fix - it was either turning secure boot off, or using dd. Or perhaps the stick is just faulty and I got lucky!

On this article regarding display scaling, I think it would be most appropriate to recommend turning on “Large Text” in settings>accessibility first (which will probably resolve the issue for many people, including me). Then recommend installing gnome-tweaks and changing the font manually. Lastly, recommend the fractional scaling setting, and make it exceptionally clear that it is an experimental setting and can (and most likely will) lead to rendering issues. Since Framework is a company that takes transparency so seriously, I believe this should be just as transparent.


Don’t know if I should have made a separate post for this or not. Also, if there is a better way to get in touch with those who write that documentation, please let me know.


Update: NOT Fedora-related. Feel free to ignore. Seems I hit Microphone not really working - #18 by Steven_Tyrer

Just setup my DIY Framework. Installed Fedora 35. Added the modprobe line for the mic. Looks like the module is loading fine in journalctl. Settings shows a mic. pavucontrol shows a mic. I’ve tested with the mic switch both ways.

I can’t get my mic to work. Any ideas? Not even sure how to debug since it shows up and everything seems to be working, but it just records silence.

Building it went well. I don’t think I bumped anything.

(USB mic works flawlessly)

1 Like


I’m sharing information related to a known bug (See bug 2074083) with the Fedora Everything installer for version 35. I think it will be a good idea to also add this information to the top post.

The installer crashes if you download package updates during the installation process. The error message you get is :

dasbus.error.DBusError: [Errno 2] No such file or directory: '/mnt/sysroot/etc/resolv.conf'

To workaround this issue, you have to do the following:

  1. Disable the download of the updates during the installation process
  2. Manually install iwlax2xx-firmware.noarch with rpm to get the WiFi working.
1 Like

Is anyone else having an issue with multiple monitors? I’ve been trying to connect my big monitor to my laptop, but there is no detection in the GNOME display settings.