Fedora Linux 35 (Fedora 35) on the Framework Laptop

Thanks @RandomUser Turns out this service is for TPM1 only
For the other problem I opened a bug here: 2018978 – TPM support does not work on Fedora 35

I updated F34 to F35 and it fixed bluetooth problems. Previously bluetooth remained functional but a previously connected device (mouse) would become unstable (connect,disconnect,connect,disconnect,…) after reboot. If I removed the component and re-paired then it was stable (until I shut down again).

Stable for 2 days and about a dozen reboots, now.

Back to being a big fan!

1 Like

I’ve noticed that I can’t invert scrolling on the touchpad

Mouse I had problems with was a Razer Basilisk X Hyperspeed.
It is bi-mode (usb dongle or bluetooth) and I only had problems with bluetooth.
Still working fine in 35.
Just curious, why are you asking?

No, I use the KDE Respin. They call it “Invert Scrolling.” It was working in Fedora 34, but the setting does nothing in Fedora 35. I also seem to be missing tap-to-click. I remember there was a modification to the quirks file to enable options that were usually absent, but can’t find it.

I lost sound. It’s really strange, and for a minute I figured it might be a hardware issue (I’ve had my laptop for less than a week). But neither speakers nor headphone jack work at all since updating to 35. I wonder if it has something to do with the “soundcard”, which I guess was changed at the last minute in manufacturing. Is there some sort of specific driver for the sound? And Why did it all work in Fedora 34?
When I go to settings and sound, the System Volume is all the way down and the speaker button has an ‘x’. I can move the volume up, click the button, but nothing changes. System Sound under “Volume levels” is all the way up. In “Output” I cannot get any device to show up, it remains stubbornly blank. Input and “Input Device” as well.
It’s really screwed up.

@Christopher_Daniels I’ll second this, Installed the KDE spin of 35. No sound. Brand new install.

I tested the Fedora 35 Cinnamon spin yesterday, and I had sound (at least while running the Live USB).

Is it possibly Common F35 bugs: no sound after upgrade? If so,

 systemctl --user enable --now wireplumber                          

in your user session (not as root; no sudo) should fix it.

Hmmm — that shouldn’t happen. This is with the released version or did you start with a beta? If beta, the above might apply. If new install, something else is going on.


I have sound, working with Fedora 35 and Cinnamon. Batch 4.

@mattdm I downloaded the release version. I had sound during live environment but no bluetooth. After install I have bluetooth but no sound.

edit: I did this late last night. Brought the laptop to work, turned it on from powered off state and I have audio. I’ll keep testing to see if this issue comes back


I’m running Fedora 35, Xfce on my Batch 4 machine. I haven’t used it much yet, but even after install and updating, the sounds seems to work just fine.

I know I’m late to the party, but given that Fedora 35 recently officially launched, and this bug is still there, I submitted a bug to Fedora for it. We’ll see how far it gets. :slight_smile:

To fix the scan lines issue, you don’t even need to change the default in /etc/default/grub. Just running sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg is sufficient.


I ended up upgrading from 34 Cinnamon respin to 35 Cinnamon respin after the official release. I do regret not giving it a few days before upgrading, since I just YOLO’d and did it on release day. It wasn’t quite as flawless as I would have liked, but I did get everything working. The only real major issue I ran into is that after the upgrade at random my 1 TB expansion card would disappear between updates, and I’d have to totally shut down and power back up to get it back. That and it took a bit of doing to get my audio working again, otherwise, it went fairly smoothly on the Framework. Registered fingerprints remained, all my settings and apps updated, and no major failures occurred. Still happy I went with Fedora on it. So far I don’t have much to complain about. F35 and Fedora as a whole have been pretty solid.

I am brand new to Linux and while this “scan lines” thing was a bit annoying, I didn’t know it wasn’t normal. But I just wanted to say thanks because your fix listed here took seconds and worked perfectly. So, thanks!

1 Like

Been using Fedora 35 for a few days now and it all seems stable. I was using a 34 respin for about a month and didn’t have too many problems. Ubuntu based distros were a nightmare of problems for me.

That being said has anyone else encounter an issue where one of their keys stops working? The ALT key next to my arrow keys stopped working about a week ago while I still had 34 installed. Ok no worries the new version is coming out, upgrading should fix it right? When it didn’t I thought it might have been a hardware issue but I booted the current version of Mint with a Cinnamon respin and it worked just fine.

Minor gripes: the long wake up period from deep sleep! (But Fedora does seem to manage battery usage much better than Ubuntu so it’s a wash I guess) That and it routinely connects to the weakest part of my mesh network >:( At least my place is small enough to where it doesn’t really matter.

Is it the right alt key? I assume so by “next to my arrow keys”. That’s probably this issue, wherein it gets inadvertently switched to serve as an “Alternative Characters Key”.

1 Like

@mattdm That was exactly what it was thank you! At some point Fedora set my alternative characters key to the right alt key.

1 Like

YES!!! This worked!! Sorry, for the delay, I’ve been installing Windows 10 from an old ESD usb stick, (for dual-boot) which meant endless updates, and then I did the latest BIOS update. But I kept Fedora on the drive, and that simple command works.
This bug not too surprising, given that Framework had to change soundcard suppliers at the last minute, combined with Fedora 35 overhauling it’s soundsystem on the software side.
In a way these little problems just confirms my conviction that the world needs PCs to return to modular, upgrade-able and repairable hardware. Because sh*t happens.
I’m also messing with an old IBM 386 PS/2. IBM at that time was attempting to introduce proprietary connectors, with the power supply, for example, incompatible memory modules, evetnually MCA, etc. Compaq, then the other clone makers, crushed IBM. I hope to see that pattern repeated with Framework!

1 Like

I’m using Fedora 35 on a batch 5 Framework. I wanted to use KDE but failed:

In my first attempt, I used the default Fedora (Gnome), then installed KDE. After reboot and login, KDE was unresponsive, and after a few clicks, strange patterns appeared, and the environment became unusable.

Second, I downloaded Fedora’s KDE spin. It was working fine until I dnf updateed, same behaviour.

In the third attempt (My current installation), I installed the default Fedora (Gnome) again, but with minimal complexities (default partitioning, no encryption, no fingerprint, no external monitor, etc.). After adding KDE, rebooting and logging in to Plasma, I got the same behaviour.

Now I’m using it with Gnome, which is torturous to me (Seriously, how do people live with so little room for customization?? But this is a post for another community site) until I can find a solution.

So apparently, my system works fine with the Fedora 35 KDE original release, but the new packages are unstable on it.

Any pointers, suggestions are highly appreciated. Thanks