Feeling Hopeless Trying to Solve Linux EGPU Issues on Framework

I made a thread a few months ago (Help with Fedora Linux configuration and EGPU Windows VM Passthrough) about an issue I’m having getting my egpu to work with my framework.

At this point I really don’t know what to do or where to look for a solution. Do I need to wait for a new bios, for the thunderbolt certification? Did I get the wrong mainboard for it to function right? Did I get unlucky with my batch number?

I know that maybe in the future it might work but that’s probably a few years down the line and I can’t really put that off because I’m running into roadblocks for my GIS workflow when Trying to do heavier computations; not to mention trying to play pc only games.

I’m really tired of trying everything. I’ve tried different brand graphics cards, different same brand graphics cards, different distros, different cables, different drives, different display managers, different scripts, nothing has worked. I even tried support to see if they had any insight but I probably shouldn’t have since it’s not really the kind of thing that they would necessarily deal with.

Man I’m just tired, maybe one day I’ll figure it out but I just don’t see that happening.

You’ll likely have better luck with some tried & true business laptops. This laptop just isn’t ready for some of us.

I had to go back to square one and purchase another ThinkPad as my daily driver. Consider the cost of the Framework laptop as a partial loss…it can still do other things…just not good enough to be a daily driver for some of us.

Don’t really have more money to spend on another computer, guess I’m stuck till I find a solution

Compared to last time, are you still having issues with passing the GPU over to your Windows VM or is your host Linux install not working with the eGPU either?

I managed to get it working. Make sure Linux is not loading your gpu driver. This causes any passthrough to flip out because Linux is also using the gpu. Use Vfio instead of other passthrough kernel modules methods. Another big tip is to not boot with a thunderbolt cable plugged in. Plug in after you get to grub screen.

In that case, time will be the payment (time = money). Hope others here will have a solution for you. TCO on this laptop is quite high especially if Linux is your environment. The community is great, definitely has some trail-blazers here.

@tokanada Yeah I’m still having trouble with my main install because it never loads past the splash screen and just leads to a blank

@Hugo_Gonzalez I tried that for a bit using an Nvidia card and then trying to disable the amdgpu modules in the kernel from being loaded but it still had the same problems unfortunately with using it natively.

The one thing I haven’t tried is the cable trick so I’ll try that next, thank you!

@A_A Very very true, given enough time and pressure, like geology, cracks will form and I might find something that works

Good News !! I got it to work. From something @Hugo_Gonzalez mentioned about when to plug the thunderbolt in I started thinking about the different things that need to go just right for it work.

Disabled thunderbolt on my host os
Used a different display port cable to make sure the output was working
Used my 5700xt to avoid the amd reset power bug

All that and the past few updates for the bolt packages have made it work!
I’m now able to pass my egpu through to a VM!

Thank you for everyone who’s tried to help, I’m so happy

4 Likes

Update:
I’ve gotten around the kinks of it. I installed Fedora 36, switched to a rx 550 and started using the looking glass client for my vm. So far no issues!

2 Likes

Late to this topic but for Nvidia users

I had this issue as well (NVIDIA card in an external TB3 housing). What did your xorg.conf look like? Typically I had to add Option “AllowExternalGpus” “True” to the Nvidia device for it to work. egpu-switcher does this automatically.

Also curious if you managed to get suspend working on the NVIDIA card in the host OS, that’s my only issue right now.

@Be_Far I have an AMD card so I’m not sure, sorry

@Standard_027 I saw that you mentioned testing with an NVIDIA card earlier in this thread, so just thought I’d ask. Sorry!

@Be_Far Yeah I borrowed a friend’s card just to see if the output changed but it didn’t seem to. Are you also doing PCI passthrough or just trying to use the egpu?

Just trying to use the egpu. Suspend has been a persistent issue across all distros.

@Be_Far I’m not sure, I’d say for me personally the issue for just using the egpu got resolved after doing a fresh fedora 36 install, but again I don’t know where the NVIDIA aspect work work in; sorry