Fingerprint on Fedora

I can’t seem to add fingerprints to a user account in Fedora. Do I need to do anything to enable it? I haven’t installed any other OS’s onto this machine, but the fingerprint reader has never been recognized. Any ideas?

@Steve_Spanjers, I am not at all familiar with Fedora, though one thing to check is the setting to enable the fingerprint reader in the UEFI (bios) settings. I could not get the reader recognized until I stumbled across that UEFI setting the other day and set it to enabled and now I’ve got it working.

I originally wasn’t going to set up the fingerprint reader but gave in when reading an Arch linux info page and gave it a try. It wasn’t until about 3 weeks after that attempt that it finally worked after I found the bios setting.
Edit: The setting is under the “Security” tab > expand the “IO Interface” option down the page a bit, and it will be in that dropdown option.


Using Fedora now and the fingerprint reader with no issue. I’m not on GNOME but KDE. I was able to enroll my fingerprint in settings.

@yetiman_64 I checked my BIOS settings, and it says enabled. Thanks for the suggestion, I hadn’t thought to check there.

@GhostLegion, I’m using GNOME, so maybe not the same, but what page in settings did you use?

1 Like

It should work out of the box and be configurable in the Users tab of your system settings:

Though it might be that your FP reader is faulty. What does lsusb print? There should be a device called Shenzhen Goodix Technology Co.,Ltd. Goodix USB2.0 MISC:

Also you can check the status of fprintd with systemctl status fprintd:

1 Like

lsusb is showing the reader (Goodix USB2.0 MISC)

fprintd is not running. I can start it, but it only stays running for 30s or so before it goes inactive. journalctl as a few long errors, but none that made much sense to me (JS ERROR: gio.DBusError)

Can you post the full error? You can get it with journalctl -u fprintd.service -p4

You can also try to configure fingerprint login using the terminal with fprintd-enroll. It should also throw an error if no suitable hardware can be found.

Whats does dnf list --installed *fprint* print?

fprintd-enroll worked in terminal; it gave me an enroll completed message for the right index finger.

Installed fprintd packages are identical to your screenshot

Error message:

Nothing out of the ordinary. Does fprintd-verify work? How do your user settings look like (screenshot in my previous post)? Your fingerprint should be configured. Keep in mind that the first login after a fresh boot does still require your password to unlock your keyring. That’s by design though.

Looking more into it, I’m getting a message saying “Deleted stored finger 7 for user **** as it is unknown”

Perhaps I’m in need of coffee here, but is this the current Fedora 37 or still 36? I ask as it works fine in 37 under users.

1 Like

I’m also in need of coffee, lol. This is fedora 37. I do have it joined to an AD domain, I’m not sure how many domain settings are inherited from AD. I wasn’t able to see any different in fedora 36 though either.

@Steve_Spanjers I don’t think that fingerprint authentication is supported with AD joined devices. But I might be wrong. You may want to ask this question over at

1 Like

I would use the solution in this post and see if it helps:

When you said you were in AD, I started to think it may be this issue with the Linux and Windows drivers fighting over a fully-functioning) print reader

I tried the fprint clear storage, seemed to execute properly but still no joy. Must be an AD setting; I seem to remember some of our windows laptops had the same problem. Must not have something set right in the group policy.