Fingerprint reader doesn't show up in settings

Hello,

I just updated from Fedora 39 to Fedora 40 on my Framework 16. Most things seemed to transfer over smoothly, but my fingerprint login disappeared, and when I went to re-add it in settings, the setting for a fingerprint is just no longer there in users. I’d guess this is a firmware problem, but I don’t have enough experience to know for sure or to know how to correct it. If anybody else has had a similar problem or knows how to troubleshoot this, that would be much appreciated.

Similar issue with Ubuntu was working fine until it was gone assuming it was with an update.

edit yah the fingerprint reader appears to no longer be detected by running the lsusb command. And purging and reinstalling fprintd hasn’t solved that issue so trying to enroll just gives an error for no such device.

edit2 so I had just tried rebooting prior to this. Fully powercycling the machine OFF and then turning it back on brought the fingerprint reader back up for myself might be worth a try?