First impressions!

Typing this on my Framework!

I had a bit of an issue getting started. I assembled my DIY very very carefully but could not get my display to show anything. There was memory training of course, but this was 15 minutes with nothing before I realised there was something wrong. Those LED codes fly by pretty quickly! I thought it was indicating “DDR initialized OK”=red (bad) or “internal display initialized OK”=red (very bad). Thinking it might be DDR, I removed a stick. Instantly I got a boot menu. Bad stick? I reinstalled it and the screen came back. OK - all’s well then.

At first it would not boot from my nice fast USB 3.2 Gen 2 UEFI NVMe enclosure. I tried and tried. Then I plopped in my ancient slow ADATA 16GB USB 3.0 drive and it worked like a charm. Installed Linux Mint. In another thread there was an indication that with Secure Boot enabled, I might not be able to boot from some USB drives. But I couldn’t get into the UEFI to disable secure boot at first, so…

Anyway, installed Linux Mint super super quick. The AX210 wireless was recognized and worked right away! Yay!

Boo, I updated the kernel and the wireless broke. :roll_eyes: Yay - using a wired adapter I found and installed the 5.14 kernel, now wireless works fine again.

With that out of the way, first impressions:

  • it’s light, thin and really sleek
  • entire assembly feels very solid
  • it’s very easy to disassemble
  • it’s snappy, responsive, fast!
  • the power adapter is much smaller than I thought. Really really nice. I’m glad I got it.
  • runs cool! I don’t even think the fan is running at all right now.
  • screen is bright, colours are good and text is very sharp
  • lots of vertical screen real estate
  • keyboard is nice and clicky. Good key travel, nice adjustable backlight.
  • trackpad is HUGE, sensitive and responsive. I can just use it without much thinking, it just feels natural.

Could be improved:

  • that UEFI timeout is really short! I miss it most of the time!
  • display scaling. More to do with Linux than anything else I guess. “Automatic (2x)” is sharp but with big icons and text, lots of wasted space. “Normal” = way too small. “Double (Hi-DPI)” looks the same as “Automatic (2x)”. I tried fractional scaling, 150% and 125% is a good size but text is fuzzy.

Can’t think of anything else. I’m really, really pleased!

I’ll post a complete review once I get Linux Mint configured and do testing and benchmarking.

Thank you Framework!

12 Likes

Great write-up, and congrats on getting it going!

I think you can configure this on the Boot tab. :slight_smile:

2 Likes

The timing is 0 so you have to really go at the key to get in.

Once you can get into the setup screen, head to

Boot > Timeout

and change the value to your preferred amount. I have mine at 5 seconds.

I also have Quiet Boot = Disabled so I have a clue when to hit F2

Which linux distro/DE are you running? In my experience KDE handles fractional scaling with a single display much better than gnome.

Nice writeup. I mentioned this in the other thread but I had the same problem trying to install the OS, wouldn’t recognize my USB 3.2 drive but managed to boot it off an old drive I had lying around (I presume it was USB 2). And yeah, had to mash F2 a bunch to get into BIOS the first time ha.

Also feel the same way about scaling. I’m currently using 150% on Windows but things are slightly less crisp. I can live with it. 200% is way too large for my tastes, though if there’s ever touchscreen support it’s a good size.

To add to your post, my only other comments are minor. Battery life is decent - saw a lot of people getting 5 hours initially but I’m getting 6-7 on better battery life setting, even using Chrome (which is a notorious resource hog). Screen colors were slightly red out of the box as others have reported, but I sprung for a SpyderX Pro a while back so that was resolved with calibration.

With 3.02?

I thought they introduced this in 3.03?

I thought I went through every setting and didn’t find this. I’ll try again.

Great post here mate! Can’t wait to get my hands on mine and also see how it flies :slight_smile:

I’ve already (sort of…) planned the distribution of the M2 drive space on multiple OS’s and such… going to replace my laptops for that one since there’s plenty of possibilities there.

Really great to read about your experience!

1 Like

Linux Mint. Uses GNOME3/Cinnamon DE.

I was considering Manjaro but seeing as the install went so smoothly and everything just works with the 5.14 kernel, I’m sticking with it.

Still playing around to get things where I like. I can cheat it where I change the default font and icon sizes as well as the panel height. Inside applications I zoom in or out.

1 Like

Ah, you’re totally right. I’ve been a beta addict for so long that I forgot that the beta BIOS was the first thing I threw on my Framework as well.

I’d install the beta BIOS too, but I’m on Linux.

Updating this, I did some networking tests using iperf.

With a Club 3D CAC-1420 USB 3.0 to 2.5 GbE adapter over a dock (uses a Realtek RTL8156):

2.35 Gbit/s

2.34 Gbit/s connected directly to a USB-A port in the Framework

With the gigabit port in the dock, it’s a Realtek RTL8153:

896 Mbit/s

(not quite wire speed, I’ve seen 940-945 Mbit/s with some adapters)

With the AX210 connected to my ac wireless access point:

277 Mbit/s averaged over 3 runs

Which is very good!

I do notice the signal strength is a bit weak. It seems to report lower signal strength than most other devices. But the speed does not seem to be affected. I’ll do speed tests over several standardized locations in the house I use in order to compare devices.

Another first impression: because the touchpad surface is glass, it’s smooth as glass. The other two touchpads I have access to are covered in plastic, I notice a difference. One of them is wearing shiny. Very nice feeling touchpad on the Framework!

I remember seeing a tip somewhere, but they suggested pressing and hold the function key(s) (in this case F2) down (instead of spamming) to get into the BIOS/UEFI menu’s on basically all devices. Not sure if it applies to framework devices too, but it does work on my thinkpads and desktops.

1 Like

Interesting. I thought it was the keypress that triggered it, i.e. if the system didn’t see the keypress and instead saw a held-down F2 (triggered in the power-off stage and held through the POST stage) then it wouldn’t register.

Sometimes this does work, sometimes it doesn’t. I’ll try it on the Framework.

I’m benchmarking. I benchmark everything! I noticed the CPU “does exactly what it says on the tin.”

Normal workloads, the CPU boosts to 2800 MHz. It idles lower.

Heavy workloads, one core of the CPU boosts to 4700 MHz. (Well, one “fake”/hyperthread core goes up too - i.e. if the single boosted core is core 0 then the other is “core 5”, if core 1 then also “core 6”, etc.) Power goes up to 28W.

Heavy multithreaded workloads (only able to do this synthetically so far), all CPU cores go up to exactly 4100 MHz. Power exceeds 28W, approaching 40W. Perhaps this is total power.

I saw temperatures spike to 95°C for a second, once, but most of the time temperatures never exceed 70°C, usually in the high 60s even under heavy load with maximum fan.

Oh the fan isn’t terribly noisy either. Good cooling solution!

2 Likes

Yeah I’ve been very pleased with the CPU cooling in this laptop. My previous “favorite” laptop was a Lenovo IdeaPad 720s 14". It had almost the exact same footprint and was a genuine pleasure to work on, except that it had a terrible fan curve that Lenovo mysteriously never bothered to fix. The Framework laptop basically replicates everything I liked about that laptop, but goes a step further in so many ways.

The only other high performance laptop I have is my hopefully-soon-to-be-sold MSI GS30-2M Shadow. It’s got a monster Core i7-4870HQ in it (45W TDP) in a chassis thinner and lighter than the Framework. Needless to say, it runs HOT when pushed. And the tiny fan whizzes up in a desperate effort to cool it, sounding almost hysterical.

The Framework is much better in terms of cooling. Geekbench5 shows the Framework greatly exceeds it single thread but exceeds it multithread by a lower margin. It was a real powerhouse in its day but the Framework is better in every way with lower heat and longer battery life.

More interesting results: I’m running Prime95 and it’s defaulting to using AVX-512. I had heard that when using AVX-512 Intel CPUs throttle down a bit. All cores were first all exactly 3000 MHz, now they are 2800 MHz exactly. This is a very heavy load, all cores are 81-82°C with the fan at maximum. Power is approaching 50W.

After a few minutes, temp is down to 78°C, fans still at maximum.

Edit: temperatures back up to 82°C and holding. The maximum temperature of the keyboard is 42.3°C, so not unbearable. Centred over the CPU obviously, around the 7-8-9-Y-U-I-O keys.

Since we’re on the topic, I have an ASUS Zephyrus G14 (RTX 2060) and Razer Blade 14 (RTX 3070, 2021 version) that are getting basically zero use since receiving my Framework. I wouldn’t game on this thing, but it’s so good for development work that I don’t even bother picking up the other ones anymore.

1 Like

Ok I promised I would follow up with my own first impressions, and I finally have a moment to share my DIY experience. TLDR; this machine is absolutely awesome and I love it!

For reference, my configuration:

DIY Edition:
CPU: Intel® Core™ i7-1185G7
WiFi: Intel® Wi-Fi 6E AX210 No vPro®
BYO everything else (salvaged from old laptop): 2x8GB DDR4 3200, 1TB Samsung 970 Evo+
3 USB-C
1 USB-A

Setting up the laptop was remarkably easy. I ordered a wifi card, but had my own memory and NVMe drive in the wings. The trickiest part was getting the wifi antennas connected, but with patience it can be done. I also had a small memory issue, in that the memory I wanted to you (2x16GB DDR4 2666MhZ - Kingston if I’m remembering) was not compatible as far as I can tell. The computer wouldn’t boot, and the 11th led flash was red (signifying DDR4 memory issues). So after trying to reseat the memory to see if it was my problem, I swapped it out for some 3200Mhz 2x8GB sticks I had, and we were off to the races.

I installed Arch Linux, running a btrfs filesystem and KDE Plasma as my desktop environment. Installation went very smoothly, wifi and bluetooth worked out of the box, and I was up and running within the hour. I am experiencing the warm boot bluetooth kernel problem (which I knew I would) running the 5.14.12 kernel, but it’s workable. I just have to make sure I shutdown the machine completely instead of using reboot the machine and bluetooth works fine.

I have also been experiencing significant wifi slowdowns when using Wifi6 on my home router, so I have disable 11ax in the iwlwifi kernel module. I had a very similar experience with Wifi6 on a previous MSI laptop I had running an AX201 Intel chip, and I think it has to do with my router and not the wifi chips. The router is an eero thing that my ISP gave me and it’s truly terrible in terms of advanced user experience (eero has locked out pretty much all settings that someone would want to play with in favour of “user-experience” and "security) so I can’t really troubleshoot that. Overall, it’s not a big deal as I still get decent wifi speeds using AC instead of AX.

First Impressions:

  • Keyboard feel is awesome, the travel distance is a big plus and they feel bouncy and sound great. Trackpad responds well, I have installed touchegg to get macbook-esque features and those work great too.
  • The laptop is snappy! I had a decent intel 10th gen MSI gaming laptop prior to this and even with the significantly higher TDP for the CPU, it never felt as responsive as this Framework CPU.
  • The 3:2 screen layout was a good call. Coming from a 16:9 screen, I feel so much better writing and reading on the 3:2 display. It’s nice and bright, and colours come out nice.
  • The Framework is small, light, and very nice to take to travel with
  • It runs quite cool, and the fan is SILENT. Most of the time I don’t even notice it.
  • Battery life on linux is good (getting about 6-8 hours writing and reading). I’m not sure how it compares to other ultrabooks/laptops on the market, but it is WAY better than my MSI (where I was lucky to get 2 or 3 even after working out power management with the nvidia dGPU).

Things I don’t love (mostly nitpicky):

  • The trackpad click (which I don’t use much, I prefer tap to click) is a bit loud and high pitched.

Overall: Absolutely worth the money and the wait. If I have it my way (and Framework has it theirs) I will fix and repair and upgrade my Framework as long as that is possible!

PS: Benchmarks to come, curious to see how they line up with @Fraoch’s considering we have different CPU configurations.

5 Likes

Great!

For benchmarking, I’m using:

I have historical comparison data on all these going back decades - every computer I’ve ever had or had access to I’ve benchmarked. The Framework is the fastest laptop I’ve ever seen. Multithreaded it can’t match desktop Ryzens, of course, but single-threaded it’s quite potent. The performance is astounding considering it’s a 28W TDP CPU.

3 Likes