Just got my FW13 13th gen all setup - Some thoughts

Got it all setup, seemed like a breeze to be honest with the guides. Here’s just some random thoughts:

I’m dual booting Windows 11 and Ubuntu, both installations seemed to work ok with a bit of secure boot throwing a fit, also it really didn’t like ventoy.

The build was super easy, the laptop seems much smaller than I thought it would (not sure why, and it’s not a bad thing).

The screen is wicked, gets really bright.

The keyboard in the chassis isn’t quite perfect and thus the up arrow was fouling on the case, I could have a raised a support ticket but I decided to undo all 30000 screws and shift it myself, now all is good.

Never ran ubuntu before but really wanted to give it a go (I have some linux/terminal experience though). Seems less stable under ubuntu which is a shame, need to spend some time sorting a few issues I have.

Working great under Win11 and my HP thunderbolt dock.

Wifi speeds are great near the router, but seem to drop off a little bit quicker than my other laptop. (still 200mbps+ so not a major issue).

Fans definitely kick in to the max under a heavier loads. Just browing around it seems pretty quiet so it’s ok. But when a download or extraction kicks in, fan go brrrrrrrr.

Running it in power saving mode and seems plenty fast.


Which ubuntu version? Ubuntu 22.04 LTS is supposed to work out of the box Framework | Linux Compatibility on the Framework Laptop

Yeah the latest 22.04 from the website. It works out the box and I copied the terminal command from the guide.

Everything works and so far seems stable but i’ve had the odd crash, scaling seems off (firefox is really blurry). I maybe need to spend a bit more time with it.

It’s definitely usable, but at the moment, not sure i’ll switch full time.

whats your scaling set to?
if its fractional id set it to 100/200% and change the scaling in gnome tweaks

Probably a xWayland problem, you can look into running Firefox under wayland (well worth it for other benefits anyways!)

Yeah I was using 125%. I’ll look at your method.

I was also having an issue where WiFi wouldn’t work at all. Turns out windows fast startup was stopping ut

Are you using Firefox ESR installed via apt?
Are you using a snap package install?
Are you using flatpak?

If you are new to Linux, you might want to check our Pop!_OS. It is based from Ubuntu but has a lot more friendly UI.

I have both Ubuntu and Pop!_OS on both the 11th Gen and 12th Gen 13-inch laptop. I would not think anything would be different with the 13th Gen model.

I mainly went with Ubuntu due to its popularity and it being officially supported. Thought it’ll be easier to get help and support.

I think if I can get the scaling sorted it’ll be better.

1 Like

True, but historically back when the 11th Gen and 12th Gen models went to market first, POP!_OS was supported.

Framework has limited staff and cannot always test each Linux distro.

If you go to a bash terminal prompt and type:


The response would be either “x11” or “wayland”

You can also try:

loginctl show-session 2 -p Type  

The response would be Type=x11 or Type=wayland

The result would be either X11 or Wayland

or You can also try::


The response could be gnome-xorg or gnome-wayland.

When I ran into anything hardware related (especially when the Ethernet Expansion Slot came to market), the Framework support staff had a good suggestion: Try to use a Live version of the base OS (by running it on a USB drive). Base on what you experience on the LIVE CD, you can then open a terminal and run the above commands to check what was that configuration.

There could be a number of applications instances or configuration choices as Linux is very open to users to make all these decision.

My concern with Ubuntu is owned by the company Canonical and there are many decision being made that will impact the future of the distro. There are a lot of YouTube vlogers denoting this. Fedora’s Program Manager was laid off as part of the Red Hat’s changes and cuts to the OS and its sources. These two OSes could have future problems supporting a free version of the Linux distribution.

What does this mean:

» loginctl show-session self -p Type

I definitely do have Xorg running; started with xinit

here is a possible link for more detail (TL;DR): pam_systemd

$XDG_SESSION_TYPE is an environment variable that stores the type of display server the system is using. There can be many values “tty”, “x11”, “unspecified”, “wayland”, or “mir”

X Server was assigned a “dumb terminal” or “console”. On Linux distros, you can use the following key combination to switch the tty:"

CTRL + ALT + F1 would be tty1
CTRL + ALT + F2 would be tty2

CTRL + ALT + F7 would be tty7.
Older versions of Ubuntu would use these for example 17.10+ was using tty1 but 17.04 and previous version would use tty7.

hope this helps or provides some more info…

1 Like

if Ben is going to switch id recommend Linux mint and Ben have you tried what i suggested?