First impressions!

Gnome’s “Large Text” Accessibility option with 100% scaling for the display works well for me on Fedora 35


I couldn’t decide what was better: making the default text sizes bigger, turning text scaling up or using “large text” in accessibility settings.

I made the default text sizes bigger because it seemed to offer more control (fine grained 1 pt adjustments, 4-5 individual settings for windows, desktop, menus, etc.) but my only remaining issue is text spillover. For example, “longtext” spills over like:


Which is annoying.

After only one day:
Installed ubuntu 21.04 w/o a problem. No wifi set up or speed issues.
Only negative so far is trackpad seems overly sensitive and registers presses/clicks when not intended. Palm of my hand, I suppose. Also when two finger scrolling, initial contact registers as a right click.
I haven’t yet looked for an adjustment and it may be my heavy hands that are the issue.

Yeah palm rejection is pretty nonexistent, but I can’t give up tap to click so I’m just trying to adjust

What can I say that hasn’t been said already about this little machine. This is my first post using my brand new Framework laptop. I’ll break up this mini review into sections below:

The Keyboard & Touchpad
Typing on this thing is amazing. I truly love this keyboard. I’m coming from a Lenovo Thinkpad and I can honestly say they produce an amazing keyboard. But this keyboard feels just as good to type on and definitely beats anything that Apple can produce. The key travel is the right amount. The keys sound clicky enough without being mechanical. There is no delay between key presses and output written to screen, albeit, a lot of that depends on what OS you are running (drivers and all). The arrow keys are little funky but it’s not like I can’t get used to them. The test will be when I start my coding projects and typing for long periods of time. However, my early impression of this keyboard is that it will get the job done without issues. The touch pad is decent enough. I’m not much for touch pad’s. I’ll be using a wireless mouse most of the time.

Hardware Installation
I’ve been tinkering with computers ever since I was a kid. The very first computer I ever took completely apart and put back together was an Apple 2c. I’ve built gaming rigs from scratch and have been upgrading my “upgradeable” laptops for some time now. But over the last, I’d say ten years, that capability has waned with most of these computer manufacturers soldering and gluing down everything now. So when I heard about Framework and saw some videos, I was immediately hooked. Let it be known, I don’t need another computer in my inventory, but I just hope this thing becomes the only computer in my inventory. Framework has made it so easy to put this machine together. I know their initial hope was that they could sell the DIY edition literally in pieces. And if they were able to pull it off, I could’ve easily put this together from scratch. I was done within ten minutes with most of the time tackling the WIFI card. I can’t say more than what’s already been said or shown on YouTube but it speaks for itself. This computer is so simple to work with.

Expansion Card
All I will say is that I think port modularity needs to be the next paradigm shift in laptop manufacturing. It’s brilliant. If they can manage to shrink it down to get more ports to interface with the motherboard, it would be a Godsend. I would love the dongle business to die off.

OS Installation
I wish I could’ve said this was a breeze for me but it wasn’t. However, it was my own doing. I knew from the beginning that I could’ve put more mainstream OS’s (Windows, Ubuntu, Manjaro, Fedora, etc) but I chose to go with a distribution I wasn’t familiar with. It boils down to the fact that I wanted a challenge. Well, I got that challenge in the form of NixOS. From having issues creating Live Media USB’s using terminal, to trying to configure the correct channels (repositories in a sense) so I could get the latest packages. And, no matter what I tried, I just couldn’t get WIFI working and that was using an ISO from the most current unstable-branch. So I finally caved and went with Fedora. With Fedora, everything, literally everything, just works. I don’t have to hunt anything down. It’s perfect. I’ll add some gnome tweaking software so I can get the look I want but this OS just works, flawlessly.

I’m honestly not sure if I’ll run them. So many people have already and I can’t say my results would be any different than theirs. I’ll be making some tweaks to hopefully help improve battery life, so I may report on that progress using some benchmark data I log in testing, but I’m not running thorough system-wide benchmark testing.

DBrand Skins
I did buy a set to put onto my laptop but I haven’t had the time to do so yet. I’ll say I like what other people have shown. I think the skins are super cool and well made. I’ll post the final look of my all white and black matte style ASAP.

And last but not least, The Fan + Heat
Typing this right now, I can’t tell I have a fan inside this machine. When I was doing my OS installation, especially NixOS, the fan made itself known. That thing revved up all the way. It wasn’t loud pitched but you definitely knew it existed. It was throwing off some big heat by the hinge and was very warm by 6-9 and Y-O on the keyboard. I’m thinking it may have something to do with the OS’s being installed from Live USB sticks. But now that my OS is on the NVME SSD, it’s super quiet.

In Final
I’m very impressed so far with what I’ve seen. I can’t wait to see what Framework has in store for the future. Thank you for providing us this awesome first generation product, I absolutely love it.

Oh…there is one more thing I want to shout out about: My expansion card holder.


Thank you @nrp for providing the schematics for this. It’s definitely handy.


Fun fact: My partner turned the router off and back on again and low and behold Wifi6 speeds work fine now…getting 245mb/s on Ookla speed test (was getting around 30mb/s with ax disabled). Sometimes even the nerdiest computer folk forget to try the obvious :man_facepalming:


As procrastination from writing, I’m playing around with some CPU benchmarks on my i7-1185G7 now (my go-to for CPU monitoring is CoreFreq) and it is pretty much as it is labelled.

Heavy Multithread: If I run AtomicBurn through CoreFreq, all cores run at 4.290Ghz for a short while, until they thermal throttle down (hovers around 4.0Ghz, with temps in the high 70s/low 80s). If I run Prime95, it does throttle down a bit more (to about 3.1GhZ), with the temps the same as above.

Heavy Single Thread: Using the turbo round robin stress test on CoreFreq gets the real results on turbo (since the whole chip doesn’t get so hot) and I get 4.7Ghz turbo frequently, with the occasional jump up to 4.8Ghz as “on the tin”. One core gets quite hot (around 90), but it sustains the high turbo because the test jumps the work around the cores.

Most of the time power usage sits around 28W, but if the turbo is really going and I have a heavy multithread test going, I see power jump up to between 45 and 50W. But that’s only temporary, the wattage jumps back down to 28ish watts when it thermal throttles.

I have been seeing some of the weird performance governor issues with my machine, where sometimes when power is connected the CPU frequency absolutely tanks down to like 0.3Ghz when I run Prime95. I’ve only experienced this once, and it hasn’t happened again since. In this thread they are discussing that it might have to do with certain battery charge levels (and other threads have discussed issues with expansion cards), but Framework is exploring it so I’m not too worried (yet).


Complete review posted here:


Is it just me… or there’s no right click on the touchpad? If I press down on the right side of the touchpad it doesn’t right click (neither on windows or Linux)

Is that normal?

No that’s not normal. There’s something wrong with your trackpad.

There’s a thread here that discussed how some trackpads are not seated properly, that to correct this you press down in the exact centre of the trackpad very hard.

1 Like

Thanks @Fraoch for your hint :wink:

Cables were sitting in the right place but then I’ve seen that other people were facing this until they installed the appropriate drivers… Which I skipped… Because I’m an advanced dumbass who knows it all but that has always something to learn :wink:

It was the trackpad driver missing. After it installed everything seems to be working fine.

On with the setup and tests :slight_smile:



hahaha… found another road blocker… So… ANSI and ISO keyboards are a huge difference as there’s one key “missing” on the ANSI…

Basically the \ and <> are missing for me which sucks…

Sure hope Framework makes available the ISO keyboards soon so I can get one and replace this that the laptop has…

Here are my thoughts after roughly 2.5 days of usage. I’m running Plasma on Arch linux. I’m coming from 2015 Macbook Pro 13", on which I had the same Plasma-Arch setup. I was using a borrowed old-ish Macbook Air with macOS for a couple months before the framework came in.

It took me a little longer than expected to assemble the laptop, but that’s probably because I was being overly cautious. It was a fun—and unrivaled—experience. The WiFi card can be a pain to install though, as I’m sure you’ve already heard.

The Good:

  • The screen can get really bright. With Plasma’s fractional scaling everything looks pretty solid too.
  • The keyboard is great. I prefer it to apple laptop keyboards tbh.
  • The touchpad also feels great*
  • The anti-slip things on the bottom look like they’ll last. The ones on my previous laptop flattened and came off after a few years of use.
  • No camera complaints. The camera toggle on the bezel does its job just fine.
  • The expansion cards are a little hard to remove, but they look well-built.
  • I like the charging cable. It’s fairly long, but I still wish it were a little longer.

The repairability and upgradability potential should go without saying.

The meh:

  • The screen is really glossy; with dark backgrounds, especially with low brightness, you’ll be looking at your face a lot. I think I can live with it, so I won’t be buying a matte screen protector.
  • [*] I miss touchpad gestures and, to a lesser degree, tap to click. I’m a little spoilt by macbook touchpads. Also, I think I recently noticed some weird touchpad behaviour when the laptop is at an angle, but I’ll have to look into that more closely.
  • The hinge feels a little too wobbly. Particularly, the screen moves a little too much when I move the bottom of the laptop or the surface on which it’s placed. It’s definitely more of an issue here compared to the apple laptop line, but I’m not sure how it stacks up against other laptop brands.
  • The output from the speakers seems a little muffled. I haven’t directly compared it with other laptops’ speakers though.

The bad:

  • The CPU throttling issue. I hope there’s some way to fix this short of component replacements.
  • The ring of light around the power button is really annoying. I hear that we’ll get a BIOS fix for that at some point, so I’m looking forward to that.
  • The battery. I’ve been using devices with busted batteries for a while so I don’t have a good sense for what’s satisfactory and what’s not, but the ~4.5 hours I’m getting with the framework—with full battery health—seems a bit on the low side. I’ll look into the tips other linux users have shared.

Haven’t had a chance to set up or test the fingerprint reader or the in-built mic.

Overall I’m pretty satisfied and look forward to using this device for years to come!


Isn’t “spotty” redundant with “rural Canadian internet”?


Also redundant with “expensive”. :roll_eyes:

There’s a reason rural people are thrilled to pay Starlink $150/month, it’s a significant savings.


Elon/Starlink - take my money! Signed up ages ago, still waiting. “End of October” is fast approaching!


Indeed it is…I’m not sure what my mother-in-law is paying, but whatever she is it’s not worth it. It works for about 3 hours in the morning before the rest of the community wakes up…after that good luck!


Getting harder to wait for Starlink with their shifting availability. Gonna try Hell again (Oops, I mean Bell). They CLAIM their wireless service can bring 50/10 to my home. I’ll believe it when I see it. Bell promised they could bring 50/10 wired to an office I rented on their sayso (“It’ll actually be 12 or 13 up!”), and it turned out the best they could do was 24 down and about 3 or 4 up. After 8 months of fighting, they figured out how to make it 50/10. The next week literally the landlord repurposed the building and I had to find a new place.

Telecoms in Canada are a problem…in NS they’ve been talking about putting in high-speed lines to connect the province for years. The government give contracts and money to companies (like Bell), but the lines never get placed. I have family who had to try an do school online from outside the city during COVID lockdowns, and it was pretty much impossible for them. That’s unacceptable in my book.

Even for a cell phone, we are paying far too much compared to other countries

1 Like

My laptop arrived yesterday [free, two day express delivery from FedEx which was perfect] and so far I really like it… :grinning:
I’ve been waiting a long time for someone to design, manufacture & sell a quality, zero tradeoff laptop [that runs non-Windows] with this user-owned and repairable philosophy.

I bought the DIY version with the i7-1165G7, as I wanted the extra frequency and the 96 EU GPU.
Build instructions were well written and easy to follow, with the wi-fi card install being to only slightly tricky part.
Because my initial testing is with an SSD with Windows already installed, most annoying part was the windows driver install… I personally wish it was a zip file not a self-extracting executable file.
Note: after installing the Framework provided drivers, Intel’s Driver Support Assistant [that I previously installed when using the SSD on an 8th Gen NUC] found newer graphics drivers [direct from Intel], and they installed fine [I tested before and after performance using 3DMark].

I added a 32 GB set of Kingston HyperX Impact 3200 MHz [that I already owned from a previous ASRock X300 Mini project, that changed direction, and I ended up turning into into a min-NAS, running TrueNAS, that I gave to a relative].

Initial testing with Windows for benchmarking / browsing / video viewing / wi-fi and battery testing, etc. Everything looking good so far.
As expected, performance is very comparable to an M1 Macbook Air for CPU, with the Xe the GPU being better, but, again, as expected, the battery life is nowhere near as good; ~5 hours versus ~12+ hours].
Thermals seem decent.
Fan is fairly loud*, but OK, as the sound is not unpleasant [*it’s certainly loud versus the fan-less Macbook Air].

I have a 2 TB WD SN750 SSD arriving today that will get a clean install of Ubuntu 21.10 [with a 5.15.x kernel], and then I plan on using this as my daily driver… primarily to see if I can finally make the switch from OS X/macOS, which I’ve been using as my primary laptop and desktop OS since OS X release day [on a G3 Pismo]… :crossed_fingers: