FIXED: trackpad in linux

Downgrade libinput to 1.17.1-1. Version 18 has a bug where it wont work with some trackpads. This is why some distros like Ubuntu work fine with the trackpad and ones like Arch that used the latest release of libinput wont work.


@Tucker_Hoog Congrats to identify the bug. I assume the “Version 18” means the libinput version 1.18.0. It’s helpful for people using Framework laptop if you or someone would check if the issue ticket exists on the upstream libinput project issues or report the bug to the libinput project.

Someone on reddit pointed me to this: quirks: add Framework Touchpad Quirk (!665) · Merge requests · libinput / libinput

So I guess it will be fixed in the next libinput release?


By the way, on Fedora 34, the libinput version is 1.18.0 (the latest package version is 1.18.0-2 with applied patch: 0001-quirks-add-a-quirk-for-the-Huawei-Matebook-2020-touc.patch coming from the upstream libinput project, this commit fixing this bug on Fedora libinput RPM package.

So, if the bug you find does not happen on Fedora 34, I assume this patch file fixes the bug on other distros using the libinput 1.18.0.

If the file quirks/50-framework.quirks added after 1.18.0 release doesn’t exist on 1.17.1. So, I am not sure why the bug doesn’t happen on the 1.17.1 without the file.

But if the file fixes the bug on 1.18.x, the libinput’s next released version should fix the bug. :slight_smile:

Note: If you want to fix this now, you can create /etc/libinput/local-overrides.quirks with the contents:

[Framework Laptop Touchpad]
MatchName=PIXA3854:00 093A:0274 Touchpad

For Ubuntu & derivatives (PopOS, Mint, etc) and possibly more generally Debian-based distros, the .quirks file should go in /usr/share/libinput/ rather than /etc/libinput. Other than that wrinkle, this worked perfectly.

1 Like

Hmmm I am also having an issue where the two finger click is not registered (running Ubuntu 21.10) . and without “Tap to click” enabled I cannot ‘right’ click to open context-menus at all.

I’m running the latest arch (5.14.15) in a dualboot configuration. the above mentioned file exists at /usr/share/libinput/50-framework.quirks. I still can’t use the trackpad for more than cursor movements in linux. it works better but not completely in windows. More testing indicated.

I am using the latest stable Debian (11). I tried adding the quirk in /usr/share/libinput as indicated here but I still don’t have right-button functionality on the trackpad. Any suggestions to have this working with libinput 1.16.4 ?

EDIT - no quirks needed - using the Tweaks application, go to Keyboard & mouse > Mouse click emulation and make sure Area is ticked.

I’m running Sway and am running into the same issues. I have the quirks listed at /usr/share/libinput but no scroll or right-click although I can tap-to-click. I’ve tried disabling the PS/2 emulation but that removes the device entirely. Anyone have an luck?

That’s really odd. I’ll check in a bit about the right-click, but certainly my touchpad works with PS/2 emulation disabled (I know because I disabled PS/2 emulation to fix touchpad issues upon resume from deep sleep).

Oh, and my scrolling definitely works.

I did some more testing. It’s the Alpine kernel I believe. With it, libinput only recognizes it as a generic PS/2 mouse instead of the PIXA3854 touchpad. I’m going to try to build a new kernel to see.

@Evan_Hazlett any updates? I’m having the same problem, also on Alpine Linux (3.15, using -lts kernel).

I’m facing the same problem as @Sebastian and @Evan_Hazlett (libinput recognizes the trackpad as a generic PS/2 mouse in Alpine 3.15 – thus I have no right click nor scroll). Did one of you find a solution ?

Have you tried single-finger clicking in the front right corner of the trackpad? That is the equivalent to two-finger tapping on this trackpad in Ubuntu 21.10 (if tapping is enabled).


I just wanted to let everyone know: I have installed Kubuntu 22.04 (beta) on my Framework Laptop. At the beginning, I could not activate “tap to click” in the touchpad system settings, the menu item was just grayed out. And now, while I was preparing to report this issue here and wanted to make a screenshot of the said settings, the item suddenly was selectable. And not only that - it even works as expected.

Apart from that, there were no other problems with the touchpad from the beginning. So it seems that the device will work flawlessly with Ubuntu 22.04 once it is released.

Regards, Dirk

I’m running Gentoo, and I manually compile my kernels. I’m running into the same issue above of the trackpad not being detected, but it seems to me that this is a kernel configuration issue. Can anyone running Linux with a fully-working trackpad post the output of lspci -k, lsmod, and lshw (possibly to a pastebin of some sort)? Note that lshw may need to be installed.

lspci -k



On Linux Mint 20.3 with kernel 5.14.0-1033-oem.

Trackpad working perfectly.

Thank you very much - I was missing the hid_multitouch module (CONFIG_HID_MULTITOUCH). The trackpad works now.

Also, for anyone else experiencing these sorts of issues, if you are comfortable with kernel configuration, please see the Gentoo Wiki page for the Framework laptop.

1 Like