Touch pad issues

So far after trying a varity of distros on the framework ive been impressed just how seemlessly they all work. The only consistent issue ive run into is the track pad. No matter what distro i use, from pop os to void, the track pad on the laptop just never works(which is kinda weird because plugging in an external track pad works fine?) So im asking if anyone else has had this issue and if maybe a driver is missing or something.

Loose touchpad cable perhaps? Is it being detected by the OS (is it listed when you run xinput list or libinput list-devices?)
For me the touchpad had worked consistently across 3 different Linux distros.

Does it work in the BIOS menu? It should be emulating a PS2 mouse from the factory, meaning driverless operation even in BIOS. If it isn’t working then you may have a faulty trackpad cable, or a faulty trackpad itself.

I ran libinput list-devices and i see a ImExPS/2 generic explorer mouse (which i assume is the trackpad) and as for the cable i did have an issue with it at first but i made sure it was in already unless i didnt fix it all the way. But the rest of the keyboard works fine

So i took a second look at the keyboard connector and noticed that on the keyboard side the housing of the connection for the ribbon cable appears to be chipped. I assume it happened without me noticing. It appears to be mostly superfical but its enough so that i can see some of the metal connections. I’m a bit busy at the moment so ill send pics later but is there a chance that could have done it and if so it it possible to buy a replacement for that part/throw together a fix?

If it’s cut and not something you could fix with some solder then I’d reach out to the support email address with pictures. You could maybe get a new ribbon cable or something.

The cable is fine its the connector

Images i was refering to

Put in a ticket with support. It looks like at least one of those pins is lifted. You might get away with placing something non conductive across them and forcing them down, but I would be hesitant to do that with my own device.

I mean it doesnt work already so whats their to loose :stuck_out_tongue: plus ive already filed a support ticket. So i took some tweezers too it and some of the pins were definitely bent so I aligned them the best i could then covered it with electrical tape but still no dice

quick question, Which Batch is it from?

@Will1 your connector is definitely damaged.
The touchpad shows up as a PTP touchpad if it is recognized:
Device: PIXA3854:00 093A:0274 Mouse

The PS2 Mouse device is our fallback emulation layer that is present and gets enabled when the Tigerlake HID-I2C driver is not loaded.