Framework 13 13th gen Windows Install Failure

Hey. I have an issue installing windows 11 and 10 on my new DIY 13th gen laptop. I made a windows media creation tool, ran through the steps to install on the laptop, but every time it restarts it boots back into the windows install page. I get no error messages, it just goes back to the initial install page. I have tried going to boot manager to pick the drive but it never shows up. I know windows is installing somewhat because I took the drive out and read it with an m.2 to usb adapter and it had partitions and windows files installed.
The drive has worked for a year in my desktop. It is readable outside of the laptop. Bios shows the drive installed and gives correct information on its model and storage size, but it does not show up in the boot manager.

13th gen DIY
Middle Spec CPU
Samsung 970 evo plus 2tb
32gb Kingston Fury Impact 3200

Is your drive partitioned as MBR instead of GPT…from your previous sytems where it’s not running UEFI?

(i.e. Framework’s UEFI BIOS’s boot manager only shows / boots from GPT partitions)

I delete all existing partitions with windows install process.

I have a feeling that you still need to do a conversion…even with empty partition table.

i.e. An initialized MBR disk doesn’t auto convert to GPT when you’ve deleted all partitions

In my head, the rationale would be: Just because an OS installer doesn’t see the existence of partitions, it shouldn’t go and convert the table automatically / destructively.

Can I ask what a “middle spec SSD” is? Are you referring to the 970evo?

Can you see the 970evo in BIOS?

You’re using a Win10 and/or Win 11 boot image created from the media creation tool?

Have you checked to make sure the 970evo is fully seated into the M.2 slot?

Correction: middle spec CPU.
I can see the 970evo in the devices section of the bios, but not in the boot manager. Like the computer recognizes it, but not as a storage device.
I used both a win10 and win11 media creation tool using the usb rather than the ISO image. Same issue on both. I also used two different usb flash drives.
I have re-seated my ram and ssd once or twice.

I took the ssd out, put it into my working pc, and used diskpart to delete all the existing partions. Then I verified it is GUID partition table. I just reinstalled it into the laptop, ran throught the process again and got the same results. I ran through the windows installer, rebooted and it went to the same installer page once again. I then force closed the installer, used f12 to go to the boot menu and it still doesnt show my SSD.

Hum…funky…that the boot manager doesn’t even see / show the EFI partition on the SSD (after your Windows installation completion).

Is the windows installation complete after that first reboot? If so then you are exactly right.

To my knowledge, yes. The ‘installation’ is the process of setting up the partition(s), copy the files to the SSD, set the Windows Boot Manager. Then reboot…to Windows ‘setup’, from the now supposedly ready / prepped EFI partition on the SSD.

You’re not being booted from the EFI partition to the Windows “Setup” process.

I mounted an Ubuntu ISO and ran a disk program that allowed me to delete partitions. Then I installed Ubuntu. After making sure that my config worked in Ubuntu, I retried with the windows install usb drive and it worked. Im just miffed. I thought diskpart would have worked, but God bless linux i guess

Did you use diskpart CLEAN, and then init the disk as GPT, or CONVERT to switch the partition type? I have had some issues when trying to use CONVERT (e.g., it says it has converted the disk but didn’t) so if I use diskpart I just clean it and then initialize it as GPT.

I didn’t do any converting in diskpart. I verified it was already GPT, and I deleted all the partitions.