Framework 16: Fan spins up when booting into BIOS


I recently got my Framework 16 laptop. One of the first things I did after installing Windows is to update the drivers and the BIOS, i.e. the BIOS version is 3.03. My issue is that when I boot into the BIOS the fan starts to spin up after a few seconds and stays at that high level making lots of noise. How can this be fixed?

I cannot discern a root cause for this since the CPU should not be working that much when I’m only booting into BIOS. I don’t know if the issue already existed in an earlier BIOS version because I installed the BIOS update before booting into the BIOS for the first time.

The BIOS comsumes a whopping 45W. It might not be normal for the BIOS to consume this much, however, it’s normal for the fan spinning at 45W


Manufacturers often tune the pre-boot environment to run the CPU at full tilt, because it gets through boot faster. There is often a setting to control boot performance.

1 Like

And the differences between these settings are pretty large. With full turbo performance enabled on a 13 Gen intel platform I get from a cold boot resuming from hibernation in Windows 11 in just under 8 seconds. (And this is with a massive 64gb of system RAM, Windows uses some comprehension on the hibernation image, but still, big chunk of data to read and restore.)

Set this setting to maximum powersave and it goes up to a whooping 48 seconds.


AFAIK Windows only stores useful data on RAM to SSD upon hibernation, unlike Linux that dumps the entire RAM to SSD. Theoretically installed RAM should have no effect on Windows if the used RAM are the same.

1 Like

Yeah I think there is a bit of comprehension involved as well. Windows definitely does hibernation better. No question about it.

/begin rant

If the Linux world would stop giving hibernation the cold shoulder, we could change that.

/end rant (Sorry)

1 Like

Also the BIOS often runs in a very basic mode where a lot of energy saving code that would be present in a proper OS is simply not present.

In short, it’s normal.


That doesn’t sound realistic, when I did the hibernation stresstesting, it was significantly faster with nothing open that with a bunch of stuff open and there is nowhere in hell my ssd can write 64ish GB in the time it takes to hibernate, hell even if it compressed to 6gb that doesn’t sound right.

I do wish it got more attention but it works pretty well already.

Well NVME drives are fast, but I remember my 12th gen FW 13 takings about 30 seconds to hibernate under Ubuntu. I would literally pick it up and listen for when the fan cut off to know it was done. It takes significantly longer to hibernate and to resume under Linux.

When I can resume from hibernation on Windows from a cold boot and be back in my complete workflow in under 10 seconds, it really makes the power savings of hibernation a huge thing.

Linux has hibernation, but getting out and back in again quickly is NOT something that it does well.

I disagree with that. The BIOS is performing very basic tasks and should absolutely not be taxing the system to an extent where fans need to spin up, regardless of power-saving features. In the last two decades I have used lots of different notebooks and desktop comptuers, and the FW 16 is the first one where I have observed this behavior.

I am well aware of the speed of nvme, however the one in my framework isn’t 64Gb in a second fast XD, even hypothetical compressed 6Gb in a second is not all that realistic (at least writing, reading it could probably pull it of just barely).

Definitely not great but it mostly works.

But I certainly wish it got a bit more love.

Well, at least suspend to idle is more efficient than modern standby

It’s good to know, however, I was not talking about the normal boot process. I meant booting into the BIOS setup and staying there and doing nothing. The first few moments in the BIOS it’s silent but then the fans become very audible and stay noisy.

oh for sure! If you are on Windows, disable connected standby immediately, but really disable S0 altogether and just use S3.

There is ONLY the normal process. Whether it’s directed to the bios / uefi settings or handed off to an OS for continued booting it is all the same.

Your fans are running loudly because the system prior to an OS load is set to full tilt.

You can check this in your bios settings, I believe under boot performance. I’m unaware of anything being said in this regard about this being wrong.

I can appreciate that your experiencing working with other computers leads you to thinking something else, but in the case of the Framework 13 / 16 what is being explained in this thread is the case.

I just did a little experiment, according to my ssd during a single hibernate cycle there were a bit under 800mb of drive writes with 1.5Gb memory usage on a device with 64Gb of installed memory. Thatdoesn’t sound like dumping the entire ram to me.

If that’s the case, I’ll happily enable hybrid sleep instead of suspend-then-hibernate without worrying about the SSD’s data units written. Could anyone explain that why you need higher or equal swap partition to ram if you want to enable hibernate?

You don’t, it’ll just fail if you don’t have enough. Having equal size swap space (personally not a fan of swap partitions) is a pretty safe recommendation though, especially since a part of that swap could also be already used as regular swap.

There’s no option for that in the FW 16 BIOS. Anyway, I consider this post as solved.

1 Like

Those inside bioses are very “streamlined” to put it diplomatically.