Framework 16 RGB Macropad no longer has RGB?

When I initially installed my RGB Macropad it had RGB lighting for a few hours? Until the laptop went to sleep perhaps? Not sure when it died. I have tried toggling the RGB per the default keymaps Default Keymap for the RGB Macropad shown there. No luck still no RGB but it does work as a numpad. Anyone else had this issue? Should I try reinstalling it did a pin jostle or something?

edit forgot to mention running the latest LTS Ubunu 20.04.4 iirc

Welcome to the forum.

RGB toggle and BL step keys do nothing? Numlock is definitely on, e.g page down works?

You could check the lighting tab at

RGB toggle does nothing, nor does RGB hue +, nor RGB + sat, page up and page down work when toggled with numlock to confirm I am on the right settings when trying RGB toggle etc.

edit Downloaded and installed chrom as the didn’t work properly in firefox and connected to the macropad there it gave two errors as follows:


  • Failed to open the device.

  • Device: Framework Laptop 16 RGB Macropad

  • Vid: 0x32AC

  • Pid: 0x0013


  • Received invalid protocol version from device

  • Device: Framework Laptop 16 RGB Macropad

  • Vid: 0x32AC

  • Pid: 0x0013

1 Like

I’d give the controls on the lighting tab at a shot.

If it doesn’t start working right, then you can try a reset.

You can reset / clear the memory by remapping a key to QK_CLEAR_EEPROM, then pressing that key. Note that this will erase any changes you’ve made in Via (

  1. Go to If this is your first time using the site, you’ll have to authorize connection to your keyboard.
  2. Select a key to remap by clicking on it, the key will start to slowly flash
  3. In the key selection area below, click on the Special section
  4. Select the Any keycode, found at the bottom
  5. Enter QK_CLEAR_EEPROM and press Confirm
  6. On the keyboard, press the key you just remapped
  7. Reload for it to show the change

Sorry, I didn’t see your edit. Sounds like you might need udev rules.

This should add them, and it also reloads the rules in order to apply them.

wget && sudo cp 50-qmk.rules /etc/udev/rules.d/ && sudo udevadm control --reload-rules && sudo udevadm trigger

Then reopen your browser.

The keytester on the site works despite the errors but will continue looking into it. Thank you for your help.

edit adding the udev rules did improve said sites functionality.

Note that the lighting keys won’t show up on any key tester. Those keys are internal functions, so no keypresses will be sent to the operating system and a key tester will not show any press.

Remapped RBGtoggle to any then `QK_CLEAR_EEPROM confirmed I was on the proper layer of the macro and pressed it. It remapped back to default in as expected. Still no luck getting the RGB to actually toggle back on or increase hue etc.

edit pulled it out of the machine and reseated the macropad the RGB is working on it again!

If I recall, there is a sleep signal that is supposed to turn off the LEDs, maybe it’s stuck in that state.

I’d try reinstalling the macropad. I think as soon as you remove the touchpad it will disconnect power to all the modules, that might be good enough. Next would be trying a reboot.

Pulling the touchpad and then the macropad and putting it back together solved it at least for now. Didn’t try just pulling the touch pad sadly.

1 Like

Tangentially, Firefox doesn’t doesn’t enable WebHID I believe which is required for using the online QMK editor (Firefox’s position is seemingly that WebHID is unsecure, so I wouldn’t expect them to implement it any time soon). And Framework’s implementation also doesn’t seem to be standard VIA so the app version of VIA doesn’t seem to work either (at least when I tested it). Hopefully that gets fixed eventually.

Framework’s Via implementation is standard.
The Via electron wrapper app does work. But you do need to load the Framework draft definition. I had some trouble getting the app to detect a keyboard reliably the other day, but no problem today. The draft definitions are found here

Download the file(s) that correspond to your module layout.

Which keyboard layout do you need? ANSI, ISO or JIS

ANSI (American) layout. Note the shape of the enter key.

ISO layout. British is shown, but this layout is valid for many languages.

JIS (Japanese) layout.

In the Via electron wrapper app, go to the Design tab (paintbrush icon), click the Load button, then select your draft definition design file. If you don’t have a Design tab, go to Settings (gear icon) to enable it.

If you have multiple modules and multiple design files loaded, as I do in the screenshot, use the Shown Keyboard Definition dropdown to select which is active.

Do note that the Via electron wrapper app is like a self-contained web browser. And it won’t load without internet access.

1 Like

Sadly the problem has returned after shutting the laptop down and restarting it. This appears it is going to be an ongoing problem.

edit no luck reseating the macropad this time either

If you haven’t already, I’d suggest contacting support at this point.