Framework 16 Sound Quality

I had already tried reimporting to no avail. As well, the FW13 profile has the same issue. However, with that information in mind about it being a highpass filter, I corrected the filter in the GUI and then exported it. Examining the JSON, I see the following:

"filter#1": {
            "bypass": false,
            "frequency": 100.0,
            "inertia": 20.0,
            "input-gain": 0.0,
            "mode": "36dB/oct Highpass",
            "output-gain": 0.0,
            "resonance": -3.0
        },

You’ll note that this is different than how your json is formatted. It seems as though the modes my version of Easy Effects is expecting differs from yours, so it’s defaulting to the first option, which is a 12dB/oct lowpass filter.

I’m using Easy Effects 7.0.7 on Ubuntu 23.10 for reference. I expect that your json is probably fine, but there is some discrepancy here in software which is unexpected. I’m not sure there’s any way to universally fix this. But, for anyone else experiencing the same issue, it should be an easy fix at least.

Hmm, interesting. I am on easy effects 7.1.5 on nixos 24.05. It seems odd that they would change the preset naming or syntax, but maybe that’s what it is. I’m glad you figured out the issue though.

I don’t have any personal experience with it, but I know some other users have had success with fxsound on Windows. There’s also equalizer APO, and it’s GUI called peace which work great. It’s just an equalizer though, so it wouldn’t be able to do the exact same thing as this preset which is using a variety of sound processing techniques.

For any stumbling across it. Installing pipewire, easyeffects etc on your system (in my case Arch) may be not enough!
Some packages for enhancing the sound were optional and needed to be installed afterwards manually, for my case:

  • calf
  • lsp-plugins-lv2

After installing both of them and a quick reboot, my sound did change remarkable according to the loaded presets.
For other distros it may change.

1 Like

This is hands down the best profile I have found for the Framework 16. The bass is just simply incredible.

Thank you very much for your work!!! As a fellow musician and a beginning music producer, I appreciate it immensely!

1 Like

I wonder if the Framework team could possibly fit this into a firmware update. Not sure if the Audio IC has a tunable equalizer.
Same as the 13 tbh, the mod sounds way better but running EasyEffects kills battery (software accelerated equalizers are not fun). Would be great if we could get it in firmware!

1 Like

I’ve had real difficulties getting Pipewire to run without crackles and pops during a CPU intensive task (gaming), I’ve tried a number of the typical pipewire troubleshooting suggestions but haven’t quite gotten it working yet. Currently I’m running pulseaudio for the simplicity, but it’s definitely a downgrade without the easyfx profiles.

1 Like

I agree. Any way to tag someone from Framework to this thread? It would be awesome if this profile replaces what they’re currently used for the “Linux compatibility” audio profile in their firmware right now.

I did notice that in Windows, while still not sounding great, it doesn’t sound nearly as bad as Linux without the EasyEffects profile.

Still, with or without EasyEffect, Linux or Windows… the overall volume is not that loud. At max volume, that’s here I consider loud enough. Which means that at 50% it is way too low compared to 50% with other laptops.

Anything below 30% is not usable for me, even in a quiet room (especially over the fan).

If they can scale the volume up louder at 100%, so 50% is reasonable, then the lower percentages would actually be usable for quiet room usage (hoping down to 5-10% for whisper quiet level).

2 Likes

I noticed when plugging my headphones into the USB-C audio expansion card, EE profiles also applies to that output, making the sound more bassy. Is there any way to only apply EE profile to just the Speakers output?

This is likely down to pipewire using too small of a quantum for wine apps. I had the same issue on nixos, And it was resolved completely by increasing the quantum for pulse audio applications up from the default.

You should be able to resolve the issue by adding custom pulse configuration. See this thread for an example configuration. This is on the nixos forum, but it should work for any system running pipe wire and the pipe wire pulse module.

On my system, a quantum of 256 at 48 khz completely solved the crackling issue in wine games.

4 Likes

This is the kind of stuff that needs to be added to the framework 16 setup guides

3 Likes

Thanks! I’ll try that out

2 Likes

It looks like that solved the issue for me! So glad to be able to use your profile again, it’s a big upgrade.

Glad it worked for you! It took me forever to track down the cause, and it was butchering the music in Balatro for me, which really sucked because that game has a great soundtrack.

Bookmarked the fix for when my Batch 17 arrives. Thank you FW community.
:grin: :pray:

I was playing around with Easy Effects, trying to follow a guide linked from the help documentation, and I got a weird result.

Modifying only the High-Pass filter, using an allegedly 100 Hz tone from YouTube, changing the filtered frequency from 30 Hz to 50 Hz results in a noticeable drop in volume coming out of the laptop speakers.

I can’t get the same result using headphones. Is the uh, Linux BIOS thing transforming lower frequencies into higher frequencies?

Hello
Is there a way to screenshot the frequency curve, so I can try to replicate it on windows via equalizer apo?

I rarely listen to anything on my laptop speakers. Also never had a laptop that sounded remotely good… I am not a gamer.

Still waiting for my batch 16 but starting to plan projects for it. I will be Linux only. Mint will likely continue to be my home distro but I’ll load Ubuntu and Fedora to play with them. I have never found a reason to use Wine.

The fix outlined here is something I would consider 'cause I like to fiddle with things, but I have a question.

By installing Pipewire, EE will I be using any additional resources (Processor activity, energy, memory, etc) that will be completely wasted if I am not using the speakers?

Is there a guide on how to do have it only apply to the built in speakers and not external speakers? Tried looking around a little bit and haven’t been able to find anything

This is a setting available in EasyEffects

1 Like