FTDI Devices on Arch Cause Errors or are not Detected


One adapter I’m having issues with can be found here. I found another post of someone using a similar adapter to mine here. I am running firmware 3.10 and am running a fully updated Arch environment. I can take these adapters and plug them into my desktop and they work perfectly, but on my framework they either do not appear or result in messages like the following in dmesg.

[  936.796798] usb usb2-port4: Cannot enable. Maybe the USB cable is bad?
[  941.226798] usb usb2-port4: Cannot enable. Maybe the USB cable is bad?
[  941.226922] usb usb2-port4: attempt power cycle
[  946.026831] usb usb2-port4: Cannot enable. Maybe the USB cable is bad?
[  950.416886] usb usb2-port4: Cannot enable. Maybe the USB cable is bad?
[  950.417046] usb usb2-port4: unable to enumerate USB device

I have one USB-A adapter from Asunflower that does generally work correctly, but I do not have it on my person to dig into any messages it generates when it does flake out on occasion. I tested a different USB-A adapter from a friend in case it is an issue with my two USB-C cards, but it ends up with the same messages in dmesg or it also just isn’t detected.

I have swapped ports around for testing to see if that helps anything, but have not found any better luck with alternative configurations. I’m wondering if there are any troubleshooting steps I should take or other messages I should gather. I have had some other issues with my laptop (touchpad not aligned correctly and sometimes not registering clicks, microphone DoA), so wondering if maybe it’s just poor luck on my laptop. On the linked thread, seems like the issues were solved with a firmware update, but I should be clear on that front.

I wanted to share that I ran into errors with the USB-A framework module and a micro-usb to usb-a cable attached to an ftdi usb controller on the device end.

When I used a different USB-A to USB-C converter into a USB-C port on the framework it worked just fine. When I attached a micro-usb to USB-C cable that worked just fine as well.

I was seeing errors like “error from flowcontrol URB”, and after a sequence of failures when attempting to communicate over serial, the whole framework USB-A adapter would stop working until I plugged it back in again.

I believe this could indicate some sort of electrical failure for the framework USB-A module/adapater.

I tried multiple boards that i’m working with, multiple micro usb to usb a cables, and multiple power supplies for my device, as well as 2 framework laptops.

Wanted to share this warning for other people in case its helpful

TL;DR: ftdi failed across micro usb to usb-a cable into the framework usb-a to usb-c converter module. It worked to the USB-c port directly and with a different convertor going into the USB-C port.