Found a USB device that won't work, what feedback do you folks need?

Hey gang. I purchase a USB to Serial rollover console cable that arrived today and it seems to not get along well with the framework in either windows or linux. It just connects and then disconnects a few seconds later over and over. The device is found here and is a FT232R USB/Serial adapter. It works a treat on another box.
So far I’ve tried Windows, Linux, a USB Hub and a USB A to USB C adapter with the same results. The only odd outlier is that if I use a hub, I don’t get connect/disconnect message but the adapter still doesn’t work. In all cases the device is identified and the appropriate driver is loaded.

1 Like

I ordered one and will see if I can duplicate the issue. Sometimes these ultra low cost cables are FTDI clones and may not work 100%. I have used our laptop successfully with a number of other usb-uart bridges including prolific, and ftdi (from sparkfun so should be genuine).


right on @Kieran_Levin Those clone cables are a real pain. The one I managed to snag appears to be legit, at least FTDI isn’t bricking the USBID when it loads up, I’d be happy to send you mine if you want.

@Kieran_Levin I see similar behavior as the OP except that the device I have works when I plug it into a hub; it’s an (OBDLink EX) with some sort of FTDI USB to UART, I’m pretty sure has a real FTDI chip (especially because their firmware update utility uses FTDI signed DLLs) or I would be pretty sad because its not cheap!

are you able to boot a linux distro real quick, even one on USB, and see if that shows up as a 232R device? If you aren’t familiar with linux, let me know and I can give you better instructions on what we’re looking for.

@Scratch I pulled the VID/PID from the reader; VID_0403 and PID_6015
PID 6015 according to libfdti’s source code is FT230x

same VID different PID here (6001) which makes mine a 232RL.

Something interesting is happening with this. When I plug this device into left side of my framework (currently it has a storage card installed and a USBC port) it seems to be ok and working.
When I plug it into the Right side (where the power button is and where I currently have the SDCard reader) it does the plugged/unplugged dance over and over AND seems to reset the SDCard reader too!
Is there a significant difference between the left and right side ports?
Can you confirm with your device @bakedpatato ?

Interesting, I get the opposite! On the “left side” it repletely disconnects while on the right side its been connected without problems.

And on the left, if I have my TB3 dock connected then connect the reader, it makes the machine reboot!

ok. I’m gonna spend some time today trying to narrow this down. so far, the FT device is the only thing I can get to trigger this but we’ll see what else I have laying around here.

Another device I found that doesn’t work on the right side but does work on the left
idVendor=10c4, idProduct=ea60, bcdDevice= 1.00Product: CP2102 USB to UART Bridge Controller

I’ve swapped the USB ports around, tried USB A vs USB C, removed all expansion cards etc and still run into the same behavior. @Kieran_Levin did you receive your adapter? I can ship you some of the ones that are causing me trouble if it would be helpful. I’ve tried several different types of devices from bluetooth adapters to microphones and it seems to be limited to a few USB-Serial adapters and localized to just one side of my machine.

1 Like

@Scratch I got my adapter and I can replicate the issue on the upper right, and lower left ports. When this happens the PD controller reboots and both ports on that side are disconnected and reconnected again. (These are both port 0 on the PD controller on each side)
It will take some time to root cause this and get a fix, but while this is getting fixed I think you can use the other 2 ports.


@Kieran_Levin no worries at all. Let me know what I can do to help.

@Scratch I was able to root cause this to a firmware bug in our PD controller.

It looks like this device has a high inrush current, and causes the overcurrent detection signal to glitch. We are supposed to debounce this in firmware, but the code doing the debouncing was only handling this correctly for 1 port on each controller.

If an overcurrent condition happens on the upper right or lower left ports on bios 3.03 or below it will cause both ports to reset on that side.

To mitigate this, use the other port on each side until the firmware update is available.

I am planning on rolling this into release 3.04 assuming all our testing is ok.
I don’t have an exact ETA for this update yet.


right on! That had to be a huge pain to track down, well done!


I have two SanDisk 16B USB 3.0 drives that show in windows up but go away and throw errors when you start copying data off them. It happens on both right side ports. Have not tried the left side yet. Other USB flash drives or USB external SSD drives work fine. These same SanDisk drives that don’t work in the Framework work fine in all my other computers.

Is this the same issue as above?

I found a flash drive with a strange behavior. Specifically Kanguru Flashblu30 8gb, 32gb, and 64gb. Plugging them directly into the USB-A expansion card results in nothing happening. No device detected and the LED on the drive doesn’t light up. That said, if I use an A to C converter, including the A expansion card, and connect it to a C card, the flash drives work properly and I can read/write at full speed. All my other flash drives work properly with the USB-A card.

So you mean you can take the A card out of the computer and plug it into one of the C cards, and that works, but the A card directly doesnt? Maybe you just have a problem with the port the A card is normally in.

I’ve seen this before with some USB 3 drives. The connectors seem to be just a hair too long, Try plugging it into the A port and then slowly sliding it back out, fractions of a mm at a time, and I bet it will suddenly pop up as available.

1 Like

I don’t think so, it wasn’t detected regardless of which slot the A card is in.

I just tried this and slowly removing the drive still does nothing, however it does show up when I slowly insert the drive! Thank you for this suggestion, now I don’t need the weird double adapter workaround.

I will say I’ve noticed the same thing, detection being kind of wonky with my USB-A card when using a USB 3 stick. I only have the one USB 3 stick so I haven’t been sure if it’s the stick or the port at fault.

Is the suggestion that there’s something out-of-spec with the USB-A card? I’d have thought the physical port would be a quite standardized part. Surely “slow insertion” shouldn’t be required, though.