FW16 USB PD Battery Issues

Hello

I already went through framework support for this and they were not able to give me any solution, but I figured I could write about it to see if anyone else has this issues. In my talk to support they said they are working on a firmware update to fix this so I hope it gets resolved.

I have a Anker battery (this one) that I bought in anticipation for my Framework 16, however when I got it, it essentially refused to charge it at any reasonable speed. With the framework USB-C cable it would charge at 0.1w (reported by the battery) then spike to anywhere from 3-18w, when it would do so windows would detected it for short periods of time.
battery_behavior

When I tried to use the anker cable included with the battery it charged consistently but only at 20w.

The battery is capable of 140 out, and it charges all other devices as expected. During my talks with support I also tested all the power capable ports with and without USB-C expansion cards and they all behaved the same.

2 Likes

I’ll be following this and I’ll let you know if I have the same issue in a couple days when my laptop arrives. I had the same idea and bought an Anker power bank. I’m using the Prime power bank instead though.

Stay tuned.

1 Like

I’d reach out to Anker, talk to them. Might be a slightly not working USB-PD implementation that’s tuned/tested on MacBooks.

1 Like

I’ve also looked at the Anker battery. Following this thread for developments.

“What are the chances it’s the exact same model I bought?”
It’s the exact same model I bought.
Batch 16 here so I won’t be much help for the next eight batches.

Is It the Anker 737 by any chance?

Bought that charger just for this laptop and now I’m worried…

1 Like

Yes, I didn’t say 737 because when I talked to support they got it confused with the 737 wall adapter for a bit, but it is that battery just the old version not the new one with the prime charging stuff

Yeah that’s the one

Great I hope they get it working soon or that’s £90 wasted.

I do have a 100W power bank as well but the capacity isn’t as big (Shargeek Storm 2 Slim)

1 Like

Do the Shargeek work?

I’m batch 9 so haven’t got my laptop yet.

That device Is mainly for my Nintendo switch and phone though, hope it does work.

Sounds like a compatibility/handshake problem. I’ve got a Mophie one that does 45W via PD and it works fine.

Then I can, if all goes well, answer that question by Friday

I bought an Anker 737 battery on sale last week after seeing how much use my boss got out of it. It charges my FW13 (Intel i5 Gen11, Batch 4) at 60w to 70w consistently. It’s pretty awesome.

Really hoping this issue gets resolved before my FW16 (batch 17) arrives. Worst case I can just give it to the family member I’m giving my old FW13 to. At least they’ll get more use out of it than I will. :sweat_smile::battery:

Support mentioned it was an AMD board only issue and they do seem to be working on a fix.

“We want to inform you that we are currently working on firmware updates for PD charger compatibility for our AMD systems as with our recently released Framework 13 BIOS update. We will be sharing more information regarding this very soon.”
- Support

1 Like

I can confirm my Shargeek Storm 2 charges my FW16 with 90 watts right now, although it takes some time to start sometimes

Edit: dropped to 55 watts and refuses to rise again even though I’m discharging the battery with a benchmark right now

1 Like

Looks like they fixed something - for the FW13

Update: I’ve gotten my laptop and I have no issues when using Anker Prime power bank

Interesting, so it must just be the older version with this issue

I and someone else have the same issue with the same powerbank

I’ve updated to bios 03.03 on FW16 and it’s still happening which I’ve reported here

I’m still not sure if it’s a powerbank issue or bios issue