[GUIDE] LVFS Fingerprint Reader Firmware for Framework Laptop 13, 13th Gen Intel Core & AMD 7040 Series fingerprint reader on Fedora 39 and Ubuntu 22.04

The 3rd and 4th:

The 5th and 6th (last):

I now realize that I should have tried again when it failed to download the metadata for lvfs-testing. I might try again tomorrow. For now, I’m out of replies to this topic, since I’m a new user. Also, if it matters at all- my computer suddenly slowed down a lot after the fwupdmgr enable-remote lvfs-testing line, to the point where every mouse movement took about 3 seconds. Was fine once I rebooted.

No worries, I totally get it - when you need to get stuff done, you do what is needed. Appreciate you closing the loop on this. :slight_smile:

Everyone else, please, please do not use this section as a guide. Start here please as not to snowball any confusion.

First off, welcome to the community! Sorry for the Discourse limits on posting, I know it’s a pain. :slight_smile:

Ideally, a new installation has been done so via our install guide to get you into a recommended kernel and made sure they were on a correct kernel. But that is another post. Put a pin in that for now. You can revisit this later.

  • In the 3rd image, I see where the attempt to resolve the cdn for lvfs-testing failed. Not sure if something was out dated as you would normally have run through the guide, and rebooted after the updates for apt and snap were run. Or it could have been a genuine CDN failure.

Without lvfs-testing there is nothing to update. So we need to understand why that didn’t work. The CDN appears to be up now. I’d try the following.

fwupdmgr enable-remote lvfs-testing

Then continue on with

fwupdmgr refresh --force

and we can skip get devices as we already know which version you had 01000320 and we want to update it. We’ll jump right to that process.

fwupdmgr get-updates 1e8c8470-a49c-571a-82fd-19c9fa32b8c3

and now that we retrieved the updates available, lets install

fwupdmgr update 1e8c8470-a49c-571a-82fd-19c9fa32b8c3

NOTE: You will absolutely see this error:

failed to write: failed to reply: transfer time out

  • This is fine. Give it two minutes, then I want you to reboot using this command:

sudo systemctl reboot -i

Thanks for the welcome! I’m very excited about my new laptop :smiley:

As you can see from the screenshot, it still thinks that Fingerprint Sensor has no available firmware updates.

Although this time when I rebooted my computer it said there was a Software Update and gave me this error, not sure if it’s related.

…and I should have noted Secure Boot IS disabled. And jst tried the commands you gave me again after rebooting, same thing.

Hello Matt,
thanks for your patience and support!

I’d just leave it here as well, that using snap might install an even higher fwupd version than is described in your knowledge base guide.

Using another distro, but also tried to use snap, I backed down to use fwupd via flatpak and rolled back the version to 1.9.7 via flatpak update --commit fdf15f34e36e8cc4aa2e050cd90a186c95a446b9c73b163c563a4f983939ebf3
Manually installing the .cab was successful, as described in your guide.

Using the lvfs-testing repo did not work for me at all.


I just tried this update on Fedora with my Framework 13" laptop (11 gen Intel), the fingerprint sensor reported version 01000248.

The update command did fail on my laptop, the exact error was:
failed to get device before update reload: failed to wait for device: device 4295296d98b3ba38c72f6baa33d24f03a1d428f6 did not come back
Then I was unable to reboot because a process from fwupdmgr claimed that the update was still running in the background.

After waiting for 10 minutes I force rebooted my computer with: systemctl reboot -i

Now when checking the device version I display the correct last version but I also have an error saying the device wasn’t updated correctly:

When retrying to update the device nothing happens:

I tried reinstalling the firmware on the device with:
fwupdmgr reinstall 1e8c8470-a49c-571a-82fd-19c9fa32b8c3

But I get the same error as when I’ve done the first update:
failed to get device before update reload: failed to wait for device: device 4295296d98b3ba38c72f6baa33d24f03a1d428f6 did not come back

I’m wondering if this is maybe because the fingerprint sensor is working on my laptop and is currently setup on my user. Could it be that gnome/fedora tries to access/start the device during the update process and this causes the update to fail?

Hi @depate,

Correct, we need a higher version due to some recent changes. The snap version tested correctly on two separate new input kits using my provided steps.

That said, like last time we tried lvfs, we again have a mix of folks who have found it was not working for them and working for others. Appreciate you sharing your findings.

Appreciate your feedback on this. Making sure after you noticed it said you were at 01000330 that you then went into Users in GNOME on Fedora and tried to registering it (after rebooting)?

Yes I did and everything is working fine, I was able to remove my previous prints and register new ones.
The update is just failing at the last step after timing out on the waiting step, I get the error I shared above but the update seems to have succeeded theoretically given that the device seems to be on the latest version.

The only annoyance is that I can’t get rid of the message saying the update did fail but this is not impacting my experience at all.

I did not use snap because I found the documentation on how to roll back the fwupd version directly for flatplak and not for snap or my package manager.

Just to make sure: using fwupd 1.9.10 worked for you on your replacement input kits?

I’m a fan of lvfs and would really like to see it working for the Framework for all the firmware related updates.
I’d be happy to help.

Shout-out to Matt for setting the parameters and giving clear instructions. Alas, I am already on (K)unbuntu 23 and don’t want to revert so I’m not directly participating. My installed firmware is 3.19.

My system is dual boot and ever since I first got my Framework13 it has appeared that only one OS can “own” the fingerprint reader, either Windows11 or Linux (I have 2 OSs installed).

I can report that it appears to still be that way. If fp works on Windows and I configure it on Linux it stops working in Windows (but does work fairly well in Ubuntu 23, fwiw). Since I prefer fp on Windows I reverted.

Does Matt or anyone have insight into whether this ownership limit will persist (because security, duh) or will it get resolved so that the hardware can be shared but securely?

Is it normal to receive this error?

fwupdmgr enable-remote lvfs-testing

(/snap/fwupd/5438/bin/fwupdmgr:4171): Fwupd-CRITICAL **: 18:29:23.377: fwupd_checksum_guess_kind: assertion 'checksum != NULL' failed

Stlil failing:

name@name-framework:~$ fwupdmgr get-devices 1e8c8470-a49c-571a-82fd-19c9fa32b8c3
Selected device: Fingerprint Sensor
Framework Laptop 13 (AMD Ryzen 7040Series)
└─Fingerprint Sensor:
      Device ID:          23ec719b6aabc2d2dac5176c232f0da7a21881b0
      Summary:            Match-On-Chip fingerprint sensor
      Current version:    01000320
      Vendor:             Goodix (USB:0x27C6)
      Install Duration:   10 seconds
      Serial Number:      UIDXXXXXXXX_XXXX_MOC_B0
      GUID:               1e8c8470-a49c-571a-82fd-19c9fa32b8c3 ← USB\VID_27C6&PID_609C
      Device Flags:       • Updatable
                          • Device can recover flash failures
                          • Signed Payload
      Device Requests:    • Image
name@name-framework:~$ fwupdmgr get-updates 1e8c8470-a49c-571a-82fd-19c9fa32b8c3
Selected device: Fingerprint Sensor
Devices with no available firmware updates: 
 • Fingerprint Sensor
No updatable devices
name@name-framework:~$ fwupdmgr update 1e8c8470-a49c-571a-82fd-19c9fa32b8c3
Devices with no available firmware updates: 
 • WD BLACK SN770 500GB
 • Fingerprint Sensor
No updatable devices

Thank you so much, this looks like exactly what I need. But, after fwupdmgr enable-remote lvfs-testing I get Failed to connect to daemon: Error calling StartServiceByName for org.freedesktop.fwupd: Unit fwupd.service not found.

Just received my Framework 13 Ryzen. I am running Kubuntu and I also run into the “No update available” message.

bolk@Kubuntu-Framework-13:~$ fwupdmgr get-updates 1e8c8470-a49c-571a-82fd-19c9fa32b8c3
Selected device: Fingerprint Sensor
Devices with no available firmware updates: 
 • Fingerprint Sensor
No updatable devices

Is there any other way to update the firmware without reinstalling the O/S? In the meantime I will try to USB boot live versions of other distro’s.

Edit: managed to make it work by following this guide and manually download the .cab file: Updating Fingerprint Reader Firmware on Linux for 13th Gen and AMD Ryzen 7040 Series Laptops

It all works until fwupdmgr get-devices 1e8c8470-a49c-571a-82fd-19c9fa32b8c3. After that I get a screen that looks similar to the one of Matt_Hartley, but slightly different:

I suspect that at this point I am already on the wrong track. I tried everything. Erasing and reinstalling Ubuntu, retracing exactly the steps described. Nothing worked.

Was able to get it working by following this guide. Will I need to do anything in the future to make sure the fingerprint reader takes new updates?


Quick update:

NOTE: Folks, if you find you’re on FP reader firmware 01000248, you do not need to do anything. This is for those on 01000320 only as we need to get you to 01000330.

For those who have not been successful, please recheck the following:

  • Ubuntu 22.04.3 or Fedora 39, not Ubuntu 23.10.
  • Ubuntu 22.04.3 users, you are certain you are only using the Snap version.
  • Fedora 39 users, make sure you followed the steps to roll back your fwupd version.
1 Like

Seems like I spoke too soon. It worked at first, but now won’t recognize my fingerprint. Going to enroll a finger shows:

Might be a coincidence, but I’ve now experienced two full system freezes, where I’m forced to hold the power button to cause a hard reboot. This hadn’t happened prior to yesterday.