Handbrake's intractable window on Ubuntu

Is anyone else running Handbrake on Ubuntu (Jammy Jellyfish) on the Framework?

I don’t know if it’s the 3:2 ratio or just (more likely) some cavalier programming on the part of the Handbrake devs, but the Handbrake (v.1.5.1) window won’t resize properly.

Its window decoration lacks a maximise button so it either occupies the whole screen (vertically, with horizontal margins that can be eliminated manually—weird) or disappears. When fully inflated it misunderstands the Framework’s screen real estate and hides its lower pixels below the bezel.

These lower pixels have important work to do: they show the encoding progress bar.

I’ve tested this with the Ubuntu Store snap installation and the flatpak installation recommended on the Handbrake site and both reproduce this same problem. Likewise running with Wayland or xorg.

It’s entirely possible that I’m missing something. If folks here can either steer me right or confirm, I’ll be able to decide whether this is something to take to the Handbrake devs.

(ISTR that the Handbrake devs can be extraordinarily snappy. I did suggest to them years ago that it might be useful to offer a pass-through option for the video for any user who just wanted to re-encode the audio. I was firmly reminded that Handbrake’s function was as a video re-encoder.)



I don’t see this issue when running the flatpak on Fedora 36 however is does not tile with the super and arrow key left/right combination, maximise and restore (super+arrow up/down and via UI) work as expected although on restoring it shifts down and to the right off screen so you have to reposition the window to see encode progress etc. if that is helpful to you or not I’m not sure :sweat_smile:

Maybe I don’t understand the problem but I don’t see any of what you’re saying: I have a maximize button (I believe this is controlled by gnome-tweaks, on Gnome at least) which works fine, and it maximizes correctly either by double-clicking the titlebar or the maximize button. Even if it didn’t, the normal “drag the corners” resizing works fine too.

This is just the apt/.deb install so neither a snap nor flatpak, but I don’t know if that matters.

Thanks for that very useful feedback, @Usernames and @John_Flatness. Having fiddled about with this for far too long I now find myself in that not very useful (to others) situation where I seem to have solved the problem with no clear idea how that came about.

I do have confirmation that there really is a problem—the Handbrake devs are doing something non-standard with their windowing that at least one other person has found troublesome.

My “solution” was to try to gain some screen real estate by vanishing the window decorations (Undecorate Window) and the Top Bar (Hide Top Bar, a Gnome Extension). Having done this, I then found I could (whether as a consequence of these vanishings I can’t be sure) unmaximise the window with Super+Cursor Down and move it around the screen with Super+TouchPad drag. Restoring the window decoration (Alt+Space Decorate) has created what seems to be a permanent Maximize/Unmaximise window button that now maximises the window correctly to include the progress bar at the bottom.

So, job done.

But it would be unfair to close this off here, because I’m not at all confident that what I’ve tried to report here accurately and succinctly (there was much more messing about and I’ve omitted what I believe to be red herrings) will work for others. A thorough job would entail running all this from scratch on a fresh Ubuntu installation. I’m not inclined to do that for what looks like an issue of only marginal interest. But if others pile in here with the same problem I certainly hope to be able to respond and test.

Oh, and @John_Flatness, I did search for the handbrake deb and could only find the flatpak on their site. Where did you get yours?

1 Like

I just installed from the Ubuntu normal repos. Maybe it’s the same version you’re using, but mine definitely isn’t a snap.