[RESPONDED] I'm about to go back to Windows

I need to rant some, but I’m also looking for advice to see if I can salvage my Linux experience. Any advice is appreciated.

I recently got my AMD Framework 13, and I’m stoked to use it more and really put it to the test. I installed Ubuntu 22 on it. This is my first attempt at daily driving Linux and not Windows. I’m a software dev so I feel like Linux should be a better fit for the work I do. I had no trouble sorting through some of the setup and config issues, but I’ve continued to have some usability issues, which I think are mostly Linux related.

I dock my Framework with a USB-C dock and an ultrawide 2K monitor, and I keep having problems with the scaling. I turned on fractional scaling (which apparently sucks) and set my laptop and monitor to reasonable levels, but my primary browser Firefox keeps having problems where the menu buttons disappear outside the bounds of its window. And no amount of moving and resizing will fix it, I have to restart the app. I’ve also had problems with it disappearing into some phantom display that I couldn’t see, and I had to fish the window back. Today my display settings reset, so scaling was back to 200% and monitor positioning was wrong. I fixed the settings, but now Firefox is permanently scaled way up (like tabs, font, and buttons are huge) and I haven’t been able to fix it.

Another issue I had was downloading a video and playing it on my TV. I download certain videos from certain websites and they always play fine on my Xbox. It’s just an mkv file. I did the same workflow on my Ubuntu Framework, and when playing on the Xbox Media Player the video would crash about 10 minutes in. I also noticed couldn’t seek (fast forward/rewind) in the video. If I open the video in Windows Media Player (or whatever they call it now) on my Windows 10 PC I get the same behavior, video crashes several minutes in and can’t seek. If I download the exact same video on my Windows Laptop it works perfectly fine.

Ok, so when the video didn’t work, I thought “I’ll just plug my Framework into my TV with an HDMI cable and watch it that way”. Nope, it wouldn’t connect to the TV. Slotted in my HDMI card, plugged it in, laptop screen blacked out and came back, but no signal to the TV and no display listed in settings. TV is a 4k TCL with Roku and has never given me trouble with other devices. Not sure if it’s a Linux issue or Framework issue.

Not to mention installing programs can be annoying or confusing. If something is listed in the “app store”, sometimes people leave bad reviews and say “this version sucks, download from the website”. So I download from the website, but then I can’t install it because idk it errors and says it’s not compatible with my system.

There’s some other problems I could rant about but this would go on forever. I knew I’d have to do some tinkering with Linux, but it’s really frustrating when the most basic crap doesn’t work without an hour of troubleshooting. On the positive side, the OS is extremely responsive and quick. This thing flies! Also, I’m fairly comfortable on the terminal so I enjoy having that extra power.

Just wanted to see if I’m missing something here, if people think these gripes are more Linux issues or Framework. I suspect the former. Thanks for reading and for any advice.

We’re here to help where we can. :slight_smile:

Not entirely sure which release you are using, however we do ask folks looking to Ubuntu to consider using the guide for the Long Term Support release we mention in the welcome email.

Step 9 and step 10 are important as this is what we test against.

Ah, I see what is happening. Yes, some docks do not do well. We test against and recommend using the HDMI and DP expansion cards as we can’t control what the docks are doing. Some docks work fine for video output, some are a hot mess. It’s frustrating and I totally get how annoying this is. We’re simply unable to vet and then collaborate with all the dock manufacturers to make sure everyone’s firmware is on the same page.

This is something I’d need to see logs for (in a ticket). If it is crashing on the Framework, that would be odd. Crashing on the Xbox using the Framework as source, could be a variety of factors that the logs might shed light on.

Is this connected through the USB-C dock to your TV’s HDMI port? If so, we recommend the HDMI expansion card. If this was using a HDMI expansion card for this instance, we’d want to see logs in a ticket. I use my TV frequently for this and have not experienced any issues with this on the HDMI expansion card.

I hear you. And I agree, the app store could use a little bit of clarity there. In this instance, I could likely help if you provided me with a screenshot of the error you’re seeing and the application you’re trying to install. “Usually” the app store is pretty reliable, but, some applications can be buggy. Happy to help reproduce.

Please bear with me as I say this. I say this as I have friends and family members who simply prefer Windows. Linux may not be right for you - and that is totally okay. Linux, any distribution of Linux, is not going to be like Windows. It’s designed differently, has completely different strengths and weaknesses. And it’s certainly not for everyone.

Eons ago (been doing this for a few decades), I used to tell folks to take what they know about Windows and what they expect, then toss it out of their minds. Approaching Linux as someone with no expectations helps a LOT.

Now for reasons of practicality, this is not always possible. Some folks have work they need to get done. If this is the case, creating a persistent Live USB may be a better approach.

The advantage is you have an escape hatch when something isn’t going well. You shrug, reboot back to Windows. But, as time and patience allows, you’re able to boot to said USB key and bang away on those challenges that might crop up.

To wrap this up:

  • Linux and Windows behave completely differently. There is a learn curve.
  • A persistent USB key may be the best tool to get your feet wet, while still being able to get things done on Windows in the meantime.
  • Errors experience, see individual responses above.

May i suggest Going bck to Windows - and installing WSL instead to play with and get the ropes of Linux before going whole-hog and frustrating yourself? I’d hate to see you have a bad experience. as commenter said above me - Linux is not Windows - it has different design goals and uses. I do understand your frustration (i had to daily drive a mac for a couple months and it was infurating)

I do wish you the best of luck on your Linux jeorney how ever yo udecide to go; its a powerful OS that can do a lot with hardware if you put the time in. Unfortunatly its not as point-and-click easy as Windows can be.


You could run Windows, but also run Linux in a guest environment.
You can keep the Windows installation very clean that way, and do most of your stuff in a virtual machine (or multiple virtual machines).

1 Like

Sorry, just had to deal with this in an Enteprise environment…don’t touch WSL if you can help it, it is a hot mess.

My recommendation as always is latest Fedora. Also your firefox issue sounds like it is not running in wayland. Check about:support to see if it is running with Wayland or X11.


I admin a large company - we have lots of success in WSL. to each their own i guess?


Thanks for taking the time Matt :man_bowing:

For the release version, I am using Ubuntu 22.04.3 LTS. I did follow the guide you linked, including steps 9 and 10 for the configuration and bios update. I’m not sure I caught the kernel update stuff, my current kernel version is 6.2.0-37-generic. I will at least give those steps a go.

Ok, fair enough. I will try just connecting to the display, I don’t really need the dock these days anyway. Had the window issue happen again, here is a screenshot:

As you can see, the window is small but the elements haven’t reorganized themselves. I think it happens randomly when I move Firefox from my laptop screen up to my big monitor. I can still move it, but can’t resize the window in this state. I just have to restart the app.

The crashing happens on Windows, either on PC or Xbox, while playing the mkv that came from the Linux Framework. I put the video on a USB and plug it into the Xbox to watch. Admittedly, the media player app on Xbox is garbage, but it has always worked for this purpose. It’s bizarre that the same video, downloaded from the same place doesn’t work when downloaded from the Linux OS. Could be the software I’m using. There’s more that I can tinker with there, so I wouldn’t worry too much about it.

This was directly from the Framework to the TV, using HDMI expansion card and a good HDMI cable. Funny enough, I tried again today and it connected just fine, albeit with some noticeable lag. Just now, I also tried connecting my monitor via HDMI and expansion card like you said, and it worked for a while, but when I re-enabled fractional scaling (tinkering with the scale issues again) the signal went out, similar to the TV. Had to go back to the dock for now. Also, I confirmed I am using Wayland.

That’s actually a really good idea, I might do that. I wonder if it would be better to do development in such an environment or stick to the more complex Windows + WSL experience? I mean, I need a development environment (mostly php), but I also need the reliability of Windows for more basic work.

Thanks again Matt!

And thanks for the other replies everyone. I did confirm on the terminal it looks like I am using Wayland. I am familiar with Linux in the context of doing server admin stuff, ironically it’s the casual stuff that I’m struggling with here. :sweat_smile: I have used WSL on Windows before as well, it worked but also felt like it added layers of complexity to things (and was sloooooowwww), so I was hoping a pure Linux experience would be easier. I haven’t tried Fedora, I kind of thought Ubuntu would be easier, but I will take a look at that as well.


best of luck. Every day is a learning opportunity! Good luck out there

1 Like

I would advise using a rolling distro or at least more recent one than Ubuntu 22, since this will give you latest kernels, drivers and also X and Wayland (Wayland supports different fractional scaling on different monitors). Also KDE - KDE has much better support for fractional scaling than Gnome, especially coupled with Wayland.

On the other hand Firefox supports their own scaling - check about:config - layout.css.devPixelsPerPx, set to 0.5 to scale down from 200% to 100%.

P.S. I’m using an extension card disk as a persistent device - just copied another already installed drive to it and booting from it does the trick. Granted, I boot Windows that way (I only use Lightroom there), but this should also work with Linux.

Concur - WSL works well, and the latest version (2.0.x) is even better. If you prefer Windows for your workflow/stability/app compatibility/gaming AND want to use Linux for Docker/development etc. then WSL is a good option.


This may be the case in many environments, but in a secure environment this is simply not the case (not suggesting your environments are insecure, just very likely not what I mean when I say secure). Wish I could go into details but I simply can’t. If it does not work in a secure environment I generally don’t recommend the use of a tool for home use. The user is simply better off either running on bare metal and figuring out solutions for the issues (which ubuntu exacerbates by using snaps for a lot of basic applications), or running a full blown VM.

Well, sufficiently “secure” depends on the risk profile around your usage - combination of sensitivity of data/processing, security controls in place and threat landscape - so difficult to conclude on the appropriateness of security based on a different context.

Anyway, you might be interested to learn that the latest version of WSL2 now applies Windows Firewall rules(!) to WSL2 traffic and that you can deploy Microsoft Defender for Endpoint into the WSL2 instance ( New enterprise-grade security controls for the Windows Subsystem for Linux - Windows Command Line (microsoft.com)

Improves prevention, detection and management somewhat.

1 Like

So - the Linux UI depends largely on the used backend → X-Windows / Wayland. Also, the frontend needs to be adapted nicely to it.

Because I’m a long time linux geek (Started end 1992), and KDE fan (did the entire french Translation for KDE 1.0), I first stuck to KUbuntu, but lately for my daughters Slimbook KDE they used KDE Neon plain on it. And that’s what I’m using here too.
KDE plasma is IMHO way more suited for HIDPI displays nowadays, and KDE Neon makes sure I always have the latest stable plasma release running on it.
To that I add the right kernels (HWE kernels are enough on 4800U cpu), but you should probably use the c-kernels for the 7840xx cpu’s.

Note that I am using Linux as my work OS for over 30 years, and I write this out of KDE Neon using a KVM integrated to my Display through DP.
USB-C display has always been a question of “chance”. Sometimes it works, sometimes it does not. Hence I avoid it for that.
I run it on an old Intel based CPU, but my daughter runs it on a AMD 4800U cpu just fine.

Operating System: KDE neon 5.27
KDE Plasma Version: 5.27.9
KDE Frameworks Version: 5.112.0
Qt Version: 5.15.11
Kernel Version: 6.2.0-37-generic (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-8550U CPU @ 1.80GHz
Memory: 31,1 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620

May I suggest Podman desktop over WSL ; it’s far less delta between actual linux. And is portable.

I ran into issues with fractional scaling and GNOME as well.
Turns out, KDE/Plasma on wayland works much better in that regard, especially with legacy X applications.

Thanks, I’m checking out KDE Plasma on Wayland right now. It looks really sleek, I’ll give this a try for a bit.

1 Like

The reason I use KDE Neon, is that they use the latest patches available for Plasma, which makes it the best KDE Plasma experience.

Rolling distros based on KDE get these too. :wink:

1 Like

Yeah, but not the main driver of KUbuntu deals with these rolling distro’s.
In terms of integration, stability and hassle-less operations, it is amazing.

1 Like

The stability has notbing to do with the release model though, it depends more on QA before pushing new updates. In my nearly 10 years of using arch linux I only had an undocumented breakage after update… once? (systemd-boot suddenly failing to parse my loader config)

So yeah. I’m currently on kde-unstable, using plasma 6 beta 1 and the wayland session is much more stable than 5.27 (was getting weird artifacts with my 2k@144Hz monitor otherwise). Loving finally being able to set different scaling ratios for different monitors.