HDMI expansion adapter does not work in one slot

I got around to testing all my expansion modules on my 2 week old framework 13 13th Gen i7. The HDMI adapter (version 3) does not work properly in the front left slot (next to microphone port).

When the adapter is in this slot I get video briefly then the screen goes blank. It usually flickers on and off every minute or so, but that’s the best I get when the adapter is in this front left slot. When moving the adapter to one of the other three slots in the laptop, all works ok. No issues.

I then tried a displayport adapter also purchased with the laptop. This adapter works fine in all four slots.

I’m running windows 11 Pro. It’s fully patched and I have the 13th gen driver pack installed. I even tried updating the Intel based drivers using the driver update tool Intel supplies. Same issue with the FW drivers as well as the latest from Intel.

I also checked device manager and the HDMI expansion adapter shows up properly as a USB device when insert into any of the four slots. I don’t see anything unusual when a external display is connected while the adapter is in this suspect front left slot.

I’ve opened a support case. Anyone experience similar or have a thought? I did read about others, with previous generation laptops, having one or more bad USB C ports requiring a motherboard replacement. However in this case the displayport adapter works just fine in this same suspect slot. USB C and USB A adapters also work on in this same suspect slot.

With the HDMI adapter I’ve tried several different cables, a couple of different monitors as well as a new Sony 4K TV. Same issue with all displays when trying from the front left slot.

Thanks in advance for your help with this while I wait for support to reply.

I am having the exact same problem.

Reach out to support. I got a replacement motherboard that does not (so far) exhibit this issue.


I have the exact same issue in my 13th gen laptop - same slot, too.

After reaching out to support a new motherboard is on its way.

Hopefully you’ll have the same success I did. Working well so far.

@Scott_H Thank you for letting me know. I am currently in contact with support.

The motherboard replacement did not appear to solve the issue.
In short, after some testing the port(s) affected seem to reliably work with Ubuntu and certain specific version of Intel’s GPU drivers, but present issues with most other versions I’ve tested (e.g. with the version installed by the driver bundle they very reliably do not produce an output at all, despite detecting the monitor).

I have recapped my experience thus far in this thread.

I’m still in contact with support for possible further troubleshooting.

1 Like

Thanks for sharing. I have the same issue, same port. I had to switch the hdmi expansion card on the right side.

Are we sure there isn’t an easier (and cheaper) solution than a motherboard replacement ?

That’s the thing, though - either I got a second dud with a very peculiar hardware defect that gets triggered under very specific circumstances, or it is indeed a software issue since depending on the software running (different OS or different driver release) the behaviour is different and the ports may work.

It’s quite puzzling and the weirdest thing.

The next suggested step is to remove the driver with DDU, and then let Windows Update do it’s thing, which should bring me to version I’ll get to it this evening.

A further update: a second replacement MB will be sent.

I’ll be equally puzzled if it turns out to fix the issue and if it turns out not to fix it, it’s so odd.

Good news. Hopefully the second motherboard does the trick. More important is that FW get to the bottom of this issue. My suspicion is that they have a timing problem that could be component selection related and/or it might be in the underlying design or PCB trace layout. Hopefully it can be addressed through a BIOS update

See, that’s my suspicion as well, especially since it seems to me from reading about HDMI issues that the left front slot is more likely to be affected, but it’s not like I’ve been keeping count of these topics so it might not be so.

Still, the fact that the ports seemed to consistently work with different OSs and specific driver versions makes me think that there might be a software component to this fault, but here I’m speculating.

It might be a hardware issue like you described that for whatever reason is more likely to be triggered with different software.

We’ll see how it goes with the third board.

I get this weird feeling that engineers designing motherboards for other OEM/ODM’s look at the FW model and say - Good luck to them making a motherboard with universal USB C / TB4 ports.

Hope I’m wrong!!!

1 Like

Also the second replacement motherboard didn’t help - still, before and after changing it I tried with a Ubuntu live USB and there all ports seem to work, so I’m leaning to this being some kind of software issue.

For now with support we decided that I’ll observe the behaviour under Windows 11 as Intel goes through some revisions of its driver and we’ll see.

Which intel driver is support referring? There are some newer drivers than those shipped in the FW driver bundle. GPU, wifi and Bluetooth are all readily available on the Intel driver site.

I’m seeing this issue on Debian 12, Debian Trixie, and Ubuntu live on both left ports (haven’t tested the right ones yet but I don’t have my hopes up).

Infrequently it is able to detect the monitor brand & resolutions if it was plugged in while booting, but it fails to actually display video on the monitor, getting stuck in a display reconfiguration loop. Sometimes it’s fails to detect monitor metadata and it presents a generic monitor vendor & resolution. Might try looking into what xrandr thinks is going on, but so far this looks like a hardware issue to me…

12:08:14 fw kernel: usb 1-4: new full-speed USB device number 19 using xhci_hcd
12:08:14 fw kernel: usb 1-4: New USB device found, idVendor=32ac, idProduct=0002, bcdDevice= 0.00
12:08:14 fw kernel: usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
12:08:14 fw kernel: usb 1-4: Product: HDMI Expansion Card
12:08:14 fw kernel: usb 1-4: Manufacturer: Framework
12:08:14 fw kernel: usb 1-4: SerialNumber: [serial number]
12:08:14 fw kernel: hid-generic 0003:32AC:0002.0013: hiddev0,hidraw2: USB HID v1.11 Device [Framework HDMI Expansion Card] on usb-0000:00:14.0-4/input1
12:08:14 fw mtp-probe[5414]: checking bus 1, device 19: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-4"
12:08:14 fw mtp-probe[5414]: bus: 1, device: 19 was not an MTP device
12:08:14 fw mtp-probe[5426]: checking bus 1, device 19: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-4"
12:08:14 fw mtp-probe[5426]: bus: 1, device: 19 was not an MTP device
12:08:17 fw kernel: i915 0000:00:02.0: [drm] *ERROR* [ENCODER:266:DDI TC3/PHY TC3][DPRX] Failed to enable link training

I was interested in an FW13 for sale online in a secondhand capacity, but spooked by the owner saying he had this issue.

Seems pretty widespread based on the small sample size here.

I am having the same issue in the same slot on the AMD 7040 MoBo

For the AMD motherboard, this is normal.
In the following webpage, go down in the “Interfaces” section: Framework | Choose Framework Laptop 13 DIY Edition (AMD Ryzen™ 7040

1 Like