Unstable HDMI output on left front and right rear expansion slot

The purpose of this post is to document the issues I’m having with the HDMI output when the expansion card is inserted in two specific slots, in the hope that others having a similar issue might find this useful. I’m still in contact with support to try to determine a cause/solution, at this point.

I purchased my 13th gen Framework 13 right on start of availability in Italy, and shortly thereafter I noticed that in some of the expansion card slots the HDMI card would behave in an unreliable manner - specifically in the front left slot especially. For reference, I’m running Windows 11 Pro as my OS.

Specifically, in these two slots the HDMI card would show up, detect an external display, but not seem to be able to produce a valid display signal unless the machin was woken up from sleep with a display directly attached.

After some initial troubleshooting, FW Support sent me a new motherboard, but the issue persisted and seemed to extend to also the right rear slot.

I then tried a live Ubuntu 22.04 LTS USB, with which the affected slots worked well.

Prior to attempting a fresh Win11 install, I also tried to “fully” install Ubuntu 22.04 to the system drive, following Framework’s procedure, and in this case also the affected expansion card slots worked fine.

Finally, yesterday I re-installed Windows 11, following Framework’s guide including the installation of the driver pack, and the issue returned: with the graphics driver included in the bundle, dated from March, the affected slots did not produce a valid video signal at all.

At this point I let Intel’s Driver and Support assistant, which gets installed along with the graphics drivers if I recall correctly, look for a more up to date version and it suggested me I install this version of the Arc Pro drivers - at the time of writing - and with these the problematic ports seem to work fine.

As a test I decided to manually install the current release of the Arc & Iris Xe drivers - at the time of writing - with these the HDMI output in the problematic ports once again became very unreliable.

Finally, I manually installed the Arc Pro drivers (see item nr. 3) and the ports were once again working well - from my point of view it seems like an issue that is either caused or compounded by specific versions (or releases belonging to different OSs) of the Intel graphics drivers, but I welcome any other idea concerning a possible cause.

After some time, Windows update bumped me to version - here the issues returned, with a quick recording of them available here: https://youtu.be/ObXTWsyY0U8?si=SywNGKRUF-bw-L2k

At this point, I once again installed the latest Intel Xe drivers, version as mentioned above, and still the output from the affected ports seems unstable: https://www.youtube.com/watch?v=RSZbv3Kj7is


  • at every manual install of the Intel drivers the “clean install” option was selected
  • at no point did the other two ports (left rear and right front) exhibit any problem. These always worked, in every test.

I have not seen widespread reports of the issue, but it’s also the kind of issue that might go undetected if someone were to just not use one of the affected slots.

1 Like

Hi, I’ve had similar issues with the Ryzen 4780 version under Windows 11 for the past two days, just today experiencing the same problem also under Ubuntu 22.04.
For me it seems to be slot 4, so the front right slot.

I’m gonna monitor this issue and possibly proceed with more findings in the future.

I had the same issue on my 11th gen Framework. I solved it by using a small extension cable for USB C. I don’t know why it’s working when the extension cable is plugged in but if I insert the HDMI expansion card straight into the laptop, the monitor randomly switches off. When I use this small extension cable, it works without problems.