[IN TICKET] Ethernet card not working on Ubuntu 22.04 Linux

  • Which OS: Ubuntu 22.04.1
  • Framework laptop: 11th gen
  • If this is a Linux issue, please use the Linux tag or at least put Linux in the title.

Hello, I am having issues getting my laptop to recognize the Ethernet USB module. I have an 11th gen i7-1185G7, up to date as of Jan-17-2023 for the BIOS and firmware. When I plug in the Ethernet card and plug a cable into that, I get no connection. If I close my laptop and let it sleep, I see the lights on the connector light up, but am unable to see what happens as once I open the laptop there is no connection. I have tried it on all port spots and had the same results. Any ideas? Please let me know if there is any more information I can provide. Thank you.

Hi @Strongthany,

Confirming this is one of the expansion cards we offer, correct? If so, please check dmesg -t for:

cdc_ncm 2-3:2.0 eth0: register ‘cdc_ncm’ at usb-0000:00:0d.0-3, CDC NCM (NO ZLP), 9c:bf:0d:00:0e:38

cdc_ncm 2-3:2.0 enp0s13f0u3c2: renamed from eth0

usb 2-3: USB disconnect, device number 23

xhci_hcd 0000:00:0d.0: WARN Set TR Deq Ptr cmd failed due to incorrect slot or ep state.

cdc_ncm 2-3:2.0 enp0s13f0u3c2: unregister ‘cdc_ncm’ usb-0000:00:0d.0-3, CDC NCM (NO ZLP)

Let me know if you see these.

Hi @Matt_Hartley

I sadly don’t see that, here is some of the output from dmesg -t

usb 2-3: new SuperSpeed USB device number 3 using xhci_hcd
usb 2-3: New USB device found, idVendor=0bda, idProduct=8156, bcdDevice=31.04
usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=6
usb 2-3: Product: USB 10/100/1G/2.5G LAN
usb 2-3: Manufacturer: Realtek
usb 2-3: SerialNumber: 4013000001
usbcore: registered new interface driver cdc_ether
cdc_ncm 2-3:2.0: MAC-Address: 9c:bf:0d:00:09:a4
cdc_ncm 2-3:2.0: setting rx_max = 16384
cdc_ncm 2-3:2.0: setting tx_max = 16384
cdc_ncm 2-3:2.0 eth0: register 'cdc_ncm' at usb-0000:00:0d.0-3, CDC NCM, 9c:bf:0d:00:09:a4
usbcore: registered new interface driver cdc_ncm
usbcore: registered new interface driver cdc_wdm
usbcore: registered new interface driver cdc_mbim
cdc_ncm 2-3:2.0 enx9cbf0d0009a4: renamed from eth0

I can confirm that this is one of thet expansion cards FrameWork offers. Please let me know if I can provide anything else.

No idea how I wasn’t notified about the update on this post - that’s on me.

Please go ahead and open a support ticket, let those who answer the ticket to escalate this to me directly. Link to this post, let them know Matt from Linux support asked for this to be escalated to me directly.

1 Like

Not a problem. I’ll get that ticket open. Much appreciated.

1 Like

I have this exact same problem as well. I’ve swapped everything out except the computer and adapter module. Just ordered another adapter to see if it’s hardware.

When the computer is sleeping, it comes up but in 100base or 10base mode (same color on my switch). The LEDs on the adapter are solid orange and green, one each. Waking up the laptop brings the link down, and I can see the LEDs flicker every now and then on each end.

Having messed with Ethernet chipsets at work myself, it looks like when something doesn’t have enough power, or some other self-protect function: it detects the link, but resets when it tries to bring it up to Gigabit or faster. Then it retries after a few seconds.

My switch is a D-Link with 8X 1000baseT ports. I don’t have any Nbase-T gear yet, aside from a Mac Mini.

i went through something similar (got another card as a result of my support/RMA ticket, new card had the same issue)

i was able to find this post from another thread that helped me: [SOLVED] Ethernet expansion card is not connecting - #11 by anarcat

essentially, it seems like the power management (tlp i think) on ubuntu is doing something incorrectly with this ethernet card. i see the same behavior on both of my basically-new ethernet cards.

the linked post has a command (something like echo 'on' > '/sys/bus/usb/devices/2-3/power/control'; ) to make sure the card is on, not being auto-power-managed by tlp. This mayde my ethernet cards work as expected. Farther down in the thread theres also instructions on how to exclude the eternet cards from TLP more permanently in case you dont want to run a command like that every time.

although this is probably more of a workaround, so it may still be worth following up with support to help them find the root cause of why tlp isnt playing nice with these cards.

it also looks like TLP is open source, so maybe, if this is reproducible on other ethernet devices with a RTL8156 controller, it might partly be solveable with a contribution to TLP to better handle that controller.

FWIW, i have a UGREEN brand USB-C dongle with an RTL8153 in it (gigabit) and that has always worked fine. not sure how similar those controllers are tho. there do seem to be a few results for RTL8153 in the TLP repo and none for 8156. maybe that says/points to something useful?

1 Like

Appreciate your feedback with this. Yes, I generally making sure the TLP config is setup as show in my TLP GUI (because it’s easier to read for this purpose) has the card set as follows. I set it this way for a different USB device, but you get the idea.

I can confirm that disabling autosuspend for 0bda:8156 immediately brings LAN expansion card to life.

Kubuntu 22.04.2, 5.15.0-69-generic.

1 Like