Installing Cloudready ChromeOS

WIFI isn’t supported on the AX210. you will need to replace your wifi card or use ethernet for this to work!

Doesn’t work:
Fingerprint reader

Does work:
Everything else

Download Cloudready from CloudReady for Home: Free Download — Neverware
I suggest using the USB creator, but either way create yourself an install USB drive following their instructions.

Boot the USB drive by inserting it into your frame and spamming FN+F12
After it boots
If you want to install to the SSD, click on the clock in the lower right hand corner and select “Install”
If you want to install to an expansion card or other removable device
login with the username chronos
cd /usr/sbin
sudo chromeos-install --dst /dev/XXX where XXX is the device you want to install chromeOS on
wait until it’s complete
sudo poweroff

and that’s it. Pretty simple.


Because of the age of the kernel in this OS?

ChromeOS supported hardware is pretty small, but I bet it will be supported in a few revs

Any recommendations for a supported WIFI card?

And when you say it doesn’t support Sleep, if you close the lid, does it just stay turned on?

Thank you for spending the time! You literally just saved me a few hours :). I would buy you a beer/coffee if I could.

1 Like

@peterk I ended up using an older Intel 3160 that I had laying around. As for sleep, it will go to sleep just fine, but when it wakes up it’s only stable for about a minute and then starts crashing eventually locking up.

1 Like

Did some research. Looks like the AX200 is the most recent and advanced ChromeOs supported WIFI card. The 9560 which was released in 2017 is the 2nd best option. Was surprised that there are a lot of intel wifi cards that don’t have ChromeOS suport.

FWIW - I bought an older M2 wifi card that mentioned it came from a Chromebook off amazon and just got Cloudready up and running. Loving it so far!

Question: does Cloudready support the Android and Linux containers?

I’ve been using Brunch for well over a year now since it supports both and it’s been great.

There’s also an option you can turn on for Intel WiFi cards that are not supported by the kennel. Don’t have a Framework to test it, but you might want to give it a shot

@Enjewneer - I tried Crostini/Linux and it worked great for me. I installed all my local software and was working in multiple containers via docker last night. However I believe Android apps are not planned to be included in Cloudready (ref) (though that may change due to their acquisition by Google).

Intel’s buggy wifi firmware has caused several headaches on Chromebooks so I think Google is a little gun shy. On the Dell Chromebook 13 (7310) the Intel firmware lost it’s mind if you had a 2.4GHz and 5GHz with the same name and it would start trying to talk to the other frequency and of course get rejected by the access points because it didn’t “know” the device/session on that radio. These were a premium model deployed by the hundreds if not thousands into schools and businesses so that kind of long standing bug was a black eye.

I ended up with switching over to Ubuntu. I tried to get ChromeOS up and running but it wasn’t perfect.

With the AX200, wifi worked fine and the system appeared healthy for basic web browsing and the like. I didn’t encounter the Sleep problems. If I just wanted that basic functionality, I could have stopped there.

But I need Visual Studio Code, and when I installed and tried running it, it wouldn’t load completely and complained about some missing video drivers. I wasn’t able to figure out how to add them. Perhaps this is related to Debian not being a supported linux variant for Framework until Debian comes out with its next version that supports the hardware.

@peterk - which version of ubuntu/debian did you try? IIRC the LTS version 20.x (which I often default to) does not fully support everything whereas the 21.x version does.

Ubuntu was a clean install of 21.x - that’s running great.
Debian was the version baked into ChromeOS Prod.

You need to select kernel 5.10 in the Brunch settings, plus turn on the iwlwifi_backports AND after booting, delete a pnvm file /lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm and reboot to get the AX210 working properly (but without BT due to an issue in 5.10, and Brunch doesn’t have a newer kernel available yet).

Ok, full steps to get Brunch booting as it took me a few tries (apparently the brunch folks don’t actually test their stuff from within regular ChromeOS so neither my Chromebooks or CloudReady were helpful, so I had to boot Ubuntu 21.04 and use the brunch-toolkit to “install” the recovery + brunch to one of my storage modules.

  1. Download Ubuntu 21.04 and “burn” to USB drive with Etcher/Chromebook Recovery Tool/d(isk)d(estroyer)/etc.

  2. Boot into Ubuntu and enjoy the functional WiFi and/or hook up an Ethernet cable.

  3. sudo apt update && sudo apt install curl

  4. The above gives us enough to grab the brunch-toolkit, but not enough to successfully use it.

  5. sudo add-apt-repository -c universe This will enable a MUCH wider set of packages, we need this for cgpt which is the Chromium oriented version of the GPT tool.

  6. sudo apt install cgpt pv tar unzip because better safe than falling into a pit of despair until the toolkit devs fix their scripts.

  7. Run the curl command from the Github README of the brunch-toolkit.

  8. Insert the drive module or USB drive you want to install Brunch to.

  9. Run brunch-toolkit and make sure you select Yes to the “running from live USB” question.

  10. Run “Install Brunch” from the menu, and after a couple of downloads, it should extract the recovery, use the brunch install-chromeos script to push it to the USB, and brunch will insert itself into the RootFS and boot process so you can modify options like the kernel version (5.4/5.10 are the primary options, we’ll want 5.10), the sleep state to use, and some other tweaks.

  11. Once the image is written successfully, restart the computer, Ubuntu should have you pull the LiveUSB and press Enter, then you should see a Grub Brunch themed bootloader where you can choose “ChromeOS (Settings)” to pick some options for the brunch framework to allow it to work well on the Framework.

  12. Select the pwa, iwlwifi_backport,suspend_s3,and acpi_power_button options, then let the system reboot into ChromeOS (Brunch).

  13. The last fix we need to make (only until they push a new version of the Brunch framework that removes the pnvm files) is to sudo ls /lib/firmware/*.pnvm and then sudo rm /lib/firmware/*.pnvm to get rid of a new format driver that isn’t supported by kernel 5.10 and causes the wireless to fail to load.

The one thing that is still occasionally an issue (may be fixed when 5.14 makes it to ChromeOS/ChromiumOS and therefore Brunch) is that occasionally when you boot up the wireless isn’t “all there”. So you have to go into the Settings and “turn it off and on again”.