Installing Elementary OS

Just got my DIY framework laptop, and I’m extremely excited. I installed all of my parts and I flashed elementary OS to a flash drive. Upon reaching the boot manager and attempting to boot to the drive, I get this: “Verification failed: (0x1A) Security Violation. I’m assuming secure boot needs to be disabled but I’m not able to get to the BIOS. As soon as I turn on the laptop I spam f2/f12 but I am never able to reach the BIOS, what am I doing wrong? Thanks!

1 Like

I saw the UEFI key was F12 somewhere. Try hitting without boot media in place (ie flash drive)

Thanks, that seemed to work after I did crl-alt-esc from the boot manager. Now the issue is that elementary os doesn’t seem to come with wifi drivers installed and I dont have Ethernet. Is there a way to get that driver without the internet?

what you have just experienced is a result of Microsoft design of Windows 10!

The problem is that Microsoft removed where you can enter Bios in exchange for faster boot times. For most people / normies who don’t care about going into the BIOS, it is not a problem. However for people like us, it causes some extra work and annoyance.

What you need to do is go into Windows settings then select Update & Security.
Then select Recovery from the left menu.
You should now see a Restart Now button below Advanced Startup.

Once you have clicked the Restart Now button and have booted up, select Troubleshoot.
After doing that, select Advanced Options.
Then click UEFI Firmware Settings. If you do not see that, select Startup Settings instead.


No, no no!
That will not work on a windows 10 laptop such as this. Microsoft changed Windows 10 to be worse for people who want to mess around.

There is now a very long and convoluted Process. See my original reply to Manas_Mathur

@Sofa_Box ooh I gotcha. Isn’t that the fast boot function they built in? I seem to remember it saves your last power off state of the os on a little stub in the UEFI to force it as the first boot option.

Manas_Mathur should be able to bypass a lot of that by holding shift and hitting restart if you’re inside windows to boot the recovery functions in windows. It’ll suffice for getting a USB boot.

It sounded like this was the original OS that Manas installed, so the windows 10 things wasn’t my first guess for troubleshooting.

Calling @cassidyjames !

@Manas_Mathur you’ll need Kernel ~5.10 or newer if you have the AX210 card. See Using the AX210 with Linux on the Framework Laptop. Cassidy noted that Elementary will have this once Ubuntu 20.04.3 is released next month. In the meantime, you may need to use Ubuntu 21.04 or similar which has 5.11.


On getting to the BIOS menu, @Kieran_Levin noted a workaround here while we fix the root cause: Booting into firmware - #2 by gjason

1 Like

Elementary is Linux… I feel like we could shoehorn something in if we get some sorta internet on there temporarily :smiling_imp:

Im now trying to get Ubuntu on there, but f12 does not seem to work whatsoever. I end up going straight to Elementary OS’ login

Have you seen this post? Best of luck! I’m jealous. :smiley:

@Manas_Mathur we wrote up a Knowledge Base article about this as well: How do I enter the BIOS on the Framework Laptop?

Let us know if that works or if you see any issues.



FWIW I have used a LOT of distros. My personal recommendations are both arch based. Garuda Linux has a lot of wonderful features default. Arco Linux is also great if you want a lot of options that you decide on. Since I am lazy I just go with a Garuda Distro and chante the theme to my style.

I used Ubuntu, Pop OS, Mint and dozens of other ubuntu distros. Once I took the leap into arch I have NEVER… EVER thought about going back. Yes I have had some headaches and yes Arch people tend to be “RTFM” type people. BUT there are a lot of decent Arch people these days that are willing to help you because they understand it is unreasonable for every the average user to have a complete understanding of Arch just to want to use the distro.

I hope you come to the Arch side we need good people to off set the “RTFM” people.

Solution based on @NRP link

Turn off
Unplug power
wait 30 sec
power on
Tap F2 for bios
Tap F10 for vPro if you have i7-1185g7
Tap F12 for Boot device

@Manas_Mathur Based on @nrp Link

power off
wait 30 sec
power on
Tapping F2 for bios
Tapping F10 for vPro if you have i7-1185g7
Tapping F12 for Boot device