Booting into firmware


what’s the magic key (or key combination) to boot into the UEFI firmware/BIOS? i’m trying to boot a linux distribution off of a USB drive and it’s not working, and i’d like to check whether secure boot (or something of that nature) needs to be disabled at the firmware level.



F2 to enter the BIOS, F12 for one-time boot override.


thanks! i could have sworn i tried every last F key, but i must not have been mashing them insistently enough :sweat_smile:

1 Like

At least you have keys to pound on - I’m still waiting on my pre-order to arrive… :frowning:


@igowen does your system already have an os installed?
I tried a few things just now and running after fedora if the system is on and does a warm reboot, I seem to run into this. You can try powering down the system, unplugging AC wait 30 seconds and then power it back on while tapping F12 or F2 quickly. Let me know if that unblocks you.


nope, no OS (DIY), but what you describe is completely consistent with my experience - i had the boot menu open, hit ctrl-alt-delete, and F2 seemed to have no effect. after turning the machine off completely and turning it back on, mashing F2 got me to where i needed to go. from there i turned off secure boot and then was able to boot from the USB drive without issue.


@igowen Thanks for reporting this and glad you were able to resolve this. We will look at getting this fixed in a firmware update.


If you can manage to get the timing correct and enter the BIOS, there is an option under the BOOT menu to set a timeout value.

As shipped, this timeout is zero seconds, which means it’s very hard to catch it and enter the BIOS, or change the boot device.

If you make it one or two, then you have a little time when the framework logo is on screen to press F2 for the BIOS, or F12 for the Boot override.


@Edward_Gray That’s a very useful tip. I will change it as soon as mine arrives.

@Kieran_Levin It was mentioned in some post that there was to be a change to the firmware. If you can change the installed BIOS for Batch 2 or later, may I suggest that you include changing the default timeout setting so that future buyers don’t get frustrated trying to getting into the BIOS or the one time boot menu?

1 Like