Intel AX210 vs. AMD (MediaTek) RZ616 on an AMD Framework

I got fed up with fast Wi-Fi transition not working and bought an AX210 (No vPro) for my Framework 13 AMD.

Compared to the RZ616:

  • 802.11k / 802.11r fast transition between APs now works perfectly (my main reason for the switch).
  • Overall Wi-Fi speed in the exact same spot is higher and more stable (although I am not sure there is any difference in practice).

However, Bluetooth… it became much worse. My specific issue is that I have a Bluetooth keyboard and a Bluetooth trackpad, which all work great, but once I connect Bluetooth headphones and start watching a video, the trackpad begins to lag occasionally (the keyboard too, but much more rarely). There is nothing in the logs, so I am not even sure where to start to troubleshoot this. Also, subjectively, the audio lag when watching a video is less noticeable with AMD.

Overall, it seems like I can get either stable Wi-Fi (with Intel) or stable Bluetooth (with AMD), which is quite disappointing. Intel AX210 seems to have pretty good reviews and I did not see any other similar complaints elsewhere, so this makes me wonder whether there is some sort of incompatibility with the AMD platform, which prompted Framework to pick the AMD module in the first place?

Have any of you, who replaced RZ616 with AX210, experienced issues like this?


Great comparison and one of the concerns I had when considering the AX210. I’m curious if anyone else has evidence like this. I will say that I am not having significant enough problems with wifi to make me disregard the possible bluetooth problems.

I’ve had a good experience with both, however the AX210 definitely consumed a lot of power during idle.

The RZ616 did as well. However on Linux 6.8 it’s calm down and runs very efficiently now.

Bluetooth has been acceptable on both however I’ve only used them for Teams calls.

Weird, mine use barely any power at idle even when connected. During iperf the ax210 seems to use quite a bit less power but also did perform a bit worse on 80mhz wifi6, on 160mhz both saturate the gigabit uplink of the accesspoint.

As a brief update, I did a couple of experiments but the situation is still the same – horrible random lagging of wireless touchpad/keyboard when headphones are playing audio, and I don’t understand what is causing it and how to debug it.

On a related note, I have replaced PulseAudio with PipeWire (should have been using it from the beginning, not sure why NixOS doesn’t enable it by default) and this solved all the video/audio sync issues with both adapters.

1 Like