[SOLVED] RZ616 WiFi issues

I got my FW13 a week or so ago and while I overall really like the laptop, there are some issues.

One of these issues is WiFi. On some networks, like my home network, it works totally fine. Connects quickly from sleep, is fast, no range issues. But some networks, like my phone’s hotspot just don’t work at all.

Things I’ve tried:

  • Bios 3.03 :x:
  • Latest driver pack :x:
  • compatibly mode :x:
  • changing network name, etc :x:
  • USB tethering :white_check_mark:
  • Using hotspot on other devices (ninetendo switch) :white_check_mark:

This signifies it probably is an issue with the RZ616 or it’s drivers. I have a AX200 laying around and I will install it then update this thread on how it’s going.

1 Like

Can confirm it’s just the RZ616 being kinda crap. With the AX200 in there I can connect to my pixel 7a hotspot with no issues (currently posting from the hotspot as a test.

0 issues with a mobile hotspot on a 7840u win11 using an s22ultra and pdanet+.

1 Like

Interesting update. After changing to an AX200 I seem to get significantly better battery life. I’m not doing anything intensive, but reading through PDFs while having background apps open (mailspring, spotify, etc) and having brightness at 1/3 I’m getting 10 hours expected battery life. Will post updates if this better battery life keeps up.

Keep in mind I have the 55Wh battery and 7640u.

1 Like

I don’t have an AX200/210 lying around to test, and admittedly I have never looked into battery use of wifi components so maybe this is normal, but I have wondered about the wifi battery usage of the stock AMD card.

A good stressor I’ve noticed is twitch, as it combined live video and chat, so constant back and forth with no real buffering opportunity.

If I go on and sort by most popular (to make sure chat is super active), opening up a stream gets powertop thinking wifi is using 5-6W, at 8-900 packets / second.

As someone who often leaves Twitch as background noise, this is not great, as it pulls at least 15W just idling on Twitch (I idle at ~5W with FF open but not touching anything, ~10W for a 1080p60 YT video, ~15-20W for Twitch depending on how animated chat is).

Makes me wonder if I should get a AX200/210 as they are pretty cheap, to see if it notably improves things.

In only initially used the mediatek card and then switched to an ax210 I already had, battery usage both on idle and under a full iperf3 load on a 80mhz ax connection was better with the ax210. Should probably retest now that I have a 160mhz ap.

Since I wanted to use the mediatek in another project and they are literally more expensive to get than another ax210 (and the be200 doesn’t work XD) I am personally going to stick with the ax210 in mine for now.

Take the powertop per component power levels with a huge pile of salt, even calibrated it has no way of knowing how much power it actually uses. Hell the ax210 doesn’t even draw 6W over idle doing 800-900mbit on iperf3

2 Likes

Most issues seem related to over zealous power management in the mtk driver stack. There are several patches around that solve this; and the power draw difference between them is minimal.

Given that the number of variables including Regulatory and power limit advertising are set on the AP side it’s very difficult to narrow down why you have specific issues in your specific topology.

I have done a relatively extensive test and have both WAX and MTK cards and Qualcomm, MTK and Atheros radios on the AP side to test with. I have seen very little draw difference between AX201 M.2 cards and the MT7922. Performance wise routinely am doing bulk transfers at 2400mbit rates to my AX in HE160 modes.

The main factor is the power management (which there are several patches - search the forum) which can cause drop outs.

The other factor is often due to suplicant → nmcli interactions which with specific AP/ESSID/Security setups and distro/version combinations can cause intermittent failure to associate (my guess is it’s something to do with backoff/ack messages).

In any case try one of the power management disabling patches for the mtk driver and you’ll likely notice performance and battery savings (yes despite the fact you are disabling some of the PMU bits in the stack).

Radio is a complicated thing to debug, because it’s a shared medium and people do all sorts of dumb things with how they deploy AP’s including turning performance/db up when down actually makes more sense. Sometimes this can trigger the radios in the client side to do odd things around power levels themselves to ‘shout’ over the noise. It’s a mess and all of the current gen stuff has proprietary blob/tuning bits in them that makes debugging it difficult/impossible.

1 Like

What OS are you running? I’m personally using the prior AX210 on my 7840U board, but I’m wondering how this card runs in Linux…

Linux (with recent kernels) - important to note that both Intel and Mediatek modern cards require a recent kernel. mt76 support for the ax chipsets only landed very late in the 5 series and I wouldn’t use anything older than 6.5 personally. So if you are using something which uses an ancient kernel (ubuntu 22 LTS for example which is a hacked up 6.1 kernel) I wouldn’t trust it.

See other thread regarding capabilities of Intel Wifi Cards. They don’t support any modes other than Station(client) and P2P - the MTK is probably the best supported card under linux other than the very long in the tooth ath9k. Qualcomm Ath10k and ath11k are ok option but they don’t generally come in NVFF options. I’ve found the MTK cards very good in general regarding support for doing things other than client applications and haven’t had any of the issues people seem to have with them ; much pref over the intels which as mentioned above do not support a heap of (IMNSHO basic) features the MTK does.

Realtek (CM) cards are an option and I’ve got them in some SBC’s but they are super opaque and flakey IMO as well as not performing well in anything other than client mode.

General consensus from Openwrt community is stick with Mediatek or Qualcomm

1 Like

If you’re running W11 and struggling with the Mediatek wifi, try one of these newer drivers. The RZ616 is the same as the 7922

MediaTek MT7920/7921/7922/7902/7821/… Wireless Lan (station-drivers.com)

1 Like

As per Luke_McCarthy observations, I also seem to be having issues with the MediaTek Wifi 6E RZ616. Download speeds (30Mbps) are far lower than upload speeds (130Mbps) when connected to our wifi router broadband fiber.

I can categorically state that there are no such issues on older laptops running Win11 or mobile phones (iphones) which all record download speeds in excess of 300Mbps.

Note that I have installed and downloaded the latest Framework BIOS 3.03 and Latest & Recommended DRIVERS 3.3.0.825 from Framework. My Framework 13 is the AMD Ryzen 5 7640U Model with 16GB RAM and Win11 23H2 Installed.

Following Scott_H’s recommendation (thank you Scott) and link MediaTek MT79xx Wi-Fi 6/6E Wireless LAN Drivers Version 3.03.00.0897
I updated / changed the MediaTek driver to 3.3.0.897 dated 21/11/2023 however, it doesn’t seem to have helped to resolve the issue.

Very disappointing Wifi download speeds on the RZ616!! Another contributor who is more knowledagable that I suggested that it is a directional issue / limitation on the antenna.

2 Likes

Today I upgraded my home wifi with a new WiFi6 AP, an ubiquity U6+.
Wired connection is HTTH 1Gb/300Mb.
Mediatek driver is 3.3.0.908 dated 27/11/2023

Here are the speeds recorded in the same location
Samsung S22ultra: 920/280
Dell xps13 7390 Killer 1465 Win11: 465/280
Framework 13 mediatek Win11: 96/175

I’m presently looking on Amazon for a Killer card, had enough of this mediatek garbage

I highly recommend the AX200. Has worked great and you get get them super cheap on eBay (like less than $10).

Here’s another datapoint:

I stumbled on this thread trying to figure out why it takes significantly longer to get connected from sleep/boot on Windows than Linux on my Framework 13. I don’t have a solution there but I can say with driver 3.3.0.825 the speedtest results actually match my wired desktop.

Desktop: 575.48 down, 23.45 up (as a baseline for internet speeds)
Framework 13: 578.61 down 23.10 up

Test results were taken moments apart and the Framework 13 is 10’ away from the Unifi U6 pro AP I have. The AP is running at 5GHz with an 80Hz wide channel. The AP is running firmware 6.6.65.

The antenna comment Jowens made is maybe a good place to look, perhaps its as simple as a loose or damaged antenna connection / wire? The drivers definitely need some improvement though.