Is it possible to use the usb-c port to bootload my ubuntu stick?

Hi there,

I have a Framework DIY 12. gen without any USB-A - Cards – my assumption was I can just use an usb a > c adapter to use my stick to boot Ubuntu. However, it doesn’t appear in the boot menu.

Is it possible to boot via a USB-C port or do I need to order a USB-A port to use my boot stick?

Best wishes


What I learned after my initial purchase of the Framework (11th Gen Intel processor),the USB-A port is needed via a thumb drive or external drive. I could not use a USB-A thumb drive SD Card reader.

I would suggest to use the USB-A thumb drive. I had the use the same thumb drive for the Framework 12th Gen (Intel) that I recently purchased.

Thanks Patrick, unfortunately I didn’t buy a USB-A Card.

In frameworks discord, I have read it is possible to use the USB-C Card however I couldn’t make it work.

I think it would be nice of the framework team to mention if people don’t select an OS that they need a USB-A Card.

I used a microSD in an expansion card to load Ubuntu 22.04 as the second OS

I used a USB stick to install Pop OS to a USB C linked M.2 SSD and it installed and ran just fine. Performance was as good as the internal M.2.

@Johannes_Theilmann I guess you could also use a native USB C thumb drive, but given the ubiquity of USB A cable and devices, getting one or two USB A would come in handy in the long term.

@dosssman I’m going to try it out with a native.

However, I think it might be also BIOS Setting related. The BIOS is recognising connected devices, but I can’t boot from them.

Eg I don’t have any EFI Settings for the boot order etc.

My set up:
1240P - DIY
Predator GM7000 SSD
3x usb-c
1x hdmi
no OS preinstalled

Secure Boot: off
USB Boot: on

1 Like

Not sure what system you are trying to install, but if the device shows up in the F12 boot menu but does not boot, it might be because the boot drive is not set up as expected.

Are you using a USB-A to C dongle ? → Yes
Also which Live ISO / Install ISO system are you trying to boot off of ? → Ubuntu

EDIT: My bad, just checked your top post and the details were already there.
How did you prepare the Ubuntu USB stick ? Does it stupport UEFI boot ?
Have you tried on another computer with native USB-A by any chance ?

The ubuntu stick (usb 3.0) supports uefi and runs perfectly fine on my windows machine.
I head out now to get a native usb-c :slight_smile:

1 Like

I guess this is the fastest solution.

Best wishes.

Just to give an update. It worked like a charm with a native USB-C stick. Thanks for handholding anyway!


If your USB drive isn’t showing up, while you are on the boot device selection screen, try unplugging the device and plugging it back in.

F12 to get into the boot menu.
Live updates as you plug in devices.

1 Like