Is there a trick to getting a UFS card to work? - UPDATE - the issue was the UFS Card, not the Framework Hardware

MicroSD cards work fine. I picked up a UFS card to fiddle around, and it doesn’t show up as a device at all in Pop!_OS, Windows, or Ubuntu 21.04 booted from a live USB. I’m trying to figure out if the card reader expansion card is not working for UFS cards, or if I need to install drivers to have it recognized. Leaning towards the latter, as popping the card out and plugging it into a different computer yields similar results. Checking here before I email Support. Thanks all.

There are no drivers required. It’s possible the card needs to be formatted, but I would expect the OS to prompt you for that. Could you try inserting the UFS Card into the Expansion Card before inserting the Expansion Card into the Laptop? The hot swap behavior is different for UFS Cards (on this controller).

1 Like

Hi Nirav,

Thank you for the reply. That didn’t change things either. I tried removing all of the expansion cards, shutting down, inserting just the one with the UFS card, and powering on, but I see the same error during boot. Here’s the dmesg output. I’m trying to search to see what I can figure out from it, but placing it here in case it is helpful and others may know more about what it’s staging than I.

[ 131.092650] usb 2-1: new SuperSpeed Gen 1 USB device number 3 using xhci_hcd
[ 131.113732] usb 2-1: New USB device found, idVendor=090c, idProduct=3350, bcdDevice=11.00
[ 131.113741] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 131.113745] usb 2-1: Product: USB DISK
[ 131.113747] usb 2-1: Manufacturer: SMI Corporation
[ 131.113750] usb 2-1: SerialNumber: <redacted>
[ 136.181685] usb 2-1: can’t set config #1, error -110

Nothing obvious from the log. It’s hard to know if it’s the UFS Card or the Expansion Card that is having the issue. If MicroSD cards are working correctly in the Expansion Card, I would guess it is more likely an issue with the UFS Card though. You can reach out to the support team, and we can try swapping the Expansion Card as a test.

Thanks, will do so. The card is brand new but could be a dud. I appreciate the help. I’m loving the machine so far, this part is just a little thing as it’s just fiddling around.

Adding a note here that Framework’s support team was fantastic. They shipped a replacement microSD expansion card. When the UFS card that I had still didn’t work, I ordered a different one. It did work. I’m exchanging the faulty card. Thank you to the Framework team for helping me sort this out, particularly since there was nothing wrong with their hardware.

2 Likes