Issues running OSs on expansion cards

I am having issues with running OSs on my storage expansion cards. What happens is that when I am using whatever OS/distro is installed, it will randomly freeze up completely. The freeze up could happen after 5 minutes of use or after 10, 23, etc. It also happens when actively in use (i.e. typing), or when sitting idle at the lock screen. I have to force restart the laptop to get it working again.

I have 4 storage cards in total (2 250GB & 2 1TB). I have installed different distros on all 4 and they all give me the same issue (Fedora 35 & 36, Ubuntu 22.04 & 21.10, and Pop!_OS 22.04). I also tried with Windows 11 on one of the cards and same thing.
All 4 cards were not bought at the same time. I also added the thermal pad to all of them.

I did some testing with all 4 on Windows using CrystalDiskMark (9 passes, 64GiB) and just transferring large video files and I had no issues. They did get hot but not to the point to throttle.

I can run any of those OSs on an NVMe without any issue, so I am stomped.
Anyone have any ideas?

I’m just spitballing but it sounds like perhaps the Thunderbolt controller is disconnecting at idle? I know you said in use but typing would be located in RAM and wouldn’t touch storage until the file is saved. I haven’t a clue on how one would diagnose such a thing but that’s what comes to mind for me.

1 Like

@GhostLegion That’s a good idea, but just like you, I have no idea how I would be able to test that.

So I found this, I read it earlier but had trouble finding it again

It’s not exactly like your issue since it related to a 3rd party device but have you tried updating to the latest firmware?

@GhostLegion So I am running on the newest BIOS (3.07). In the BIOS it shows both PD Controller versions as Not sure if there is a way to update the firmware manually.

My apologies, by firmware I meant the BIOS and it seems you’ve already done that. Have you already reached out to support?

@GhostLegion I was going to do that yesterday but I thought to ask here first, maybe someone would have an idea on things to try before reaching out to support.

Hopefully someone can chime in then, I don’t even own a Framework yet, I get mine in July. Hopefully this gets resolved quickly for you.

1 Like

So I realized that I hadn’t tested all the ports. I thought that it would be the same thing on all ports but after testing, I was wrong. Weirdly enough, it still worked after an hour, running Ubuntu 22.04 on the top right port using the 250GB card.
I guess that something is wrong with the USB controllers on my laptop. Time to contact support.

1 Like

Please keep us posted on the root cause (if known) and what the fix recommendation from support will be.


Did this ever get resolved? I was trying the same thing. But the specific port did not seem to matter. I was able to run for a few hours without issue. Then the system would lock up. So far I have only tried this with Ubuntu 22.04 and Fedora 39. Firmware is up to date.
I am used the Framework 13 11th Gen i5.

What follows is just theory on my part. I haven’t but a lot of effort into full diagnostics yet:

To me, this appears to be a heating issue. When I lose functionality, the system does not even see that the drive exists (checking in UEFI). When I touch the module, it is VERY warm. This leads me to believe that there is not an effective thermal transfer solution in place, but I have not opened the module to confirm this. So that is from external examination only at this point. If I let it rest and cool down, it works without issue.

Initially the storage expansion cards had an overheating issue: 1TB Storage Expansion Overheating - #22 by nrp