Laptop crashed, now very slow

A more general comment, it is amazing how many things could have a firmware update.

SSD devices
Network cards
The computer itself
The fingerprint reader
The keyboard
Maybe even the screen.

Camera accessories

And for the most part, it’s hard to mess the update up.
Design and implementation has come a long way.

Just make sure the power is sufficient.

1 Like

Hey @Edward_Gray thanks for the reply and list of items. I’ll take a look at these as well. Thanks!

My problem with firmware updates? 99% is only in the form of executable for windows OS :frowning:


I also had a similar problem. I have the i5 model, batch 5. My laptop also has the 500GB WD SN850 drive. The computer is running Pop OS 21.10, and until now it has been much faster than my i7 Lenovo X1 Carbon.
Today, though, when I went to use it, it was unreasonably slow, taking multiple seconds just to open “files” windows. Likewise, I have Windows 10 in a Boxes VM, which usually starts up in about 10 seconds, and this was still on the startup screen after several minutes.
I noticed that the SSD was 95% full, and though that might be it, so I started moving things off of it onto an external drive, but performance did not improve even after freeing up a reasonable amount of spacce. I decided to reboot, which was a mistake, because after the reboot, the startup was so slow that it was still not showing me the login screen even after 10 minutes.
Before I rebooted, I checked htop, but nothing unusual was running (qemu was eating up processor time after I started boxes, but that’s to be expected). Still, the fans were not running.
I only have USB C, USB A, and HDMI modules, and I was only using USB-C for power/video and USB-A for the external drive I was moving stuff to.
After reading this, I removed all except one USB-C, powered off, and powered on again. This did not seem to do anything useful, as it was still to slow to even start up.
Finally, I went into the BIOS and used the “Disconnect battery” option. I pressed the power button a few times, connected power (which caused the power button to blink red!), and then pressed it long enough to cause the laptop to start up - perfectly fast this time.

So I think the take-away might be that it could be some BIOS issue, potentially causes by the SSD? maybe? but using the “disconnect battery” option seems to have fixed it. I have a feeling that the fans were just not spinning when they should have been. I installed xsensors to have a look in the future should this happen again.


You may find this helpful:

Basically make sure your SN850 is using the most current firmware. WD is to blame for this one, I’m afraid.

1 Like

Have been having similar problems to OP, thought i’d post incase someone comes across this.

Before i found this thread i was running HWinfo, System health checks, virus scans, repairing drives etc etc and everything appeared fine. The only thing that i might have noticed out of the ordinary was that the fans weren’t spinning, or spinning so lightly that it was almost indiscernable. Temps on HWinfo were hovering at around 50 C so it was a bit strange, usually running various full system virus scans on the laptop makes the fans pick up spead, but none of that was happening. It was like the system was thermal throtteling at 50 C with lower core clocks for some reason… Which was why this comment with regards to power made me consider it was more likely something with the battery:

This seemed to work for me, kinda.

I checked the battery disconect option and hit save and quit in the BIOS. Now, it had said that it would restart but it didn’t. So I turned it on manually again and unfortunately Windows was doing exactly the same thing.

In my frustration, I unplugged the USBC power to even check if the option for battery disconect had even registered. It had, because the laptop immedietely turned off.

I then plugged the cable back in and manually turned the laptop back on and… it’s fine. It’s literally back to normal as if there was never any problem… here i am typing this message with everything working as it should. What is strange (?), i just unplugged the USBC power again and the system remained on? Perhaps the BIOS setting for battery disconect only works on the immediete restart, idk.

But yeah everything is working fine… kinda. This happened before about 2 months ago. I seem to remember going through the same process but after a normal restart the issue fixed itself. Which leads me to believe that there is no reason why this won’t happen again.

I don’t have an SN850, I have the Samsung 970 EVO Plus, so i’m not sure if that’s causing an issue but i’ll look into it. If this happens in the future, i’ll update here.

Best of luck!

Just piping in here to say (a) I have almost the exact same setup, including the OS and framework batch, (b) I too experienced this exact issue and (c) the battery disconnect in the BIOS seemed to do the trick.

The only thing I’d consider adding is that it might be a battery health issue related to leaving the computer on for some time plugged into power. That was at least the precondition that occurred with me right before seeing this issue. I’m also loosely aware that some vendors/OS’s will attempt to slow down compute if it detects unhealthy batteries. Feels related to me at least.

Just want to add I had the same issue. Laptop became very slow suddenly, however disconnecting the batter in bios also seems to have fixed my issue.

I also had the same problem. After a crash/hard reboot the system went was slow.
I’m reporting this issue because I think it’s a bug (BIOS?).

The problem is OS independent (I check different OS) and already is a problem during the Boot sequence.
Rebooting did not change anything. On thing that was striking … the fans did not turn on during boot or OS activity.

I ran a HWiNFO session to check for strange behavior. See screengrab “slow”:

Striking is that the cores run only at 399Mhz and never go any higher than that.
This might be an indication on the source of the problem?
Also the Windows task mananger only states 5-7% activity.
This speed does match with the (very slow) responsiveness of the system.

I tumbled upon this thread and used the BIOS Battery Disconnect setting.
Disconnected the power, so the system got a hard shutdown.
Rebooted, and it seemed not to work at first.

I also turned the max battery charge limit from 60- > 100%, turned OFF the disconnect.
Rebooted and the system was back at normal speed.

See screengrab “back2normal”:

Hopefully the Frame.Work developers can use this information and find + crush this (rare) bug.

Well it’s been a while, but I thought i’d update quickly incase this is relevant.
It seems that this case was the start of a number of problems with my framework, and particularly my mainboard. I’m not sure if this is related, but soon after this issue, some of the USB ports stopped working properly. Some of the ports didn’t work at all. This wasn’t an expansion card issue, it was with the board itself.

Anyway I ended up contacting support and they asked me to do a bunch of things including reseting the mainboard state (disconecting the battery, RTC cell etc) and then for photos of the mainboard. I took this photo which revealed a part of the board which had seemingly burnt out;

So they offered me a replacment on warranty. I don’t know if that was the start of the issues, or if this was entirely unrelated to what’s been going on in this thread or whatever else. Best of luck!

Interesting this is the second time I have seen this mosfet burnt out on the forum. I wonder what it is for.

There is a whole thread on this problem, with over a half dozen instances of this same problem.

Care to point me to it or just tell me what the problem was/ what this mosfet was connected to?

I don’t know if an ultimate cause was ever determined, but I believe it was the chip for PD power on one of the USB C ports on the mainboard. If I remember correctly, once that chip pops that port will no longer charge the machine. There may be other symptoms, but I believe that was the main one.

It is a p-channel mosfet, so it probably was part of power routing then.

Mosfets don’t tend to just blow up on their own though so it may be a symptom of something else. has replacing the mosfet been tried (or hell even just deleting it in case it failed short and is feeding power where it should not)?

1 Like

I’ll look for the thread, but from what I remember, Framework was sending out replacement mainboards and asking for the failed boards back so they could be sent out for failure analysis. As you say, they wanted to get down to the cause of that mosfet failing. I think there were even some who found the plastic above the mosfet warped from heat, but hadn’t suffered a full failure yet. So the mosfet is overheating for some reason, and eventually failing.

Edit: Found one thread

Overheating does kill mosfets pretty reliably, at least under load.

That’s the other instance I was referring to.

There are at least 10 distinct reports in that thread, each with photographs (And here’s another one).

I’ve been summoned.
Btw for that issue, the laptop didn’t even turn on :man_shrugging:

1 Like