Laptop shuts down during sleep

So far, I’ve managed to stop (or at the very least severely decrease) these crashes. On my system, I was seeing two issues that could potentially be the root cause. The first was the Framework fingerprint driver crashing anytime the system cycles to Modern Standby. The second was a flood of events from the UserModePowerService indicating a power scheme change every few seconds.

The first I’ve tried fixing with the Framework Support team without success. I’ve re-installed all the drivers, replaced the hardware, and even did a clean install of Windows 11 Pro. Problem happens regularly and is easy to repeat. In the end, I simply disabled the device and decided to live without the fingerprint reader. Obviously, this fixed the driver crashing issue. NOTE: Support has indicated that they have escalated this driver issue to their engineering team. That said, they gave no indication that they would issue a driver fix.

The second issue is extremely annoying as it spams the event log every few seconds. It’s the event others have described before whereby WUDFHost resets the policy scheme to the same scheme GUID. It seems that this is a widespread issue and something a lot of people are experiencing outside of just Framework. It’s unclear if this is because of the Intel Wi-Fi adapter or the Intel DTT device. Regardless, after some research and some trial and error I was able to get the events to stop. I performed the steps to configure Group Policy in the following [post](https://www.reddit.com/r/DellXPS/comments/tzbilc/comment/j184dxn/?utm_source=share&utm_medium=web3x&utm_name=web3xcss&utm_term=1&utm_content=share_button). It’s been two days and I have not see any of these events in the Event Log.

So far, the machine finally appears to function as expected. Hopefully this helps others here.

1 Like

Definitely not the WiFi adapter. The events happen for me as well with a different adapter. I’ll see if changing the group policy helps.

1 Like

Disabling connected modern standby and using only disconnected modern standby seems to have fixed the issue for me.

I picked up on this because I was facing the same issue, but I noticed that it only ever happened when my computer was plugged in and in sleep mode. (By default, Windows uses connected standby when plugged in, and disconnected when on battery).

https://www.elevenforum.com/t/enable-or-disable-modern-standby-network-connectivity-in-windows-11.3286/

If that doesn’t work and you are on an AMD mainboard, another thing you could try is going into Device Manager, finding the USB4 Root Routers (should be under Universal Serial Bus Controllers), and disabling “Allow this device to wake the computer”. I’m mentioning this because I realized that I did BOTH of the aforementioned solutions above, so IDK which one seemed to fix it.

Yeah, realized I did the same exact solution that Geoff did but I used the Group Policy Editor instead of powercfg to disable connectivity in standby, also seems to be giving me good results, the link I post in my earlier post here detailed 4 different ways to do it, so I guess pick your poison lol.

Still a shame this even has to be done though, it just proves that even after LTT brought attention to it in their video, Modern Standby is STILL broken.

It’s not conclusive yet but for me it may have been tinc VPN. Just by pure coincidence I found a log message about tinc having connection errors during Modern Standby so I set the service to manual start (I don’t need the VPN to be always on while I’m working from home) and so far I haven’t seen any more crashes… which of course means that as soon as I post this, things will go wrong, as always.

Anyway, if all of the above solutions don’t work for you, check if you have some background services that might aggressively reconnect during standby.

Unfortunately, it was Windows Update causing the crashes in my case :woozy_face:, hence needing to just disable network connectivity in Modern Standby all together. Lovely operating system Microsoft, thank you.

1 Like

I’m not sure it is Windows Update that is the actual cause. What is likely is that Windows Update is setting a wake timer so that it can run periodically if the machine is sleeping. Then, when the wake timer hits, your machine is crashing as the machine wakes from sleep. I was experiencing this with other things that set wake timers (like my backup software).

I believe what is happening is that a driver is getting into a corrupt state when entering or exiting sleep. Then, on wake, it hard crashes. In my case, I was not even seeing a bugcheck or memory dump.

What ultimately worked for me was disabling the fingerprint device in BIOS and making the GP changes from my post above. I’ve not had a crash in several weeks now. (fingers crossed)

I may actually need to do what you did, I’ve noticed that while I have lessened the amount of instances that my computer shuts down in sleep mode, its not completely fixed, opting to do it once every three-four days instead of every single day. So slightly better but still annoying.

I have noticed that right before I run into this issue, my computer will report that “an unrecognized USB device” has been plugged in and my fingerprint scanner will just refuse to work for signing back in after sleep mode. Then, the next time the computer goes to sleep, it will shut down.

Overall very nice, reliable computer /s. In combination with the DPC_WATCHDOG_VIOLATION blue screens I get, it is getting very hard to recommend this computer to anyone for anything beyond hacktivist activities. Like if you just want a computer to play around with and experiment, sure by all means get a Framework. You want a computer that will actually perform as expected for daily tasks? Nah, get something else.

Yeah, it is my opinion that the fingerprint device/driver is causing the issue. Regarding your USB error, do you know which device it is? The Framework Fingerprint device is USB connected so it’s likely that failing or one of the USB interfaces beneath it.

If you go into Device Manager, select the Framework Fingerprint Reader, and then view devices by connection you can see the full device connection path. On mine it looks like this:
image

Anyway, since I’ve disable this, I’ve not had a single crash. I’ve contacted Support and requested that they provide a driver update but I’ve not heard back anything regarding the status of this.

I’m now at least 99% sure that my problem was a rogue background service (namely tinc vpn) that became active when Windows update woke up the laptop, retried the connection to the server multiple times and eventually crashed the wifi driver.

After I disabled the service I haven’t had a single crash in almost two weeks.

So my conclusion is: we may have at least three different problems in this thread (expansion cards, fingerprint reader, background service). To find out which causes your problem, look through your logs!

I agree, I think there are a few potential issues here with similar characteristics.

In my case, the system crashes and does not even bugcheck. The only way I know that this is happening is when I start my machine, it’s a clean boot. The Event Viewer shows an unexpected shutdown. Beyond that, there is no other evidence which is why this has been so hard to diagnose. My opinion, is that the Fingerprint driver is doing something wrong and the machine hard faults on resume. Again, this is my situation.

During the troubleshooting, I did update my Intel network driver to the latest driver from Intel’s site. Not sure if that will help in your situation @Christian_Kaser but it may be worth exploring. The Intel driver version is slightly ahead of what is available on Windows Update.

In my case, the system crashes and does not even bugcheck. The only way I know that this is happening is when I start my machine, it’s a clean boot. The Event Viewer shows an unexpected shutdown.

Same here. The other log entry was pretty far down and hard to find.

During the troubleshooting, I did update my Intel network driver to the latest driver from Intel’s site.

I updated my driver multiple times and even replaced the card with a non-Intel one so that’s not it.

Having the VPN disabled most of the time isn’t a problem for me though. I mostly use it to access my home stuff when I’m traveling so I can just start it on demand.

Looks like it could be this:

TLDR: Here’s how I got rid of the issue: I send back the laptop and got a refund.

This is not a solution to the shutdown problem. I just want to share what I did in case someone else is considering that option.

I purchased a 12th gen i5 Laptop in 2022 and quickly started experiencing the shutdown issues described in this thread. I got in touch with the support, did what they asked me to do, and at some point, they send me a replacement mainboard. I reinstalled Windows and went through many hours of troubleshooting, just like many other people in this thread.
I also had several other problems:

  • The fingerprint reader stopped working after a while until rebooting the device or disabling and reenabling it in the device manager. A replacement input cover didn’t change anything. I found out that the issue was related to the Thunderbolt dongle I used, so I got a different one which avoided the problem.
  • My storage expansion card and sometimes even the external monitor briefly or permanently disconnected when I inserted a USB device on a different USB port.
  • To solve this problem, the support recommended to install the beta BIOS update. This did not help but added a new issue: When connecting a USB 3 device to a port for the third time in a row, the USB port was somehow disabled and could only be revived by removing and reinserting the USB A expansion card.

As a response to those issues, Framework asked me to send the laptop to a local repair company called “LetMeRepair” here in Germany. A few weeks after shipping the laptop there, I asked how the repair was going. I only got very vague responses. At some point I was informed that the mainboard had been replaced again (that’s the third mainboard for that laptop).

Seven weeks after sending back the laptop, I set a deadline for the repair. Working with the dinosaur of a laptop I used as a replacement was just getting too annoying. Framework only send me another vague response.
This is why, nine weeks after sending back the laptop, I rescinded from the purchasing contract in accordance with § 323 BGB (German Law, this may be helpful if it applies to you: Übersicht: Gewährleistungsrechte des Käufers – LawAndLegal ). I also talked to a lawyer to confirm that my interpretation of the law is correct. Framework accepted my decision by making “an exception from their return policy” because of the “error in return handling” or something like that. Eleven weeks after returning the device, Framework refunded the money.

Needless to say, I am not happy with the way my decision to buy a Framework laptop ended. I still really believe in the idea behind the company, I think right to repair, upgradeability and sustainability are super important, and I liked the laptop, but I was so frustrated with their ignorance towards the problem we have here. This laptop was by far the most expensive thing I’ve bought in my entire life, and I really wanted it to be reliable and last a long time.
And to be clear: I do not blame the local repair company for any of this. Their task was basically impossible to do because it would have required extensive troubleshooting and time-consuming analysis and most likely changes to the software, not just replacing some obviously faulty component.

In case anyone at Framework is reading this and actually wants to change something, here’s what I would have wanted:

  • Take your customers issues seriously.
  • Value my time. I felt like the support agents didn’t care that they took one to two days out of my life every time they told me to reinstall Windows, because I need to set everything up again afterwards. I would have liked to just hand the troubleshooting to them at this point.
  • Keep me updated and send me a replacement device if whatever repair you need to do takes more than two months!

I’m just glad this is over.

3 Likes

That’s rough. I hope whatever laptop you buy as a replacement serves you well. It’s a shame that framework still has issues handling these issues in a satisfying way.

On a more positive note: since I’ve disabled automatic startup for the tinc VPN background service over a month ago, I only had a single unexpected shutdown and that may have just as well been something entirely different.

2 Likes

Just discovered this: https://www.xda-developers.com/amd-chipset-driver-pc-wake-up-from-sleep/
To check your AMD S0i3 Filter Driver version go to C:\Windows\System32\drivers and hover over the ZenProMnf.sys file. Alternatively go to device manager, click view->Devices by driver, then right click oem111.inf (zenpromnf.inf), click properties. The 1.0.0.19 version has fixed this issue.
It looks like the latest Framework driver bundle date is 10/24/23, so they have not pushed this update yet. Due to the large amount of network issues related to this I think this may be the cause. Doesn’t explain the issues on Intel chipsets though.
If you want to try installing the updated driver, try these steps AT YOUR OWN RISK:

  1. Download the full chipset driver package here: https://drivers.amd.com/drivers/amd_chipset_software_6.01.25.342.exe
  2. Open the file, the driver package should then extract, and an installer window will open.
  3. Close the installer window and go to C:\AMD\Chipset_Software\Packages\IODriver\S0i3Filter
  4. Open the AMD-S0i3Filter-Driver.msi to install the driver.

You say shut, you mean sleep. It will sleep for a while, maybe until 5% of the battery is used (default) then power off and hibernate.

That’s the default setup.

I really want to sell my laptop but I can’t due to this ongoing issue which sucks might have to just take the loss.

At least for me, I know it has shut down because all my apps are closed, Chrome reports an unexpected shutdown, and Windows Event Viewer also reports an unexpected shutdown.

2 Likes

I’ve have this issue, got tired of troubleshooting and I just live with it. I’m going to install fedora this month once 40 is released. Not sure if linux users have this issue.

Claiming it’s not “reproducible” and the lack of bios updates on 12th gen is leaving a bad taste in my mouth.

1 Like