Laptop shuts down during sleep

I’ve had the framework gen 12 laptop for a number of weeks now. I’m quite happy overall, but I’m finding that it keeps shutting down when I leave it for more than a couple of hours.

The problem is inconsistent, as well. I’ll open the laptops some mornings and all my apps will still be open, no problem. Other times, it will have to go through the whole reboot process, all my apps will have been closed, etc.

I use the laptop for work and being able to pick things up again quickly is important to me, so this problem is very frustrating. I’ve tried tweaking just about every power plan setting with no luck. Any help is much appreciated.


What OS are you using

I’m running Windows 11

There is a deisgn that after the battery losses 5% it drops to hibernate etc.

Search the forum for more info

Right, but hibernate shouldn’t close all my apps. I’ve even disabled hibernate in the command prompt, but the problem persists. I’ve searched the forum quite a bit and haven’t found anything helpful.


You may like to try terminal commands to assess what is happeing

powercfg /sleepstudy


I have the same issue (complete shutdown of windows - and a corresponding kernel error that power loss was unexpected), not a hibernate. I’ll try the powercfg commands.

Edit: I see the events in that sleep study (abnormal shutdown) following sleep and screen off, but not sure how to debug them further.

Edit2: I looked more carefully at the kernel log and it just has an “OS started” after many hours of nothing, eventually leading to the entry that the last shutdown was unexpected. So this just looks like random power loss?


I’ve seen this issue as well a few times. Mostly was happening when the pc had gone into hibernate but seen it once this week where it lost power while just sleeping. Not sure about cause.


A sequence possibility: Sleep / Suspend → Windows auto update triggers system to wake up → Update system → Shutdown system …maybe?

The usual, look into sleep study, battery report, event viewer…


I’m finding the same thing on my 12th Gen too. Sleepstudy and Event logs both show abnormal shutdown but only clue is lots of these in the System log:

Process C:\Windows\System32\WUDFHost.exe (process ID:1424) reset policy scheme from {381b4222-f694-41f0-9685-ff5bb260df2e} to {381b4222-f694-41f0-9685-ff5bb260df2e}

Did it last night at 21:10 after being in sleep for over 3 hours but most nights it’s fine.
Just tried disabling hibernate and most of the modern standby directed items in the local GP and see if that makes a difference.

Edit: a pox on modern standby and whatever idiots thought it was a good idea to set as the default behaviour!

So it looks like multiple people are experiencing abnormal / abrupt shutdown while in sleep / suspend / modern standby.

Can each of you report to Framework Support so they can collect the relevant information?

@Kieran_Levin, is this something Framework is looking into internally?

1 Like

I encountered an abnormal shutdown today—the timestamps indicate it happened just as I opened the lid and turned on the device.

I own two laptops from another company Len… and both laptops have the same issue with Windows 11. I realized that if I disconect the wifi and put the laptops on airplane mode the laptop will not shutdown during sleep. Moreover, everyone in the company is experiencing the same issue with windows 11.

Yes, windows is getting worst and worst everyday. But you can switch to a Linux kernel.

In conclusion, is not framework fault but windows.


I’ve opened a support ticket about this. So far, they have me updating drivers, with no luck. There are a number of other, somewhat more complicated things that they’ve recommended that I haven’t gotten to yet. I’ll update here if a solution is found.

1 Like

Same problem here.
12th gen base model running Windows 11. SleepStudy shows abnormal shutdown in the logs and all open apps closed. I’m worried about system stability since this occurs so frequently.

It looks like a complete power cut, so not so much a “crash”. Anyway, they had me update drivers which I just did. Beyond that I was sure it happened while plugged-in, unsure while on battery. So they had me remove all expansion cards and leave it on battery to see what happens next.

1 Like

It didn’t shut down overnight with all expansion cards removed and on battery. It also didn’t shut down overnight with all expansion cards removed and AC power provided directly to the internal port. Going to add back cards one by one.


This topic is considered duplicated with this topic:

Please refer to this for more information.
I am not sure how many people, or what percentage have this issue.
The FW Team really needs to dig into it and find out the reason. It is a very annoying issue.

@Benjamin_Woollard You are not alone.
Based on my experience with FW support, they just try to let you swap RAM, update SSD firmware, etc to fix it. I did all of the suggestions and still it cannot be fixed.

Try your best to escalate this issue to let the FW engineer be aware it is the FW laptop problem.

1 Like

I’m still good now with the USB-C cards re-inserted. A few more nights to really narrow it down, but I am so far 100% good with no-non-USC-C expansion cards overnight vs almost every night bad (unexpected power loss) with my USB-A and micro-SD also added.

@jacob_ma They asked me to remove expansion cards and that does indeed appear to be related to the root cause in my case. Did they ask you to do that / have you tried that? Does it happen with all expansion cards removed and left on battery power?

1 Like

For me, the test cycle was very long, sometimes 13 days there was no issue at all, with all expansion cards inserted. Hope you can isolate and figure out which expansion card cause the problem very soon.