Laptop wakes up from suspend on its own

Hello,

After being several hours in sleep mode, the laptop wakes up on its own. When this happens it draws a lot of battery and gets quite warm. This does not happen every time and is more likely to happen, the longer the laptop is in sleep. This happens since I got the laptop in April over several kernel versions and it’s very annoying.
This also happens when the laptop is just sitting on a desk, nothing plugged in and no expansion cards (except 2x USB C) attached. A fresh install didn’t help.
On the bottom you find a journalctl entry.

When it doesn’t happen, the battery draw is only around 0.5%/h.

I hope anyone has an idea how to solve this!

Fedora 36 KDE
Intel i7 1165G7
Kernel: 6.0.7-200
Bios 3.10
sudo grubby --update-kernel=ALL --args="nvme.noacpi=1"
s2idle

Nov 20 09:23:09 fedora kernel: Freezing user space processes ... (elapsed 0.008 seconds) done.
Nov 20 09:23:09 fedora kernel: OOM killer disabled.
Nov 20 09:23:09 fedora kernel: Freezing remaining freezable tasks ... (elapsed 0.000 seconds) 
done.
Nov 20 09:23:09 fedora kernel: printk: Suspending console(s) (use no_console_suspend to debug)
Nov 20 09:23:09 fedora kernel: PM: suspend devices took 0.585 seconds
Nov 20 09:23:09 fedora kernel: ACPI: EC: interrupt blocked
Nov 20 09:23:09 fedora kernel: nvme nvme0: I/O 977 (I/O Cmd) QID 1 timeout, aborting
Nov 20 09:23:09 fedora kernel: nvme nvme0: I/O 916 (I/O Cmd) QID 7 timeout, aborting
Nov 20 09:23:09 fedora kernel: nvme nvme0: I/O 450 QID 2 timeout, completion polled
Nov 20 09:23:09 fedora kernel: ACPI: EC: interrupt unblocked
Nov 20 09:23:09 fedora kernel: nvme nvme0: Abort status: 0x0
Nov 20 09:23:09 fedora kernel: nvme nvme0: Abort status: 0x0
Nov 20 09:23:09 fedora kernel: PM: resume devices took 0.283 seconds
Nov 20 09:23:09 fedora kernel: OOM killer enabled.
Nov 20 09:23:09 fedora kernel: Restarting tasks ... done.
Nov 20 09:23:09 fedora kernel: random: crng reseeded on system resumption
Nov 20 09:23:09 fedora kernel: PM: suspend exit
Nov 20 09:23:09 fedora kernel: mei_hdcp 0000:00:16.0-b638ab7e-94e2-4ea2-a552-d1c54b627f04: bou
nd 0000:00:02.0 (ops i915_hdcp_component_ops [i915])
Nov 20 09:23:09 fedora kernel: mei_pxp 0000:00:16.0-fbf6fcf1-96cf-4e2e-a6a6-1bab8cbe36b1: boun
d 0000:00:02.0 (ops i915_pxp_tee_component_ops [i915])
Nov 20 09:23:09 fedora rtkit-daemon[1218]: The canary thread is apparently starving. Taking ac
tion.
Nov 20 09:23:09 fedora systemd-resolved[1163]: Clock change detected. Flushing caches.
Nov 20 09:23:09 fedora flatpak[2471]: 09:23:09.766 [JavaFX Application Thread] WARN  o.cryptom
ator.ui.fxapp.UpdateChecker - Error checking for updates
Nov 20 09:23:09 fedora flatpak[2471]: java.net.ConnectException: null
Nov 20 09:23:09 fedora flatpak[2471]:         at java.net.http/jdk.internal.net.http.HttpClien
tImpl.send(Unknown Source)
Nov 20 09:23:09 fedora flatpak[2471]:         at java.net.http/jdk.internal.net.http.HttpClien
tFacade.send(Unknown Source)
Nov 20 09:23:09 fedora flatpak[2471]:         at org.cryptomator.desktop@1.6.15/org.cryptomato
r.ui.fxapp.UpdateCheckerTask.call(UpdateCheckerTask.java:41)
Nov 20 09:23:09 fedora flatpak[2471]:         at org.cryptomator.desktop@1.6.15/org.cryptomato
r.ui.fxapp.UpdateCheckerTask.call(UpdateCheckerTask.java:22)
Nov 20 09:23:09 fedora flatpak[2471]:         at javafx.graphics@18.0.2/javafx.concurrent.Task
$TaskCallable.call(Task.java:1426)
Nov 20 09:23:09 fedora flatpak[2471]:         at java.base/java.util.concurrent.FutureTask.run
(Unknown Source)
Nov 20 09:23:09 fedora flatpak[2471]:         at javafx.graphics@18.0.2/javafx.concurrent.Serv
ice.lambda$executeTask$6(Service.java:727)
Nov 20 09:23:09 fedora flatpak[2471]:         at java.base/java.security.AccessController.doPr
ivileged(Unknown Source)
Nov 20 09:23:09 fedora flatpak[2471]:         at javafx.graphics@18.0.2/javafx.concurrent.Serv
ice.lambda$executeTask$7(Service.java:726)
Nov 20 09:23:09 fedora flatpak[2471]:         at java.base/java.util.concurrent.ThreadPoolExec
utor.runWorker(Unknown Source)
Nov 20 09:23:09 fedora flatpak[2471]:         at java.base/java.util.concurrent.ThreadPoolExec
utor$Worker.run(Unknown Source)
Nov 20 09:23:09 fedora flatpak[2471]:         at java.base/java.lang.Thread.run(Unknown Source
)
Nov 20 09:23:09 fedora flatpak[2471]: Caused by: java.net.ConnectException: null

Just to confirm, your s2idle is set to deep, correct?

The suspend settings can be either set to s2idle or deep, and I am using s2idle.