[RESPONDED] Laptop sometimes won't wake from sleep (Kubuntu 22.04.4 LTS)

I am using Kubuntu 22.04.4 LTS with the 6.5.0-1020-oem Kernel, Plasma 5.24.7 and X11. Secure Boot is enabled for some reason.
Sometimes, when putting the laptop to sleep, it will not properly wake again. The integrated display as well as any connected external displays stay off, the power button, however, is permanently lit as if the laptop was turned on.
The only way I have found to recover from this state is to reboot. Sometimes, simply pressing the power button will reboot (with a shutdown animation on screen), sometimes a hard reboot has to be performed.
I have not been able to find a way to reliably reproduce this issue. However, it only happens when the laptop stays in sleep for a somewhat extended period of time (i.e., > 10 min).
I have followed the installation instructions for Ubuntu 22.04 and not changed any low-level settings. This issue has also happened on a completely fresh install of Kubuntu. For troubleshooting, I have reset the BIOS.

The only other indication of any issues that I have is an error message when booting:
cros_ec_lpcs cros_ec_lpcs.0: EC ID not detected.

Any help would be greatly appreciated as this is very annoying :slight_smile:

Moved your thread to Linux subcategory for better visibility.

Im having a similar problem on my Framework 16. Im using Fedora 40 stable (did it on the beta as well and I did a clean install between both)
Most of the time when the laptop goes to sleep, it works fine, but every now and then when it goes to sleep and I try and wake it up, nothing happens and the power button pulses on and off. Only way to get it to turn on again is to hold the button till the system reboots.

These reports are similar to point #4 in this message of mine:

That being said, I have not encountered that issue since two weeks ago.

Yup, that post and the one below that was also from you are pretty much exactly whats happening to me as well. Doing a bios update seemed to help it. It went from happening every single time, to every now and then, and the logs from journalctl didn’t help at all either.

Unfortunately, I have already upgraded my BIOS to the latest version. Journalctl also lists errors (most pertaining to amdgpu, the journal now seems to be overwritten though).

EDIT: I have since been able to reproduce the errors in journalctl. Note that this happened when trying to enter sleep, not when trying to wake - the amdgpu errors, however, are the same as when failing to correctly wake from sleep.

For AMD users (FW16 for example)

Please run this script.

  • Download, run with:

sudo python3 amd_s2idle.py

Paste output back here. I have not had any issues waking up FW16 from suspend. Please run the script after the next occurrence, paste results here in a reply.

Also include all devices attached (displays with how they are attached in detail, docks, other peripherals)

Additionally, we do not test against KDE, so it’s not impossible there is correlation there - not something I’ve seen with KDE on Fedora, but we have seen it with other distros using KDE.

I told it to run 10 times as it doesn’t happen every single time, but it happened on the first run. Laptop is plugged into the 180w charger. Nothing else is connected.
Running Fedora 40 KDE (stable)

Thanks for your reply! This is from a run I just did in which the laptop failed to suspend. It failed to wake from sleep a few minutes earlier.
I don’t know why my kernel is flagged as tainted. The solution suggested by the script does not work, as ryzen_smu is not installed or loaded. I have tried re-installing the Framework kernel, this also did not resolve the ‘tainted’ warning.
For running this script, I have removed all expansion cards and am using only the integrated display, keyboard (and numpad) and touchpad.
The interesting thing I have noticed while running this script repeatedly is that the laptop only seems to fail suspending when applications (with a gui) run in the background. The only applications I have identified so far that can run without causing problems are Konsole, VLC and Google Chrome.

Since my last reply, I have upgraded to Kubuntu 24.04 and the 6.8.0-31-generic kernel. As far as I can tell after one day of use, this has solved my issues and does not produce any amdgpu errors in the journal.

Im still having the issue unfortunatly. Im on kernal version 6.8.7-300 stock fedora

@Conan_Kudo is this something you’ve experienced with Fedora 40 KDE by chance? This customer’s s2idle report is above.

1 Like

I didn’t observe this issue back when I had my laptop configured to sleep (right now it doesn’t do that as it sits docked all the time these days). I’m away from my Framework 16, so I can’t switch it back to do sleep and see what happens.

1 Like