Laptop won't power on unless i plug in AC power

The BIOS is the cause of this, update to 3.07.

1 Like

Thanks for all replies. I’ll checkout the links and troubleshoot tomorrow, I’m burnt for the day.

I upgraded the bios to 3.07 successfully, then “loaded optimal defaults”. This didn’t fix the problem. I opened the case and tested the CMOS battery with a multimeter; it’s sitting on 1.5 volts, where it’s rated for 3 volts. I assume that’s the issue? I find it rather odd that the system won’t even boot from a fully charged battery just because the CMOS battery is dead (assuming that’s the issue).

I check the CMOS battery socket on the motherboard, and it feels/looks solidly connected to the pcb.

As a further diagnostic stop, I pulled the RTC battery and disconnected the power battery. After waiting for several minutes, I put the RTC battery back in, then reconnected the power battery. The main board immediately started flashing red LEDs on both installed USB-C modules and then they went out after several flashing cycles. I hit the power switch and now the system powers on from battery with no AC attached. I’ll keep an eye on the system and use it regularly over the next several day and see how it behaves.

1 Like

So the issue seems to be that if you let the laptop sit for about a month, the RTC battery will run down to less than half its rated voltage, which causes the system to act dead if you try to boot from battery. I’ve had many laptops over the years, some of which have sat for multiple months untouched, only to boot up just fine from battery. Case in point: I have an old mid-2015 Macbook Pro that’s been sitting unused in my closet for 3 months, and it just booted up from battery with no problems. Note that all the other laptops I’ver ever had used a standard CR2032 coin cell RTC battery, and not a rechargeable battery. This seems to be a hardware/firmware/design issue that’s a real deal breaker for me unless something is done to fix the issue. A system should not act dead when it has full battery power, but a dead/low-voltage RTC battery. It should boot up just fine, with the wrong date/time, granted, but it should boot.

So why does the RTC battery drain down to half it’s rated voltage in just one month of sitting idle?

1 Like

I have the same problem. Contacted the support and they ask me to do an RTC battery reset, it worked for a short while but eventually I couldn’t power on again. Then I read that it was the BIOS that caused this. Updated to 3.07. Still doesn’t help. Have you managed to solve the problem? @Stephen_Manis

Oh no! I am sorry to hear that you are facing the same issue, Wee. Please reach back out to our support team as we would love to help you resolve this :orange_heart:

I am having a similar problem too. It seems relatively recent. It happens when the laptop is not used for several days. Plugging it in allows the power button to light up and boot when pressed. I haven’t updated BIOS. I’ll keep watching this thread for info that may come in on this. After booting, the unit will boot without plugging it in until I leave it set again for several days.

After assembly the laptop will run from battery alone but will not boot from battery without mains being attached first, even if only briefly. ie. i can attach the laptop to AC and then diconnect and as long as i try to boot immediately it will start, otherwise it refuses to boot. When the laptop has to boot with the AC attached, it also has a longer boot time as if it is doing a memory test etc as it did when i first booted the laptop after build.

Has anyone else had this symptom? or has anyone have any idea of what i should look for?

Any input would be greatly appreciated

Dave

That’s intended behaviour. The laptop is shipped with the battery disconnected (not physically but a soft switch in the BIOS) and it must have the AC connected to reset this switch and boot.

Then there will be memory training on first boot, which may take a minute or two.

2 Likes

Well done Fraoch, Much appreciated. The next task is how do i get ot of it. The battery has been fully charged three times and the condition is still present. Do i have to go into bios and if so what do i do. It can run completely from the battery as it is, but it won’t boot from it. Surely something else needs to be done.

You’ve put my mind at rest, so thanks for your help. Do you know what to do next.

I would be thankful for any suggestions.

Dave

1 Like

No that’s not normal. I’ve seen this on the forums once or twice though.

Normally you shouldn’t have to do this, but try resetting the mainboard:

Just be very careful with the RTC battery holder - it’s fragile. Pop out the battery with a pin like the article describes.

1 Like

@David_Ian_Henderson please submit a request through the support form: Framework | Support

This may need a mainboard replacement.

2 Likes

Thanks nrp, i’ve already submitted two requests (without answer up till now), so perhaps i need to follow your advice Fraoch, for the time being. I mean if it does need a new main board there isn’t much to lose, and the whole point of buying a framework is to attempt things yourself. What’s annoying is it runs so well off both battery and Ac… it just won’t boot from ac. Did notice an option i bios to recognise battery but it wont let me change that option. I was wondering is there some kind of security measure i need to make in bios to allow me to make changes. Or am i barking up the wrong tree?

Anyway guys, thanks so much for your help. i will persevere until i hear from support.

Dave

Hi… Me again Fraoch, have just completed the reseting the mainboard state. Wasn’t too tragic although my button cell holder lifts up when you try to lever out cell so i had to put my finger on it to hold it down. Wondered if this could be my problem but as soon as i put the cell back (step 8) the red flashing started (so it must be getting power from cell as main battery was disconnected and mains disconnected at this point). Guidance suggests that the flashing should start when mains was attached with no button cell and no main battery and it was flashing (all good Step 7), but mine was flashing immediately the button cell was replaced as well (step 8) although there is no mention of this in the guide.

I only mention this as you seem quite familliar with the process so perhaps it might make you aware of anything else there may be wrong.

Anyway all running as it was before (i’m using it now as the instructions suggest you can keep using the pc). It’s Just about waiting 24 hrs with ac attached now. I will let you know what happens. In the meantime thanks again for your help it is greatly appreciated.

Dave

I’m not too familiar with the process and have never done it myself, but I have seen where it’s solved one or two similar issues on this forum.

However if Nirav (founder and CEO) suspects it might be the mainboard, I would go with his advice!

It sounds like nothing has changed. It was worth a shot.

Hi David, when you say the cell holder, are you referring to the battery slot that is attached to the motherboard? Take a look at this thread, I had a similar issue and it was due to the battery holder not properly soldered into the board. I got a replacement board.

Hi Kimo, my botton battery holder lifted up as you push down on the pin. It had no resistance it just rocked on the edge it was levered from. Personally i dont think that is my problem as when i did a reset, there was no battery and no mains attached and when i put in the button cell i immediately got the flashin red lights, i then carefully tried to carefully wiggle the button cell but the red lights stayed flashing. if i was to guess i would say my issue was more than likely it came unglued rather than unsoldered as i would have expected no power from the board.

My problem has not been resolved and nrp suggested i may need a new board as well. I’ll have to inform support again.

Thanks to all who tried to help, i’ll be back in touch when i struggle with the next one.

I’ts a lovely machine though and so fast and light. i will hate having to wait for a repair.

Anyway all the best to you all and thanks for trying

Dave

For anyone who’s following my problem is solved but not fixed (asofyet). It turned out to be the button battery holder. I know i said it appeared to work before but i must have pressed it into connection when putting the battery back in.

Anyway, i booted with the case open and held the battery down and all works fine. It did one boot with memory check (green lights) and when i rebooted (all from internal battery only) it restarted without memory check (well faster anyway ). i then placed a small rubber grommit on top of battery so the case holds battery down and all is working.

Clearly i can’t operate it like this as i could be putting the board under stress. However, this one problem has been solved. Support will be informed and hopefully there will be a more permanent fix. I’ll try and attach a video to this message (not sure if i can or if it will work) if there is no video attached then i failed.

Dave

Attached is a still i couldn’t get a video format that worked