Laptop won't power on unless i plug in AC power

Hi David, when you say the cell holder, are you referring to the battery slot that is attached to the motherboard? Take a look at this thread, I had a similar issue and it was due to the battery holder not properly soldered into the board. I got a replacement board.

Hi Kimo, my botton battery holder lifted up as you push down on the pin. It had no resistance it just rocked on the edge it was levered from. Personally i dont think that is my problem as when i did a reset, there was no battery and no mains attached and when i put in the button cell i immediately got the flashin red lights, i then carefully tried to carefully wiggle the button cell but the red lights stayed flashing. if i was to guess i would say my issue was more than likely it came unglued rather than unsoldered as i would have expected no power from the board.

My problem has not been resolved and nrp suggested i may need a new board as well. I’ll have to inform support again.

Thanks to all who tried to help, i’ll be back in touch when i struggle with the next one.

I’ts a lovely machine though and so fast and light. i will hate having to wait for a repair.

Anyway all the best to you all and thanks for trying


For anyone who’s following my problem is solved but not fixed (asofyet). It turned out to be the button battery holder. I know i said it appeared to work before but i must have pressed it into connection when putting the battery back in.

Anyway, i booted with the case open and held the battery down and all works fine. It did one boot with memory check (green lights) and when i rebooted (all from internal battery only) it restarted without memory check (well faster anyway ). i then placed a small rubber grommit on top of battery so the case holds battery down and all is working.

Clearly i can’t operate it like this as i could be putting the board under stress. However, this one problem has been solved. Support will be informed and hopefully there will be a more permanent fix. I’ll try and attach a video to this message (not sure if i can or if it will work) if there is no video attached then i failed.


Attached is a still i couldn’t get a video format that worked

I have a batch 6 or 7 (I forgot) and today was the first time it’s happened to me.

I too am having this issue (batch 8) it’s been like it since delivery. My coin cell battery holder seems to be suitably fixed in place but for whatever reason I can’t power the laptop on without having AC power connected. I’m on BIOS version 3.07 and using PopOS.

Trying to power the device on with no charger connected the laptop does not respond, regardless of battery charge level. When the charger is plugged in it turns on right away although the boot time seems a little long (I haven’t been able to identify whether it’s doing the memory check every time) and the LEDs on the chassis flash green.

I have logged a suport ticket and tried both resetting the mainboard and giving the RTC battery a charge by leaving the laptop on charge for 24 hours. Neither of these steps has changed the behaviour.

That sounds just like my issue, What appears to happen is if the button cell is not charged enough and not connected, regardless of how well the main battery is charged, the laptop will assume it is booting for the first time.

With me, if i attached the mains lead briefly, without switching it on, and then disconnected the mains and powered on immediately afterwards then it would boot. But left any reasonable time off the mains would be treated as a full memory check (long booting sequence)

Thats why in my example i held the button battery down when switching off and on again, i would assume its because the button cell hasn’t had a chance to charge.
That’s my assumption anyway.

1 Like

I had this issue as well. I had to physically unplug the main battery, reseat the RTC battery, plug the main battery back in, connect AC, and let it sit overnight to fully charge the RTC battery. After that, it would work normally, where I later installed the 3.07 bios and it fixed this issue. I’m still suffering from the “high battery drain when powered off” problem, but the upcoming 3.08 bios is supposed to cure/help with that.

1 Like

I posted having the problem. Turned out my BIOS was 3.02. I updated to 3.07 and stopped having the problem. I got the computer in July 2021 and didn’t see the problem until recently. But 3.07 seems to have fixed it for me.

Edit: 4/6/22 - I am having the problem again where I have to plug in to boot. I did install a new version of Linux Mint and wonder if that has something to do with it.


I am having this problem as well. I just bought my framework laptop, DIY edition. The Input cover I received was damaged in shipping, so I had to wait for a new one to use the laptop. I received it yesterday, May 26, 2022, and the laptop mostly works fine. But it wont turn on unless its plugged into the AC Power Cord. Once its turned on, it works fine, I can unplug it, and so long as I don’t shut it off, it stays powered on.

This is kind of frustrating. I made sure i have the 3.07 BIOS on it, I actually updated it before I even realized I had the problem, yet here I am. Has anyone found a fix for this with the newer batches? I received the laptop on May 12, 2022.

I had to do this:

  1. Remove the CMOS battery.
  2. Unplug the laptop battery and wait for 60 seconds.
  3. Reinstall the CMOS battery.
  4. Plug the laptop battery back in.
  5. Attach AC power and let it charge overnight.

This sort of resets everything and gives the rechargeable CMOS battery time to get back up to 3+ volts. The whole problem here was that if the CMOS battery voltage drops low enough, it won’t recharge, regardless of the laptop’s battery level and/or AC adapter being plugged in. Why they don’t just use a standard CR2032 CMOS battery, I don’t know…

1 Like

I absolutely agree, I’ve had to go through this rediculous ritual several times now, because the RTC battery has discharged. At some point something is bound to break. This RTC battery issue is definitely a design flaw. New updated boards should be given to those of us that find this a real problem. After all, why should we pay for a new motherboard, just to get a system that works the way it should? An official reply should also be forthcoming. For instance, is it possible to completely fix this issue on current mainboards or is it not possible to fix? Also, is it guaranteed fixed on 12th gen boards?


No, the RTC battery clip is perfectly fine, you just have to use the right technique. Some boards had too little solder but that is a completely different story.

1 Like

Have you contacted support properly about this, making a complaint here, when it seems so important to you, may serve you well :frowning:


I haven’t contacted support, because it seems to be a well known issue. There have been acknowledgments, but, no definitive answers. I’m not the only one affected by this problem, which is why I think there should be a response in the forums laying out the issue in detail and the chances of a complete fix or not.

There is an issue with depleted RTC/BIOS batteries being discharged on receipt but there is a guide to remedying that.

If if happens repeatedly there would appear to be a problem that isn’t so common. Well known to some on the forum but is there any reason to think Framework have that under consideration?

I’ve found this topic (and seen others) since it’s also affecting me. I’ve used my laptop every few days since I got it a few months back (batch 8 - so assuming BIOS 3.07) and have just come across this issue. The laptop wouldn’t power on until I plugged in the AC cable, then there was a long green light, then orange, then a pulsing green light as it powered on. I’ve not always had it plugged into the charger when using it since I’ve not had to - the main battery performance has been excellent - but I’ve never let the main battery level get below 50% or so.

This problem regarding the RTC battery is unacceptable however. Every time it happens I have to correct the system time manually (since the BIOS hasn’t retained it) and my custom BIOS settings are lost. I shouldn’t have to be plugging the laptop in overnight every few weeks just to make sure the RTC battery retains charge. I absolutely should not be having to open the laptop and internally disconnect the battery routinely. I don’t even know whether there’s any indicator that the RTC battery is properly retaining charge - is there one?


Yes. I read a post from nrp stating that this problem was resolved with 12th gen boards, but, I can’t find that post now. I was just perusing the forums and didn’t make a note of where it was. I had already decided to buy another framework, but, I’d like the one I have to function correctly. Otherwise it means buying a new board to solve the issue with my existing framework. Which is what I’ll do if I have to, although, it obviously, won’t make me happy. Even if they offered to swap the boards at a reduced price would be something.

Welcome to the forum

I also have a batch 8 but had to update the BIOS manually to get 3.07

Wow! You only plug in less than every few weeks generally.

Whereas I don’t keep mine plugged in overnight, regularly I use it whilst plugged in.

For the first couple of months I just let it run down and charged it, which meant every other day at least.

So I don’t see how the RTP/BIOS battery would have a chance to discharge to such a degree.

But I will be careful in removing it if I have to.

The laptop was designed not to power on the first time until plugged in. That’s in the basic instructions ??

The Framework Laptop ships in a mode where the battery is disabled until power is first plugged in, so you really do have to plug in power at this step!
Framework Laptop 13 Pre-Built Quick Start Guide - Framework Guides