Left arrow and F9 keys stop working

Like the title says, my F9 and left arrow keys will randomly stop working. Its always both of them at the same time. I’ve tried reboots and removing/reseating the keyboard as well as reseating the ribbon cables on the back of the keyboard. The keys will eventually start working again, until they decide to take another break.

I’m running Fedora 40 if that matters.

Have you reseated the Mid plate? This intermittent connection sounds like the Mid plate isn’t completely flat and is not making a great connection with the keyboard.

I’ve removed and reinstalled the mid plate and both keys are working now. The question is will they stay working? I’ll wait a week or two before I call this solved.

That didn’t take long. They’ve already stopped working again.

I think I may have figured it out, the tab that sticks out from the bottom left of the keyboard was bent upwards slightly, I straightened it out a bit, and the keyboard has been working for a couple hours now.


And they stopped working again. Time to reach out to support.