Linux users: Use kernel >=5.13.10 to avoid WFi/BT issues

Possibly https://bugzilla.kernel.org/show_bug.cgi?id=213829

2 Likes

I assume a cold boot is also performed directly after a linux kernel upgrade? Might be why its working for me

Just tried a cold boot after upgrade, still no luck.

The only other thing I did pertaining to bluetooth was install bluez and bluez-utils , enable the bluetooth service, and try toggling bluetooth off and on, on the newest kernel. The only bios option I changed was legacy ps2 emulation to disabled but I doubt that has any effect.

1 Like

@Anthony_Powell did you install bluez-utils or bluez-utils-compat? I have the latter installed, I wonder if that’s my problem? I installed it as the regular utils didn’t seem to work, but now I might switch and see what happens.

Non compat afaik. I just did what the arch wiki suggested

Hey! I finally got it working this morning. I installed 5.13.8-arch1-1, replaced bluez-utils-compat with bluez-utils, and also removed setting the autosuspend kernel parameter to 0 and now it works!

3 Likes

@mbernhard what is this kernel parameter / what does it do?

I had set btusb.enable_autosuspend=0 as a kernel param following some advice here: https://bugzilla.redhat.com/show_bug.cgi?id=1589548

1 Like

Welp, nope. I’m still periodically having this problem. After wake up I have no bluetooth. Weird.

Reverting back to 5.12.15 fixes it reliably.

Strange, I’ve been running this for a while without issues. I do have to manually reconnect to my mouse or make it enter pairing mode briefly for it to connect again but I assumed that was an issue with my mouse

Yeah, after wake from sleep, bluetoothctl shows no device and GNOME offers me the option “Bluetooth Off: Turn off”. I’m too tired today to dig more, but I’ll try to tomorrow.

This is possibly fixed.

I’m running kernel version 5.13.7-200 and I have full WiFi and Bluetooth support. Tested using a Bluetooth headset. No latency or quality issues noted.

As a note, I did manually install the driver for this card as noted in [Guide] Install Intel Wireless Drivers on Linux.

Would someone be willing to try updating to help confirm this?

It seems finally fixed. 5.13.10 seemed to do the trick.

Edit: nope. After several reboot, somehow, I’m back to where I was.

Ah, I can finally confirm it’s the cold boot/warm boot problem noted here: https://bugzilla.kernel.org/show_bug.cgi?id=213829

3 Likes

Besides being up to date, I’ve made no changes to my system, running 5.13.12-200.fc34.x86_64 (Fedora 34 Workstation) and haven’t noticed a single bluetooth issue.

Anyone running 5.14 yet? I’m tempted to build out a kernel just for kicks to see how it’s doing, but if there’s known breakage I might not bother just yet… :slight_smile:

I tried 5.14 on ElementaryOS 6, and WiFi/Bluetooth seemed to work fine but for me Sleep was broken. For the time being I went back to 5.13.13

@mbernhard if the issue is resolved, consider appending to the title of this thread to note the version # in which it was resolved, to save others’ time.

1 Like

Running 5.14.7 on Solus 4.3 here and everything’s working well. I had disappearing bluetooth issues with 5.13 but it’s been solid since updating.